Installing Home Assistant Supervised using Debian 12

Why did you post a screenshot showing various Raspberry Pi OS images if you installed Debian Bullseye?

To configure network interfaces in Home Assistant, go to Settings > System > Network > Configure network interfaces.


Since I had RPI imager installed I could easily printkey it and I figured I could rule them ALL Debian versions by RaspPI out that I had tried and failed to install to get a proper supervised version install after having tried them all but was getting errors (os-agent and such) that I could not resolve with latest upgrade at the time.

Peyanski article for Supervisor install

Since then I have got a whole house generator which I want to monitor from HA. That is why I asked if you know how to disable onboard wifi from within Debian. I have this external USB antenna


and was going to use nmtui so that I could have ethernet connections to 192.168.2.x for HA based and also connect to for wifi to monitor the generator.

I don’t want to disable wifi within HA as I still want to connect using USB antenna. Do you know Debian well enough to disable the wifi chip from in it. Does not seem to be a cmdline.txt file in boot folder to add dtoverlay=disable-wifi

No. Derivatives of Debian can have different utilities and that’s an example of one.

That’s available on Debian. What was the result after you tried it?

1 Like


When I first went into it did not show any WIFI connections just my ethernet connection to my home network 192.168.2.x. So, I added my connection to and saved it. When I went to activate it, it only now showed my home WIFI SSID (which I did not add) but not the generator WIFI connection. I see it when I want to edit connections but not when I want to activate it. I am hoping it I can disable the wifi on the PI in Debian so that things might clear up.

Raspberry pi os (or Raspbian) is not Debian 11 (the only supported os for a supervised install). If that’s the OS you installed then you are running a derivative of Debian, not Debian. Which means you aren’t actually following this guide. Instead you are running an unsupported install and (unsurprisingly) running into issues.

Additionally if you are using a raspberry pi then you’re in the wrong place. As the instructions state there is a separate guide for raspberry pi.

The other guide starts by telling you exactly which image to install. And you’ll notice it never once shows the rpi imager because none of the images in that tool will work here.


…and don’t forget to read (but not only skim through) at least Section 1.6 of

How to help us help you - or How to ask a good question

which you can find within the very first pinned thread of the forum :wink:

1 Like

Unsupported OS now blocked during installation.


The apt-get install is missing apparmor and lsb-release. See GitHub - home-assistant/supervised-installer: Installer for a generic Linux system

apt-get install \
apparmor \
jq \
wget \
curl \
udisks2 \
libglib2.0-bin \
network-manager \
dbus \
lsb-release \
systemd-journal-remote -y

Probably because those are installed by default on Debian 11

lsb-release was, but not apparmor. I just followed this guide, but installed the latest standard Debian 11 release.


I have just installed HA-Supervised on debian 11. Thanks to the instructions was simple and worked like charme. Thanks for this!
However, after install, all my docker containers were gone and only the home-assistant ones were left :frowning: I was able to track this down to the fact that the Home-Assistant installation comes with an own /etc/docker/daemon.json and one very relevant input in mine was missing:

"data-root": "/srv/dev-disk-by-id-ata-xx/docker-container",

Can I just manually add this, or would this be overwritten?

And a second question:
Since I installed, I cannot reach any services anymore that I had on this server from the internet:

  • Wireguard Server
  • Nginx Reverse-Proxy

What could be the reason?

Best regards,

I’ve followed this guide step by step and the services are running but I can’t log in to the web service. I use my machine IP and port 8123 (the same that was displayed after the successful installation).
I’ve installed it on Debian 11. The device is Odyssey X86J4125800 with CPU Intel Celeron J4125.
Both agent and supervisor services are running. However, I can’t access the web service. I also noticed that the network on my device stopped working. I tried to grab a new os agent from GitHub but I can’t access the internet on the device. The device is connected via cable to the router. Any idea how can I restore the internet and access the web service?

lsb-release was missing from (install made yesterday)

This was key to get a Supervised install in a Proxmox LXC container. Although it will be unsupported, I just wanted to have a look at this kind of install. So far so good!

I really like the OS virtualization of LXC containers vs HW virtualization of VMs.
I’m trying both at this moment as I’ve had the HAOS VM running for more than a year already under Unraid.

How lame to block unsupported install just because some people aren’t following bug reporting rules. Not cool.


This has been coming for a very long time, move on.


You understand I’m just a HA user who tries to help others by writing guides and had nothing to do with that decision, right?

This is an install guide, if you want to vent to Devs, start a new topic or head to Github.


I’ll be sure to do that. I confused you with the maintainer. My apologies kind sir. (I’ve removed my sarcastic reply)

install it at a j1900 pc. work very well! thank you!

Great work!! Thanks a lot!
Can you update link for Debian image with firmware?
this is it