Installing Home Assistant Supervised using Debian 12

Running other containers alongside home assistant which aren’t addons isn’t supported in a supervised install. If you want to run other things which aren’t addons then you should be using container not supervised.


Might also be worth looking at spinning up a HA OS VM.

Hi there,

I have installed as per instructions the HA Supervisor - which didn’t show any errors - but when trying the ‘ha’ command line - complains about the hassio CLI missing - I’ve checked docker - and see only the supervisor container was created. At what stage do the other containers get created?

The output on terminal said it would be listening on IP:8123 but of course no container = no response, nothings listening.

Its hard to find out how or when these containers get created?

Platform: Intel NUC (ASUS VivoStick) running Debian 11.

1 Like

So upgrading HA broke my old Buster Raspbian installation :-<

I’m TRYING to install Debian Bullseye on my RaspberryPi 3b.

Connected a keyboard, mouse, screen, network cable to my Pi.

I first used Bullseye image 2022.01.21 for my 3b here Raspberry Pi Debian images and used BalenaEtcher. Booted up to a login prompt. Entered root without password and I’m in. Great! Nope. I get no network. ifconfig? Command not found. /etc/network/interface not there, /etc/netplan? Not there either. /etc/dhcpcd.conf? Not there either! But I do have a /etc/dhcp.d directory! That’s a flop!

So, scrap that. I’ll follow the instruction here, got the debian-live-11.3.0-amd64-standard iso file and rufus. Used it to flash my MCHD card. Kept the default options (BalenaEtcher is much easier to use) Got some weird message about needed to download something before it can flash (sys… something). Once done, I put the card back in the Pi and… nothing. Screen remains blank, no boot

Kinda frustrated at this point. Raspbian was so much easier to use. Just put wpa_supplicant and ssh file in the boot directory and off you go!

Anybody want to venture helping me why I can’t get the 3b to successfully boot with a frickin network??? If I put the original MCSD card in, it boots (DHCP) and I have a network connection. Why is it so hard with Debian???



So I went and installed Raspberry OS 64 bit (2022-04-04-raspios-bullseye-arm64-lite.img.xz) from Operating system images – Raspberry Pi

All went well until I installed

dpkg -i os-agent_1.2.2_linux_x86_64.deb

Got this for answer:

dpkg: error processing archive os-agent_1.2.2_linux_x86_64.deb (--install):
 package architecture (amd64) does not match system (arm64)
Errors were encountered while processing:

Another dead end :face_with_symbols_over_mouth:

So, I’m up for any help here because I’ve reached the end of what I know what to do to get that thing working :frowning_face:

Obviously you need the arm64-package which is this one.

You are in the wrong thread anyway. As for your RaspberryPi 3b this is the correct thread.

1 Like

Thanks. Yes, I should have read more than just the title and jumping right into the installation. Maybe the title should be changed to “… on a x86_64 with Debian 11”, like it says for the RaspberryPi?

Or just read it a little more closely :wink:

No mention of a Raspberry Pi being used anywhere in the guide. The Debian installation process is completely different on a Pi to an x86 machine, so the entirety of ‘Section 1’ should have given you a hint also.

Hopefully you have better luck with the Pi guide :+1:

1 Like

Yeah, I said that already, but the title is still confusing. Wouldn’t hurt to make it more obvious.

how to change data folder location from /usr/share/hassio to /home/user/hassio
please guide

how did you change data folder?

Supervised-installer breaks network on Debian 11.3 · Issue #217 · home-assistant/supervised-installer (

1 Like

I have been running HA Supervisor for over 5yrs and I decided to update Debain10 to Debain11 which didn’t go well, but it’s up and running now.
So I installed HA Supervisor and followed the steps outline here, but could not get Docker install as outlined above so I googled how and got it running. I got HA Supervisor running. Now I need to get my backup back. Can someone please tell me where are the HA file located in Debain11 and running Docker? A big thanks

The more permanent work around I have found to get it working on Debian 11.3 is to use the following command: nmcli connection modify “Supervisor IFNAMEHERE” connection.autoconnect yes
Make sure you change IFNAMEHERE to your actual interface name, you can get it by typing nmcli connection. Alternatively you can run nmtui and enable autoconnect using the GUI.

So I understand this, does that mean node red does not run well inside home assistant in a container, in bullseye?

No? Node red runs fine.

If you’re doing a supervised install you should install the addon for it and let supervisor setup and manage the docker container. You should not create and start a container yourself from a node red public image using the docker cli or docker compose.

In a docker install do the opposite. There’s no supervisor so there’s no addons. If you want node red then find a public image (or build one) and create and start a container from it yourself.

I think I understand😅
I am having trouble installing some nodes in node red.
One for sure is Govee bt.
It gave me some python errors then npm errors.
I had all this node red working on a rpi3b.
Then started down the home assistant rabbit hole.
Ending with a nuc running bullseye and going to get the nuc to manage the node red things also.

I won’t do it, but it seems I could install node red in root of bullseye and in home assistant.

I have node red up and running with a simple MQTT flow in home assistant/node red so I know it works.
Thanks for the help.

1 Like

Hi folks!

I used this method without any issues. And HA worked great. Until one day when it started to give me some weird errors. Maybe they are not related to what I am about to tell you later on. But just in case. The error I got was the following while trying to update HA and addons inside of HA: ‘AddonManager.update’ blocked from execution, system is not healthy>>

Anyway I decided to reinstall everything from scratch. So I did a fresh reinstall of Debian 11 and followed the rest of the steps, including the ones is Section 3, my ethernet connection stopped working. I pinged the pc HA is running on and it gives me time out. I don’t believe I have an IP Address anymore for the ethernet card.

I executed the commands via ssh so for sure everything was working until the last step 3.1

BTW, when I physically type ha core check, I get Error: Can’t execute command. Details in the attached pic.

I tried the process to reinstall Debian 11 and then HA 2 times. Any idea what I am doing wrong? Or it’s not working anymore? Thank you!

I just saw there is a bug present which breaks the network.
I saw there is a solution.

Enabling “Automatically connect” with nmtui seems to fix this issue.

Newbie here. What does that mean? What exactly should I do? What command should I send?

LE: I found this 16.04 - How to trigger network-manager autoconnect? - Ask Ubuntu
Executed this commandnmcli device set IFNAME autoconnect yes (where IFNAME is my ethernet name) but I still have same issue.

Check this thread. Looks like you ran into that error. Try the solution with the last post.