Installing Home Assistant Supervised using Debian 12

Thanks for the fast response :slight_smile: :heart:
I did have to prune the old networks and volumes first. Else it would keep going back to the same error.

DANGER: read before you execute

docker system prune -a --volumes

Thanks. It seems the docs now don’t even mention or link to any supervised installation any more??

I see there is also a guide for installing on Ubuntu. Which install would be best for a Dell Wyse 5020 thin client to be used as dedicated Home Assistant server with a Husbzb-1 for ZWave and Zigbee. I am coming from Windows environment and little experience with Debian or Ubuntu. Thanks-

I offered help to update the official install docs back in May, and my offer was declined. It increasingly looks like they are trying to slowly and quietly kill off Supervised.

2 Likes

Either will work, but if you want to be “Officially” supported, use this Debian guide and skip this line for installing SSH in step 1.18.

sudo apt install openssh-server -y

Other than that, I believe the Debian guide will give you an “officially” supported installation.

Thank you. I am going to give it a try when my thin client arrives.

Great. Post an update with how you get on.

If I skip line 1.18 will I still be able to connect via the ssh add on.

Sure will.

I just have a personal preference for installing SSH to the system, but the add-on will work just fine.

Agreed. There is no way I can see to even find the installation instructions on the HA site itself - you can only stumble over it on github now.

2 Likes

One last question for today. I used Bittorent to download the ISO file debian-live-10.5.0-amd64-standard and it was less than 1 GB when I used Rufus to burn it on thumb drive. Does that seem right. You mentioned using an 8 GB thumb drive.

If you used the link I provided to obtain the image, that’ll be correct.

I used the link, only difference is it is now 10.5 instead of 10.4

1 Like

What is the ultimate difference between installing this on Debian 10 and Debian 9? Besides the Debian version that needs to be installed of course?

Is there any difference in the procedure or scripts after you have some version of Debian installed?

I’m on 9 and somehow I just managed to accidentally delete my HA Supervised HA container trying to update and obviously the old script I used to initially used to install it to try to re-install it won’t work.

All I need is the installation script for HA Supervised itself. Not all the rest of the stuff.

If you sudo -i, then you should just be able to run the script and it will only install what is needed/missing, that’s my understanding anyways. Might be wrong.

Well, I have to (kind of) say that worked. Maybe…

Before I stopped in here last night I had tried to run the script as just a normal user using sudo and I kept getting a “please install avahi first” message. I ran the peripheral package install command again in the chance that something changed since I used the old supervised install script and everything installed properly as far as I could tell. But I got the same message again.

then I used your suggested “sudo -i” to get root access and ran your installer script again and then it ran fine. But I still never got the actual HA container to redeploy. I even waited overnight just to be sure (which is why I waited till this morning to respond).

This time all I did was restart the Supervisor container using Portainer and in a couple of minutes the HA container finally showed back up and seems to be working again.

TBH, I’m not really sure what got me into this mess in the first place. For some reason I could never update HA thru the Supervisor before and had to go into Portainer to do it. Which is what I did this time and even tho I thought I had done it exactly the same as I had always done I must have screwed something up.

But the question is why couldn’t I update from the Supervisor before? is it because I was using the old deprecated install script?

Hopefully when the next release comes out I can test things again to see if using your new script fixes that issue.

Luckily this wasn’t on my production system. And this is one of the reasons I’ve been hesitant to move to HA Supervised as my production install. There seems to be too many mysterious “black boxes” interacting between the supervisor service, the supervisor container, the HA container and Docker itself. And with no official support/documentation for this install method and no easy troubleshooting method it kind of sucks when things go wrong.

Thanks again for your help.

I am using docker on my RPi3…and I had some problems updating to 114 from the supervisor page in HA. This post has me wondering if I shouldn’t do the update through Home Assistant…and maybe there’s a different procedure when using docker.

Has anyone using the supervised docker install upgraded to 114…and how did you do it

For it was a v114 specific problem. I haven’t ever been able to update HA from within HA ever since I installed the supervised version.

But I also used the old install script to install supervised literally a few days before it was “deprecated” so I never had a chance to know if it ever worked or if it’s because of the old script version I used.

@kanga_who
I noticed after completing your extremely well done guide that there is a message in the Supervisor panel that says
“You are running an unsupported installation. Learn More

After following the link, I found that Frenck points out a few extra stipulations for a supported system which include using overlayfs2 storage and journald logging in docker.

I was able to make it a ‘supported’ installation by performing the following in a terminal:

# open/create a file with nano
sudo nano /etc/docker/daemon.json

# insert the following content then save (ctrl + s) and exit (ctrl + x)
{
  "log-driver": "journald",
  "storage-driver": "overlay2"
}

# restart docker
sudo systemctl restart docker

# wait ~10-15 seconds then restart Home Assistant
sudo ha core restart

It would be great if you could add creating the file and restarting docker between the Docker & Home Assistant installation commands; then people will end up with a ‘supported’ configuration.

Have a great weekend!

7 Likes

Thanks for the feedback and the extra instructions.

I will spin up a Debain VM in the next day or so and run through this and add it in. Thanks again!

1 Like