Integrating GE Concord alarm system


#22

I’m going to have 30-40 zones, can I use a PI Zero or would that be too much for it?


#23

I’m not entirely sure but I think that should be fine. I’m using a Pi Zero and it works fine for about a dozen zones. My Pi Zero is dedicated to the alarm system and doesn’t do anything else.


#24

So I’m getting a pattern from the module, but not the correct/expected bytes

[email protected]:~ $ python -m serial.tools.miniterm /dev/ttyUSB0 --parity o
— Miniterm on /dev/ttyUSB0 9600,8,O,1 —
— Quit: Ctrl+] | Menu: Ctrl+T | Help: Ctrl+T followed by Ctrl+H —
�����A��A��A��A��A��A��������������������������������A��A��A��A��A��A��������������������������������A��A��A��A��A��A��

This module was part of ADTs pulse setup the previous owner had. Wondering if it’s some setting done to the module.

@silfa718 do you have a link to the module you got. Wonder if I should try another module.


#25

What do those bytes look like in a hex editor?


#26

[email protected]:~ $ python -m serial.tools.miniterm /dev/ttyUSB0 --parity o --encoding hexlify
— Miniterm on /dev/ttyUSB0 9600,8,O,1 —
— Quit: Ctrl+] | Menu: Ctrl+T | Help: Ctrl+T followed by Ctrl+H —
F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 DE 41 66 DE 41 E6 DE 41 E6 DE 41 E6 DE 41 E6 DE 41 E6 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 F6 C2 DE 41 66 DE 41 E6 DE 41 E6 DE 41 E6 DE 41 E6 DE 41 E6

DE 41 66 DE 41 E6 DE 41 E6 DE 41 E6 DE 41 E6 DE 41 E6

ÞAfÞAæÞAæÞAæÞAæÞAæ

Its all off. Not sure whats going on.


#27

Yeah, strange. All your serial com settings look right to me, but the hex values are very different from what should be expected.


#28

More data.

[email protected]:~ $ python -m serial.tools.miniterm /dev/ttyUSB0 --parity o --filter debug
— Miniterm on /dev/ttyUSB0 9600,8,O,1 —
— Quit: Ctrl+] | Menu: Ctrl+T | Help: Ctrl+T followed by Ctrl+H —
[RX:u’’] [RX:u’\ufffdA’] �A [RX:u’L’] L [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’]
[RX:u’\ufffd\ufffd’] �� [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’] [RX:u’\ufffd\ufffd’] �� [RX:u’’]

I think I’ll have a hard look a the module and pull it out. Maybe see if I can reset it or something and reinstall it.


#29

With the Zero are using the serial on GPIO or a micro usb => usb => serial setup?


#30

I have a Interlogix 60-783-02 SuperBus 2000 Automation Module with RS232.


#31

Hi,

If data appears to be garbled, possibly the baud rate settings. 9600,8,O,1 is incorrect.
Try altering these settings, maybe the control panel is using 9600,n,8,1 which is sort of a default settings devices work on.

Hard to find these days, but can you connect to something else that supports serial?
This will confirm your serial to USB converter is working correctly.

Rob.


#32

According to the manual for the automation module, the correct serial comm parameters are:

8 data bits; 9600 bps; Odd Parity, 1 stop bit


#33

After updating to 65.6 half of my alarm binary senors disappeared. Rolled back to 65.5 and everything worked. Anyone else see this?

Update: Not seeing this issue anymore in the .66 release.


#34

So bought a new automation module and installed it. The concord panel ‘learned’ the device and its listed on under the BUS. The Power LED is green the bus light is flashing red. However, not it seems nothing is being sent to or from the module:

[email protected]:~/py-concord/ConcordAlarm.indigoPlugin/Contents/Server Plugin/concord $ python concord_test.py /dev/ttyUSB0
Wait for message start, byte_read=u’\x00’
r
SEND REFRESH
Sending message (retry=1) '022022’
write_message: '\n022022’
Resending message, attempt 2: '022022’
write_message: '\n022022’
Resending message, attempt 3: '022022’
write_message: '\n022022’
Unable to send message (timeout), too many attempts (3): '022022’
Looping 20
Looping 40
Looping 60
Looping 80
Looping 100
Looping 120

Do I have to do another set in the installation of the panel? Did I miss a step?

Thanks for the help.


#35

Just installed and setup the server on a Raspberry Pi running through HA. Everything works fine except the motion sensors are not detecting or reporting motion to HA. I’ve confirmed the motion sensors are working fine.

I used the binary_sensor to expose all the sensors to HA. Both the contact sensors and the motion sensors are wireless and are showing up on the main screen of HA.

Is there any changes I can make to HA to fix this.


#36

What is the status of this?

  • is it still working ok In the latest Hassio version?
  • Did the silent arming get fixed?
  • Are you able to use the motion sensors?
  • If you have it on a seperate pi, does it communicate via MQTT? Is there already code for this or did you write your own?

Thanks!!


#37
  1. I’ve got mine working on the current version.
  2. I don’t use the silent arming
  3. My motion sensors show up and show when motion is detected
  4. I have mine running a separate pi, but communicates via the included component. All my door and motion sensor show up via the component.

#38

Thanks silfa718
Would you mind sharing some of your yaml interacting with the module?
Also, since I’m running Hass.io. How would I go about installing the client?
Thanks


#39

The current HA alarm code does not support silent alarming, because there’s no way to pass through the option.

I wrote a patch to HA which generalized the alarm interface to allow this. Unfortunately, the developers didn’t like it and they didn’t accept the patch because it was “too general”, or something. I didn’t agree with their assessment but it’s their call. I just keep the patch locally because silent arming is a must for me, which is an unfortunate pain.

My motion sensors work fine.


#40

Thanks.
Any chance getting a copy of your patch?


#41

In my yaml I have two entrys:

alarm_control_panel:
  - platform: concord232
    host: Client Pi IP address

binary_sensor:
  -platform concord232
    host: Client Pi IP adress