Integrating Lutron RadioRA2

Hello, after an extensive search and looking through old topics. Im planning to use Home Assistant, however I had the quote and was about to proceed with Radio Ra2, but it’s unclear if it works fine with Home Assistant. In an old topic it said that only Radio Ra2 Select may work.

However the select version doesn’t support one of the things I loved the most, the Lutron RadioRA 2 6 Button Hybrid Keypad. So can anyone confirm if the lights with RadioRa2 works fine with Home Assistant, or anyone has a better suggestion that have a similar elegant and simple keypad instead of having multiple switches. (With RadioRA it needs the switches, but was planning just to hide it and have the keypad)

Thanks a LOT for any help.

Best Regards

Here’s what the docs say:

Were you able to integrate with RadioRA2? Looking to replace my zwave system with this right now.

1 Like

The auto discovery features worked like a charm to discover lights in a lab setting. The config is radio ra 2 (not the select version) software 12 with a apple kit hub. 2 Lights in two rooms with the following dimmer can be turn on or off or dimmed RRT-G25LW. Unfortunately the newer model that provides reverse phase dimming is not recognized is the auto-discovery, model rrt-g5new. These are in a third room. Any idea what is wrong with the code?

Hello Alexandre. I am new to Home Assistant. I installed it on a raspberry Pie 3 B+. The first time i installed it, the system proposed me to connect to different discovered systems like my Hue Bridge and also the Lutron Pro Bridge. Whis is great. I did a few things with my home assistant and then reinstalled back a fresh version but this time the system does not propose the Lutron Bridge anymore and i cannot find a way to integrate it back. I have actived telnet, set a fixed ip adress to the bridge and also used the lutron caseta add-on but nothing works. It seems i am missing something. How did you managed to add your switches ?

Can someone update if the Integration of Lutron RadioRA 2 is still accurate? I’ve modified the configuration.yaml as identified. My question is

Still functional
The user = Lutron
Password = integration

My logs are showing warnings and ultimately disconnecting

Confirmed with Lutron and a version update around 12.2 the lutron/integration login was removed. I added them back in into the RadioRa2 software(Integration Telnet) and looks good now.

hello, i just installed HASSIO and added my Ra2 system to it, but all the lights and devices in Ra2 don’t come with a Unique ID so i can’t add lights to rooms or really change anything about them. see photo:
Screen Shot 2021-03-23 at 10.28.22 AM

any ideas? apparently i can’t add a unique ID per the documentation.

I already have Hubitat and it works like a charm with Ra2. I want to move to Home Assistant, but this would be a deal breaker if it didnt let me add lights to rooms.

thx

1 Like

This is actually an active issue that has been worked on for more than 9 months, here is the relevant link to the dev process:

It is NOT ready for prime time, as there are changes to the dependency in addition to the integration, as well as keeping up with core changes to HA… but they are working on it

I agree. Hubitat’s Lutron integration is very good and Home Assistant’s isn’t. Based on community topic activity Hubitat seems to have proportionately more RadioRA 2 users than Home Assistant. Until a better integration is released you can use this to pass the Hubitat devices to HA:

Did this ever get worked out? I’m curious about moving up to an ra select system