IntesisHome WiFi AC Control

Hello everyone

Is there anyone who is getting this issue?

2022-11-07 09:28:07.493 DEBUG (MainThread) [pyintesishome] sending keepalive to {self._device_type}
2022-11-07 09:28:07.493 DEBUG (MainThread) [pyintesishome] Sending command {"command":"get","data":{"deviceId":224571441733184,"uid":10}}
2022-11-07 09:28:07.493 ERROR (MainThread) [pyintesishome] <class 'ConnectionResetError'> Exception. (104, 'Connection reset by peer') / [Errno 104] Connection reset by peer
2022-11-07 09:28:44.267 DEBUG (MainThread) [pyintesishome] {'config': {'token': XXXXXXXX, 'pushToken': 'channel-XXXXXXXXXXXXXXX', 'lastAppVersion': '2.8', 'forceUpdate': 0, 'setDelay': 0.7, 'serverIP': '', 'serverPort': 5210, 'hash': 'XXXXXXXXXXXXXXX', 'inst': [{'id': 1, 'order': 1, 'name': 'First installation', 'devices': [{'id': '224571441733184', 'name': 'Office_test', 'familyId': 8192, 'modelId': 477, 'installationId': 82936, 'zoneId': 86127, 'order': 1, 'widgets': [15, 3, 5, 7, 9, 44, 42, 11, 13, 47, 49, 52, 53]}]}]}, 'status': {'hash': 'XXXXXXXXXXXXXXXXXX', 'status': []}}
2022-11-07 09:28:44.268 DEBUG (MainThread) [pyintesishome] Server:, Token: XXXXXXXXXXXX
2022-11-07 09:28:44.268 DEBUG (MainThread) [pyintesishome] {'224571441733184': {'name': 'Office_test', 'widgets': [15, 3, 5, 7, 9, 44, 42, 11, 13, 47, 49, 52, 53], 'model': 477}}
2022-11-07 09:28:44.268 DEBUG (MainThread) [pyintesishome] Opening connection to IntesisHome API at
2022-11-07 09:28:44.405 ERROR (MainThread) [pyintesishome] Connection to failed with exception [Errno 111] Connect call failed ('', 5210)

it is breaking the integration to pyintesis home. I started getting this issue recently and not sure what is causing it?

Looks like you’re using the Cloud API?
Was that your only option, or can you use the intesishome_local?

What version are you running of the integration? What version of HA?


Intesishome_local does not work correctly for me as it disconnects every few hours and produces this logs:

2022-11-07 20:32:21.441 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue
2022-11-07 20:32:27.611 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue
2022-11-07 20:32:33.682 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue
2022-11-07 20:32:39.753 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue
2022-11-07 20:32:45.830 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue
2022-11-07 20:32:51.965 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue
2022-11-07 20:32:58.130 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue
2022-11-07 20:33:04.223 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue
2022-11-07 20:33:10.302 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue
2022-11-07 20:33:16.374 DEBUG (MainThread) [pyintesishome] Sending intesishome_local command getdatapointvalue

It is not receiving any update. My device is the IS-IR-WIFI-1 (which is not in the list of known devices) I know that it works for few hours then it stops working but not sure why.



I am a new HA user and I am trying to add the IntesisHome integration and following the necessary steps by editing the configuration YAML file but it does not seem to work. My AC device is not visible in HA and whenever I try to restart HA, I am getting an error message.

Add-in integration

Editing configuration YAML file:
username and password updated

Error message received after restarting HA:

Failed to restart Home Assistant

The system cannot restart because the configuration is not valid: Integration error: password - Integration ‘password’ not found. Invalid config for [climate.intesishome]: required key not provided @ data[‘password’]. Got None required key not provided @ data[‘username’]. Got None. (See ?, line ?). Integration error: username - Integration ‘username’ not found.

My login and password do work when directly connecting to Intesis AC Cloud Control and from the AC Cloud app (iOs).

HA version installed on Raspberry Pi 3B:
Home Assistant 2022.11.4
Supervisor 2022.11.2
Operating System 9.3
Frontend 20221108.0 - latest

AC model: Panasonic CS-HZ25TKE
IntesisHome Type: IS-ACX-WIFI-1

Thanks in advance for your help!

Update: Resolved. My formatting (indentation with tabs) was wrong.

1 Like

You shouldn’t need to manually write YAML now either @Sway-SWE . The latest version works with ConfigFlow, so you can add the repository in HACS, restart HA, then go in to Settings → Integratoins → Add integration → search for IntesisHome
And just add it that way :slight_smile:

1 Like

Thanks @Chilling_Silence! I didn’t know about HACS but I’ve now installed it. My current YAML setup is working fine though it’s currently cloud based. I understand it’s possible to control my device locally instead so I might switch to that through ConfigFlow as you mentioned.

Glad to hear it. Highly recommend it, the local control is significantly more reliable (Intesis fault, not the integrations)

I don’t see this is HACS? Under integrations I only see the cloud integration. Be great to bypass the cloud, not that I’ve had issues so far.

Go to HACS → Integrations → 3-dot Menu → Custom Repository and add the URL:

1 Like

Thanks for that. It looks like anywAir is still cloud based if i reading overview correctly?

Only if you can’t use the intesis_local option.
Add it to HACS, restart HA
Go to Settings → Integrations → Add integration, add the IntesisHome integration. It’ll guide you through setting up local access


Ok, great! Would you suggest I comment out the yaml code to disable cloud integration prior to setting up local integration?

No, you get to pick and choose when you follow the second step. It’ll ask you if you want cloud, or local etc

1 Like

Thanks so much for your guidance. I will give that a go tonight when I get home from work. Much appreciated Merry Christmas/Happy Holidays.

1 Like

All the best, let us know how you go. Nothing better than having your A/C able to be automated in time for the holidays! :sunglasses:
Merry Christmas to you too

1 Like

Especially in a sub tropical climate (southern hemisphere) this time of year :sunny:

1 Like

Yeah I’m from New Zealand. Bring on summer :sweat_smile:

1 Like

Hello from across the ditch :rofl:

1 Like

I ran into the same problem. Solved it without changing password by adding “device: airconwithme” to configuration.yaml (and restarting) :

  - platform: intesishome
    username: <<myusername>>
    password: <<mypassword>>
    device: airconwithme

As described here: IntesisHome - Home Assistant device is having IntesisHome by default. airconwithme or anywair can be set optionally.

1 Like