Intruder Alert Notification with Pictures from MJPEG Stream

I got this working kinda, I can run the .sh script manually, but when I run is via HA I get the following error. I’m sure its a permissions kind of thing

Fri Aug 17 2018 18:14:07 GMT-0400 (Eastern Daylight Time)

Error running command: `/home/homeassistant/.homeassistant/www/tmp/`, return code: 1

NoneType: None

Lastly, pushbullet does send the gif (after I manually created the gif via the script), but it just looks like a picture. Do animated Gifs work in iOS pushbullet?

Thanks, very easy to follow and get set up, so far

Same error I got, sorry, should have posted about it. You need to change the owner of the script to your home assistant user. I am using Hassbian, so it

sudo chown homeassistant:homeassistant

I am pretty sure it was that, if you do a ls -l in the home assistant directory, will tell you the owner and group of the files.

Edit: they should work in Pushbullet, I have only tried in testing, but it seems to work for me. Its only three frames thrown together, but yeah it displays fine in the iOS app.

So i got some mail today, and this where the automation is setup, and it seems the animated gif only plays in the preview in pushbullet. When you open it, it doesn’t play, and every time i go to download it, its get to 100% and crashes out the app. Honestly, for me, it doesn’t matter at the moment, as it just a stupid notification for when I get mail.

I tried to make a gif from jpgs running HASSIO with:

convert -delay 100 -loop 0 /config/www/dafang_1/dafang_1_snapshot_door_open_1.jpg /config/www/dafang_1/dafang_1_snapshot_door_open_2.jpg /config/www/dafang_1/dafang_1_snapshot_door_open_3.jpg /config/www/dafang_1/dafang_1_snapshot_door_open_4.jpg /config/www/dafang_1/dafang_1_snapshot_door_open_5.jpg /config/www/dafang_1/saved/dafang_1_snapshot_door_open.gif

When I run this in SSH I get:

convert: command not found

Is there a way to get this working and get a gif in HASSIO?

Did you find a solution for the convert command not found error.
I am running hassio on Ubuntu / docker.
The convert command runs fine when I SSH to the host but not from the HA container.
Is this even possible?

You need to modify file permissions to make it run , as well as whitelist the directories where the files are listed.

Any idea how to make a gif from multiple motioneye screenshots?