iPhone away presence not updating until I open the Home Assistant app

I’ve just set up Home Assistant recently and I’m using my iPhone for presence detection. The problem is that it isn’t working most of the time when I leave home. The status for the phone never moves from “Home” to “Away”.

I’ve noticed that often my phone’s status will not change to “away” on Home Assistant until I open the Home Assistant app on my iPhone. “Background App Refresh” is enabled in the settings for Home Assistant.

I ran the following “experiment” in an attempt to fix the issue/get a better understanding of what’s going on:

  1. Leave home
  2. Open a browser on my mobile phone and type in the URL for my Home Assistant server.
  3. The Home Assistant login page appears and I log in
  4. I go to the “Overview” dashboard. My “person” status is set to “Home”. I click on the “person” entry and on the map under the “Info” section, I see on the map that Home Assistant thinks I’m still at home.
  5. I then open the Home Assistant mobile app, which is already configured with the “external” URL to my Home Assistant server
  6. I scroll in the app to my “person” status and now it says I’m “away” and my location on the map is updated to my current location.

I’ve been able to reproduce the above steps multiple times (although it does not happen 100% of the time).

Anyone else have a similar experience? I’d be happy to troubleshoot this with a developer or someone with a deeper knowledge of the mobile app.



There are two settings you need to check on the iPhone: location must be enabled and on “always allow” with précise location and background app refresh must also be enabled.

In the app settings, in location, location permission must be set to always, location accuracy to full and background refresh to enabled. All update sources should be enabled.


I own a new iPhone 14 pro max. All is set as defined but still it is not working even when the phone is charging.
It looks like a bug. My old Androids was working fine.

1 Like

Same with iPhone 13 mini, settings are correct but late location updates happen often.


I posted some more information about my issue at: iOS app communication - #2 by pmb1

If your technically inclined, you can try the “workaround” that I now use that works very well to update my “home”/“away” status. I installed the Pushcut app and created a background trigger that calls the Home Assistant API to update my presence when I come home and leave. It works really reliably. You need to create a long-living (I think that’s the term) access token and use that in your call to Home Assistant so that you will be authenticated properly. The specific call to make will be dependent on your presence set up.


I own a Pixel 8, no problem.
My wife owns an iPhone 13. All settings are correct but it refuses to move from home. (Google Maps knows where she is)
Without that I can’t set up automations.

It seems my son has solved the issue by setting the external url so the app knows where to go when my wife isn’t on the wifi.

I’ve got an IPhone 13 Pro and works like a charm and can confirm that all the mentioned settings must be enabled.

The only setting I have disabled is “ allow cross site tracking”.

Have an iPhone 15 Pro Max. Updates on the iPhone do not show in HA unless I switch to the HA app. I have verified that all permissions for the Home Assistant application are enabled other than “Allow Cross-website Tracking”. I’d prefer not to use a another app to work around this, and do my automations with the HA app itself if possible.

Having the same problem with iPhone 15 Pro. Wife’s iPhone 14 Pro is working as expected, comparing settings are identical except she has both motion and focus permissions denied. In the companion app on the 15 I can see where/when I was outside of my home zone…but not on the server. Result is automations are not working as expected.

Edit: Problem resolved, my VPN connection had become disabled.

I’m running into the same problem with my iPhone and my wife’s iPhone.

Her’s is an iPhone 11 and mine is an iPhone 15. Both dashboard cards have some entities that update and some that do not.

I have the HA app downloaded on both devices, I am logged in as myself on both devices (could this be part of the problem?) and I have the external URL configured. I currently use Cloudflare to access my HA instance when I’m away from home.

I’ve checked all the settings mentioned in the various posts on here on both phones and on the apps in each phone.

I’m not sure what to try next. I may try what Paolo suggested.