Is an end device required to flash D1 mini pro?

I connected my D1 mini pro to my HA server and able to get all the way to installing a new device from the ESPHome addon. After selecting device type (Pick specific board: WeMos D1 mini Pro), install, Plug into the computer running ESPHome Dashboard, selecting /dev/ttyUSB0, successfully compiled and uploaded, it seems I’m getting a common failure when trying to log output.

==WARNING Found stack trace! Trying to decode it==

The device never comes online.

I don’t have anything connected to my D1 mini except the usb cable to the computer running HA. Is a connection required to the mini’s pins to close a circuit and confirm a signal? (I expect digital output could be open or 0.)

No - a Wemos D1 Mini (well, probably a clone…) should just work with a USB cable and nothing else.

As an alternative, you can flash any firmware file (off the shelf, or custom from ESPhome) with a supported browser. I use Chrome on Linux as Firefox doesn’t support WebUSB.

Plug into any machine, open a browser, flash, and with several options, configure the WLAN, etc.

If this helps, :heart: this post!

@FloatingBoater Hopefully, this isn’t another rabbit hole…, but what driver should I install? My d1 mini is not recognized with ESP web tool.

-edit- sorry, just figured it out, it was CP2104.

@FloatingBoater, I tried ESP web tool demo, installed completed, but after selecting next to configure wifi, it sent me back to the install dialog. Does this mean the board is bad?

Probably not. I flash D1 mini’s all the time but I do a manual install, legacy format for the first flash. Then I run ESPHome Flasher to flash the bin file (legacy format) to the D1 Mini. After that you can do wireless flashing.


Testing with a fresh Wemos D1 Mini clone (Intel, Linux, Chrome), should end with “Provisioned”.

  • A Wemos D1 mini looks like this. Most are cheap clones these days.
  • ESP flasher:
  • Final result after adding WLAN creds:
  • To test the install, the web tools include a serial log viewer - start flashing again, but select LOGS to see a live terminal (hit the D1 reset button to see from the start).
  • HASS should pop up a message with the discovered new device which can then be set-up via WLAN.

It should be as easy as that. Flashing existing devices used to be a rite of passage with many failures (e.g. a random Tuya ESP82** product with Tasmota in 2019), but a Wemos D1 Mini is designed to just work, and if not, buy another one and try again!

You’ve not mentioned what client device you are using (Linux, PC, Mac, OS type…), but most detect the USB serial chip automatically (FTDI clone usually).

This advice might also help in the future:

If this helps, :heart: this post!

FYI: This is the board I have:

I’ve tried:

  • ESPHome web tools (result cycles back to install, no configure dialog)
  • (result is below)
  • manual download from HA (both Modern and Legacy format), then ‘Install’ from (result is below)

This is the result after install,


then attempting to configure wifi:


Also, not sure if it matters, but my client is Windows 10 using a VirtualBox to run HA. No problems so far with HA. Thanks for the advice reference, but I can’t find where I’ve strayed from it. If the only solution is to ‘buy another one and try again’, so be it. But I usually try everything I can first.

For anyone with a similar problem using the D1 mini pro, it is the issue of the wifi antenna. This board comes with both an internal and external antenna, but only the internal one is connected with the zero ohm resister.

Apparently, the internal antenna is very weak (useless) or it simply is faulty. After moving the zero ohm resister to the external antenna, the board works as expected and able to be installed in HA.