Is it possible to read the CPU temperature on an Intel-nuc running HassOS?

I use Open Hardware Monitor to monitor my windows server disks, temperatures, fan speed, CPU, memory etc in Home Assistant and it works really well. I used to use the Pulseway service but never use it at all anymore.

1 Like

Open Hardare Monitor works great! Thanks!

Thanks but I’ve tried Glances - there’s no CPU temperature listed. Open Hardware Monitor is not applicable to my use case.

Is there an easy or straightforward way to get OpenHardwareMonitor to display it’s sensor temperatures in Celsius, despite my HA global settings being Fahrenheit? Thanks in advance!

It stops to work on the HA core-2021.6.0 version.
Do you know how to solve it?

It’s running fine here.

Upgrade the custom component version: GitHub - custom-components/sensor.ssh: SSH Generic Sensor

1 Like

Did you resolve this? I would also like to get C.

Wondered if this was ever solved. My thermal directory on my intel nuc is:

Yes, in the first and second reply.

What do you get at the command line when you enter:

cat /sys/class/thermal/thermal_zone2/type

This is from the ssh add-on in HA

If I

cd /sys/class/thermal/

ls -all

I get the list in the last photo shot

Same here with Hassos installed on NUC is not possible to have the value for Temperature, without HAssos working fine

How can you set the refresh interval?

I’ve come across this same issue on my HA OS install on my genuine Intel NUC DN2820FYKH which has a Celeron ‘Bay Trail’ processor. There are no ‘thermal_zone’ directories under ‘thermal’
I’ve raised this here, which is hopefully the correct place:

thank you, had the same setup

Hey everybody!
Thank you for all helpful contributions. This helped a lot in getting things to work on my new machine.

One addition:
While the code snippets supplied above work on 2023.6, with 2023.8 there will be a change to how the command line stuff is treated. See below for an example that should work beyond 2023.7.

#CPU Temperature
    - sensor:
        name: CPU Temperature
        command: "cat /sys/class/thermal/thermal_zone0/temp"
        scan_interval: 15
        unit_of_measurement: "°C"
        #unit_of_measurement: "°F"
        value_template: '{{ value | multiply(0.001) | round(1) }}'
        #value_template: " {{ (( value | multiply(0.0018)) + 32 ) | round (1) }}"

I know your post is quite old (>3yrs) so I apologize; I’ve got HAos running in a VM on a NUC now too, 40 months later, and like this setup but for the life of me, what HACS / Integration / Addon / ??? did you add in order to have ‘platform: ssh’??? Maybe this used to exist and is now gone, I have no idea.

Edit: never mind, I found it. Had to edit it after install according to an open issue, but it works.

finally got around to fixing the CPU temp sensor and came across this, thank you, I’m running ver after 2023.8 so had lost my sensor…
just something for anyone else that comes across this post, the solution shown by @mgraeuler may need a minor change depending on your setup and NUC for the command.
if I use /sys/class/thermal/thermal_zone0/temp I get a constant -263.2°C, which would be quite an achievement…
to find your thermal_zoneX relevant file connect to your HA command line and

cat /sys/class/thermal/thermal_zone0/temp
cat /sys/class/thermal/thermal_zone1/temp

and find the one that returns x86_pkg_temp - that is then your CPU temp thermal_zone file (mine is thermal_zone1)