Is it still possible to disable updates for Addons? Toggle is now missing

I used to disable updates to addons when I’d got the whole system working well and take a snapshot image of the entire system in that state (Rpi 4 - SD card install) using the excellent rpi-clone script.

Knowing that a system configuration with specific versions of addons and Home Assistant itself is stable is very valuable.

Has the ability to disable addon updates been removed? I can’t find any information on this anywhere. If so, is there a way to disable all updates (addon and system) so that I can install them manually after having taken snapshots of known-good setups?

Addons Yes:

System updates have always been opt in, no change there. Same for HASOS updates.

Supervisor updates are another kettle of fish. You cant disable this and it makes many people unhappy.

Thanks for reply. None of my addons have the “Auto update” option underneath “Start at boot”. I assumed this was a recent change?

I really, really hope not…

I never auto-update - I wait for all the bugs to get Ironed out!

What version of Supervisor?

Supervisor 222

I am on last HA version (0.109.6) , Supervisor 222 (Ubuntu 18 Supervisor Docker install) and the option to check auto-update is there.

@mcarty Thanks for letting me know. Seems I may have a bug of sorts in my system maybe. No idea why since this is a fairly fresh install. I used the Home Assistant Supervised install script before it was deprecated to install on top of Rasbpian Lite and it has always worked well. When you say you run Supervisor Docker, do you mean you install Home Assistant as a Docker container and then the Supervisor as a Docker container and manage the links between them including any addon containers manually? If so, do you know of any good tutorials on how to do this?

Separately, if anyone has any ideas on how I can fix my current installation without a full re-install, I’d really appreciate any info.

Same install as you (the one being deprecated now), the only difference is that i run it in Ubuntu and you use Raspbian (that shouldnt be a problem).

Enable advanced mode on your profile in order to see that.


That is not on by default for any addon, you need to actively toggle that on.
A recent change in the frontend made that choise harder, as @frenck stated you now need to enable advanced mode to toggle it on.


1 Like

Does the advanced mode only affect certain addons for auto update?

The glances addon still has auto update visible, whereas the other addons i have enabled are not shown when advanced mode in on.

If not in advanced mode, the toggle will still show if you had it active before this change.

ok, cheers for the info

only run up this instance with addons as a test to the genric installer script, so was able to test

@frenck Thanks very much for letting me know. I really wouldn’t have figured it out myself easily if at all and you’ve saved me an unnecessary and very time consuming re-install.

For reference to others, you need to click your username at the bottom left of the screen when logged in as an admin user and the advanced mode toggle is on that settings page rather than going to the Users list.

Mark his reply as the solution :slight_smile:

1 Like