Issue IP Hassos on Proxmox - Guest Agent not running

Suddenly after a reboot of Home Assistant proxmox does not assign an ip address to the VM, I tried to reboot both HA and the PC that hosts Home Assistant, but nothing, I tried to create a new VM re-install HA and the new machine has its own IP what can I do? Improvvisamente dopo un riavvio di Home Assistant proxmox non assegna un indirizzo ip alla VM, ho provato a riavviare sia HA che il PC che ospita Home Assistant, ma nulla, ho provato a creare una nuova VM re reinstallare HA e la nuova macchina ha un suo IP cosa posso fare? allego uno screenshot delle due VM nella prima invece dell’IP mi compare Guest Agent not running

English please. Point 0 here How to help us help you - or How to ask a good question

check your router… your server IP might have conflict

It is not a home assistant error.

Guest agent not running… seems that the issue is there… by default this is not installed. Check the proxmox website on how to install it. Not a HA issue. The installation might or might not have an IP assigned right now… who knows :stuck_out_tongue:

The best way to check if an IP was assigned is by using the console and for example executing: ip a

Nothing here is a useful answer. I’m following the Installing Home Assistant OS using Proxmox 7 and am stuck in the same place. I looked up install of qemu-guest-agent for nothing:

[email protected]:~# apt-get install qemu-guest-agent
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
qemu-guest-agent is already the newest version (1:5.2+dfsg-11+deb11u2).
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.

So seems to be an HA issue to me.

Did you enable it for the VM you run HAOS in?

Enable Guest Agent Communication

Communication from Proxmox VE with the guest agent can be enabled in the VM’s Options panel. A fresh start of the VM is necessary for the changes to take effect.

In the Options tab? Yes.
I went back and ran

bash -c "$(wget -qLO - https://github.com/tteck/Proxmox/raw/main/vm/haos-vm-v3.sh)"

to build a second VM and this one worked. The script I did that I thought worked was
wget https://github.com/whiskerz007/proxmox_hassos_install/raw/master/install.sh
from Error when installing `Unable to handle file extension 'zip'.` · Issue #113 · whiskerz007/proxmox_hassos_install · GitHub
That got the VM done but still no guest agent.

oh, but it’s a local address 172.17.0.1 but I gave it a VLAN value. Next one worked.

This guide (HowTo install Home Assistant (HA) OS in Proxmox VE (PVE) 7.1) might help learning how to flawlessly install HAOS in Proxmox VE. Works for any version of HAOS and you are in complete control of the process.

The whiskerz007 script downloads the wrong file. (haos_generic-aarch64-8.0.rc3.vmdk)