Issue with a Lifx Bulb

Hi all,

Having trouble recently with a lifx bulb (I have more than 20, issue only with this one) which seems to fail to initialize

Logger: homeassistant.components.lifx.light
Source: components/lifx/ 
Integration: LIFX (documentation, issues) 
First occurred: 20:01:50 (4090 occurrences) 
Last logged: 22:44:52

Failed to initialize

At first I thought issue was with the bulb going offline but looks strange if offline HA trying to initialize it more than 4000 times in a couple of hours.

Does anyone have idea of what is going on here?

1 Like

First, can you try to power cycle the bulb (i.e. remove its power completely)?


so behavior is strange as if I powercycle it I would expect the light to turn on while it doesn’t.
Not sure really what is going on: I suspected a not stable power supply but doesn’t seem the case as, for example, currently the bulb is online since 2 days without having physically touched anything.

One thing I have noticed about Lifx (I have about 50) is that they have very weak wifi.

If your light fitting is made of metal it will make this worse.

It is definitely metal, but signal reported into the app looks decent (3 dots) so I thought it wasn’t an issue.

Also the same bulb worked fine for 2y with zero issues on the same lamp/location: so I was wondering if a lifx firmware upgrade (currently on latest 2.80, it is A19 Gen3) or HA update created an issue.

In the last I had similar issue with lifx going offline exactly due to low wifi bandwidth they have: I had to much broadcasting across my network and probably they could not substain it.
It is not the current case though, so I am a bit lost

So I made more test and there is something definetly strange with this bulb.
Upon HA reboot this does not come up:

  • the bulb is fine in HA
  • HA rebooted, get lot of errors
  • then waiting long enough sometimes HA can connect to it again

wifi signal is not that weak as said.
All this looks very strange: I think HA upon restart send a lot of broadcast packets and I was wondering if this could put in trouble the bulb?
Still can’t understand why only this one…

Should I try to remove and add it back from HA?

So in my case is definitely HA making crash the bulb.

all works fine, I reboot HA and the bulb is no more connected to wifi while before restart everything was perfect.

My idea, but I have very little understanding, is HA is flooding the bulb with requests and it make it crash, although this does not explain why it is happening always on same bulb.

Now I also tried to move the AP closer to the bulb (1.5m far) but still same behavior.

So really no clue about the reason: any ideas?

does anyone know how to remove a single bulb from the integration and then add it back?

should I try to remove completely and re-add the integration?

The only way is to edit the .storage files. Make a backup first. You do not want to mess that up.

Probably should open an issue about that on github.


Thanks for this @tom_l !

concerning your suggestion of dealing with .storage files I am not sure about where to start: I can locate them, but concerning what to modify…really not sure!
Can you provide a hint?

In the meantime I opened an issue on GitHub:

Issue is still there on 2021.10.3, while I found another odd behavior.

If i restart HA while that bulb is fully powered off (i.e. has no electricity) and then turn on the bulb after HA started it immediately goes online :-/

I’m still fighting with a similar issue, I’ve tried removing pi-hole no luck, as the other thread said that was their problem.

The lights always show available in the LIFX app but randomly go offline in HA. I can try and reload the LIFX integration but that never works, I finally have to restart HA and then the lights come back online for a while. Any ideas what causes this?

Hey I was having issues with my globes assigned below made them 215 - 234 and they show up no issues now.
No idea why this would matter.

It’s not even just giving them a new or fixed ip, as i fixed them to whatever they were and then re allocated to another number and still no good wasn’t until i moved them higher up that it fixed the problem.

these lights worked fine otherwise at the lower numbers, just HA couldn’t see them