Issues configuring autostart

hi, ive ran through the manual installation guide, got raspbian lite installed, all dependancies and booted up hass and accessed the web interface.

Moved onto the “autostart using systemd” guide and got as far as configuring the execstart file. Got that bit sorted and then when i run the command:

sudo systemctl enable [email protected]

i get the following error:

[email protected]:/ $ sudo systemctl enable [email protected]
Failed to enable unit: File [email protected]: No such file or directory

any ideas where i’m going wrong?

You could use this to see what services there are that are similar and see if there’s a typo etc

systemctl list-units --type=service | grep home
[email protected]:~ $ systemctl list-units --type=service

alsa-restore.service loaded active exited Save/Restore Sound Card S
avahi-daemon.service loaded active running Avahi mDNS/DNS-SD Stack
console-setup.service loaded active exited Set console font and keym
cron.service loaded active running Regular background progra
dbus.service loaded active running D-Bus System Message Bus
dhcpcd.service loaded active running dhcpcd on all interfaces
dphys-swapfile.service loaded active exited LSB: Autogenerate and use
fake-hwclock.service loaded active exited Restore / save the curren
[email protected] loaded active running Getty on tty1
keyboard-setup.service loaded active exited Set the console keyboard
kmod-static-nodes.service loaded active exited Create list of required s
networking.service loaded active exited Raise network interfaces
raspi-config.service loaded active exited LSB: Switch to ondemand c
rc-local.service loaded active exited /etc/rc.local Compatibili
rsyslog.service loaded active running System Logging Service
[email protected] loaded active running Serial Getty on ttyAMA0
ssh.service loaded active running OpenBSD Secure Shell serv
systemd-fsck-root.service loaded active exited File System Check on Root
[email protected]\x2dpartuuid-762b43d6\x2d01.service loaded active exited File System Check on /dev
systemd-journal-flush.service loaded active exited Flush Journal to Persiste
systemd-journald.service loaded active running Journal Service
systemd-logind.service loaded active running Login Service
systemd-modules-load.service loaded active exited Load Kernel Modules
systemd-random-seed.service loaded active exited Load/Save Random Seed
systemd-remount-fs.service loaded active exited Remount Root and Kernel F
systemd-sysctl.service loaded active exited Apply Kernel Variables
systemd-timesyncd.service loaded active running Network Time Synchronizat
systemd-tmpfiles-setup-dev.service loaded active exited Create Static Device Node
systemd-tmpfiles-setup.service loaded active exited Create Volatile Files and
systemd-udev-trigger.service loaded active exited udev Coldplug all Devices
systemd-udevd.service loaded active running udev Kernel Device Manage
systemd-update-utmp.service loaded active exited Update UTMP about System
systemd-user-sessions.service loaded active exited Permit User Sessions
triggerhappy.service loaded active running triggerhappy global hotke
[email protected] loaded active running User Manager for UID 1000

LOAD = Reflects whether the unit definition was properly loaded.
ACTIVE = The high-level unit activation state, i.e. generalization of SUB.
SUB = The low-level unit activation state, values depend on unit type.

35 loaded units listed. Pass --all to see loaded but inactive units, too.

nothing in there that resembles home assistant. maybe i missed a step during setup?

im starting over!

Did you create the file? It doesn’t create itself.

I just followed the manual install guide, then moved onto the autostart using systemd guide

A service file is needed to control Home Assistant with systemd. The template below should be created using a text editor. Note, root permissions via sudo will likely be needed. The following should be noted to modify the template:

right, so this is where i become mega noob.

i entered
sudo nano -w /etc/systemd/system/[email protected]

and then pasted the config from the guide, saved and closed. i guess thats wrong?

From the link I posted:

/etc/systemd/system/[email protected][your user].service

Is your user ‘homeassistant’?

1 Like

woo it worked this time. no idea what i did before, but thanks for helping me out!

so now my problem is that i dont have the “hassio” shortcut to load addons. Do i have to go real pro now and install them another way?

btw - the reason i ditched hassio and went this way was because i was trying to get some customizations installed from the forums and couldnt install dependancies. But now i want to install samba, ssh and mqtt and that addon installer isnt there?!


You didn’t install hassio. You don’t have hassio ANYTHING.

Add-ons are exclusive to hassio.

Hassio tab is exclusive to hassio.

You should have known this prior to installing manually but the documentation is a mess and doesn’t explain the difference.

1 Like

Well, SON, I didn’t blame you for not reading, I said the documentation doesn’t make it clear.

I’m just tired of seeing the same posts over and over about people installing manually and wondering where the hassio tab is.

So, don’t ever call me SON again.

1 Like

hahaha, calm down. no need to go all aggro on a forum.

i asked for help, you kindly helped. I asked another question, you got all chewy.

i’m quite happy to go back to hassio, ive got it all backed up.

i always thought the point of communities like this was to help people, make things better. i guess this one isnt.

First of all, my frustrations are with the documentation, and nothing was directed at you, but you should have read it in the getting started guide.

It is the point of communities and I did help you. Again, I will say it again because you didn’t read it the first time, you were too busy trying to talk down on me, MY FRUSTRATION IS WITH THE DOCUMENTATION.

Sorry, D. but @flamingm0e was correct in his thoughts on the way your writing was going.

He said in his reply that you should have know BUT the docs didn’t make it clear, you then assumed he (or she) was having a go at you. I feel he was correct to get slightly defensive.

May I suggest that you try and remember that attitudes and other non-verbal communication isn’t translated well on the internet and as such calling somebody “son” when you have no idea who they are is a shortcut to agro. A simple " :wink: " could have negated much of the last 4 or 5 posts.

Night, all!

1 Like

Fair one. I misread it, the SMH bit set me away.

Thanks for the help earlier, appreciate it. I’ll get back to it tomorrow and see how I get on

Just to put things in context, this thread shows the frustrations of trying to get the documentation updated to avoid the mistake you made.

There have actually been some changes to the getting started page since that thread, but clearly not enough.