Issues with SkyConnect + OTBR + Thread + Android Nanoleaf + Essentials Bulb Integration

Thanks so much for your writeup. I’ve read through your comments, and I’m unfortunately in a bit of a similar situation where I am unable to get my nanoleaf essentials to connect via my thread network at all.

I’m currently running home assistant within kubernetes, and I’m running the silabs multipan RCP as a separate container (with both home-assistant and the mulipan RCP container connected to my LAN via multus-cni with a macvlan network attachment; I’m able to see and send mDNS requests successfully for other services like google cast, homekit protocol, etc)

  • I am also able to see a meshcop DNS-SD entry, with the 3 ipv6 addresses associated with it, so I believe my thread network is being advertised.
  • I can also see the thread network appear in my nanoleaf android app, like so:

However, when I try to pair my essentials strip with the android app, it just remains loading on the “looking for thread network” for about 10 seconds before giving up and just defaulting to BLE.

Where specifically did you find these batch of IP addresses assigned? If I go to my OTBR web interface → status, I can see that I have a MeshLocalAddress assigned there starting with fd77; did it have to be fd33 specifically?

I’ve also skipped this entire thing as I wasn’t quite sure what you were referring to, but my home assistant instance only shows the one network and I have set that to preferred; my understanding is that this is where I should be.

Would you be able to share what query you made in wireshark to view these? I am unable to find any ltpdu messages in wireshark (and I am assuming that’s because I haven’t been able to get the lights to join the thread network).

I’d appreciate any further direction you have - I have checked my firewall, but I seem to have full IMCPv6 allowed in my local network. Thanks.

After enabling NAT64 features in OTBR, or using this with Apple Thread Border Router cause problem. Should I add same firewall rules for IPv4 range?

Are you seeing the bulbs stay up pretty reliably?
I have 36 of the essentials bulbs and since adding more than about 12-15, it seems a bunch of them are dropping off unavailable a lot of the time.
Gives me hope seeing someone with a whole lot of the lights up and connected.

I lost hours and hours on this one.
@idkwatimdoinman firewall rules were crucial for thread network to show up in nanoleaf app.
But, device would not connect to thread. And finally solution was Home Assistant companion app on my Android phone! :slight_smile:
You must sync Thread network credentials. In the Companion app, go to Settings > Companion app > Troubleshooting , then select Sync Thread credentials .