ISY994 Integration Failures

I had ISY working within Home Assistant, and everything was working just fine on the HA dashboards I set up. Then, I had some issues with some Insteon switches and so had some scene rework needed in ISY Admin. I also had a few NodeServer integrations set up in ISY, but since I wasn’t using them I decided to remove them from ISY. Then, the ISY HA integration began failing. I have deleted and re-added the HA integration several times, with a full HA system reboot between each attempt, but still get ISY errors in HA.

The integration says that it successfully completes, but I’m left with an integration that says “Failed to set up Check the logs.” Seems coincidental to have so many “node” references in the logs:

Logger: homeassistant.config_entries
Source: components/isy994/
First occurred: 1:29:28 PM (1 occurrences)
Last logged: 1:29:28 PM
Error setting up entry ~HomeUser's ISY994i ( for isy994

Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 313, in async_setup
    result = await component.async_setup_entry(hass, self)  # type: ignore
  File "/usr/src/homeassistant/homeassistant/components/isy994/", line 175, in async_setup_entry
    await isy.initialize()
  File "/usr/local/lib/python3.9/site-packages/pyisy/", line 138, in initialize
    self.nodes = Nodes(self, xml=isy_setup_results[2])
  File "/usr/local/lib/python3.9/site-packages/pyisy/nodes/", line 108, in __init__
  File "/usr/local/lib/python3.9/site-packages/pyisy/nodes/", line 380, in parse
  File "/usr/local/lib/python3.9/site-packages/pyisy/nodes/", line 48, in __init__
    self._members_handlers = [
  File "/usr/local/lib/python3.9/site-packages/pyisy/nodes/", line 49, in <listcomp>
AttributeError: 'Nodes' object has no attribute 'status_events'

Not sure what all this means. In trying to follow the directory paths above, it doesn’t appear that I have a python3.9 folder. From putty, I see that my Python version is 3.8.10 (I’m running supervised via portainer/docker on Ubuntu server 20.04). Does the ISY integration install Python, or has it recently required a newer version than what I am running?

Or is there some manual process to fully remove a prior integration from HA, prior to doing a re-installation?

I’ve posted the same info over in the Universal Devices forum. So far I have no takers, so thanks for any insights you all can provide.


Fair warning: I’m not going to be much help.

I used an ISY994i with Insteon devices for a long time (PLM, light switches, repeaters, etc). When I started with Home Assistant, I got my ISY working with HA but slowly realized over time that I had too much complexity: Raspberry Pi w/ HA, PLM, ISY, cha-cha-cha… Plus I was starting to have failures with my Insteon switches and replacing them was a pain (and expensive).

So, as the Insteon switches failed, I replaced them with switches that could be controlled directly from HA (without the PLM or ISY).

My ISY, PLM, and Insteon switches are all gone now and I’m much happier. No more kludgy ISY programming environment, simpler hardware environment, better control.

Getting back to your original question…I would remove the integration completely and start over. There should be a dropdown menu to delete the integration then you can restart and then add the integration back into HA. The same dropdown menu should lead you to a “know issues” section. And the Universal Devices ISY994 page has a feedback section where you may find some additional help.

I hope you find an easy answer to your question and I’m sorry I couldn’t help more.

Thanks, Mark. Just happy someone replied…!

I have not found a dropdown to remove the integration, but am using the right-click on the ellipsis dots on the integration card itself, then selecting “Delete.” I’ve been doing a complete restart of my NUC w/portainer running the docker instance following each deletion.

The fact that I’m getting references to “nodes” and a python3.9 folder that I can’t seem to locate is probably at the root of the issue. I’m not sure where python is supposed to live within HA, but when I run the version command from the putty session to the base NUC, I’m getting 3.8.x.

Have been tempted to run the 3.9 upgrade to HA, but am afraid I’ll muck up the rest of my setup. I’m going to have to research more on where/how python gets managed from within HA, or ask the group for ideas.

Thanks, again,

Do you have a backup of your ISY994 config and your HA config (prior to making the changes that caused you grief) that you can use to restore to a known working state?

Also, I found this thread (not sure if it will help - I did not read the whole thread): Update Python to the new version 3.9

See also: