ITead’s “Sonoff Zigbee 3.0 USB Dongle Plus V2” (model "ZBDongle-E") based on Silicon Labs EFR32MG21 +20dBm radio SoC/MCU

Thanks for your swift reply en feedback Edwin. I’ll need some more digging to do.


Flashed my ZBDongle-E in Windows 10 (PowerShell as administrator) as well and this is my outcome in ZHA:

python flash -f Z3RouterUSBDonlge_EZNet6.10.3_V1.0.0.gbl -p com4 -b 115200

Used my previous flashed ZBDongle-P to pair it into ZHA. Devise is visible in the Visualization but not connected to the coordinator. Has no end devises connected as well. WTH? :wink:

edit: updated wrong screenshot / added OS platform

You probably just have to wait 24-hours, then if still the same report such ZHA issues to Home Assistant core →

FYI, many if not most Zigbee End Device products will not automatically change their connection to a closer Zigbee Router if you added that Zigbee Router after you added the Zigbee End Device products, so in those cases, you might just have to remove its battery/power for a while in order to it to make a new connection when put battery/power back or sometimes manually re-pair/re-join the Zigbee End Device in ZHA.

Those Zigbee End Device products that do automatically change their connection to a closer Zigbee Router usually only do so in intervals of once every 24 hours or more after it has evaluated its strongest neighbours.

Most other Zigbee Router products will however automatically change their connection once every 24 hours or more after it has evaluated its strongest neighbours.


Thank you Hedda for your elaboration. I was assuming that the SONOFF DONGLE-E_R used as router would make faster pairing possible than my BlitzWolf SHP-13 Energy Sockets/Meters.The SONOFF DONGLE-E_R has now paired itself into the mesh - 15 hours later - and has already made some connections.

Still not sure about the LQI / RSSI (not showing) for the majority of devices in my mesh. For now I’ll let the ZHA mesh do its thing and check it everyday or so.

Next time I pair a device I’ll have more patience. :wink:

edit: added model SHP-13

@Arc8dium ,
did you able to recover from firmware 7.X.X?
also try to downgrade to 6.10.3,
but after firmware flush the device stop to respond,
try again to flush with the bootloader mode,
but nothing help.
with the ezsp utility getting this messege:

python3 probe -p /dev/ttyACM1

2022/10/27 10:39:26 Elelabs_EzspFwUtility:   Couldn't communicate with the adapter in Zigbee (EZSP) mode, Thread (Spinel) mode or bootloader mode

Hello for everyone instruction to flash with extraputty:

  1. start extraputty
  2. plug in dongle E pressing the boot button (led falshs red)
  3. Connect with this settings:

    You have to check your COM Port here:
  4. After that push enter then you will see a text in the console.
  5. Enter 1 then click “File transfer” at the top → Xmodem → send
    It is important that you push 1 and then you will see: CCCCCCC
    While you see this you have to start the file transfer.
    After that extraputty uploads the firmware and after finishing you have to push 2 → it goes to paring mode.

have fun


Yes i’m back at the original firmware because of the amazing work from XSP1989. See the forum thread here about this issue: please help with recovery - Issues Antenna

Basically you need to flash the nvm3_initfile.gbl file after flashing the 6.10.3 firmware and it will come back to life.


Some questions from someone who is fairly new to the subject:

  1. Does Model E not support HomeAssistant by default? At least that’s what I read here in the table from Sonoff.
  2. Which model is more suitable if I want to equip HomeAssistant on my Raspi4 with Zigbee?
  3. I have heard that the Model E may have better support from the HomeAssistant developers because of the chipset. Is this true?

Thank you in advance.

1 Like

Hi all,
I’m trying to flash my two e dongles with the router firmware. I tried with SecureCRT and also ExtraPutty with parameters you told:
Serial: COM10 (for this example) and 115.200 bauds. Data bits to 8, parity None, stops bits 1 and flow control XON/XOFF
I can connect but I cannot send the firmware. SecureCRT says that receiver never responded to the start of transfer request.

I also tried booting the dongle pushing the boot button and also the reset one. Nothing worked.

Am I missing anything?



  1. Both are supported by HA’s ZHA integration →
  2. Both work great with the ZHA integration, but you should always use them through a powered USB 2.0 hub (via a long USB extension cable) if you computer does not have USB 3.0 ports as using those directly will cause interference, read →
  3. For now they work equally great with Home Assistant’s ZHA integration today, however, you could maybe speculate that support for Silicon Labs based adapters like the ZBDongle-E might perhaps indirectly become better integrated in the future if prioritized by Nabu Casa’s own developers only because it uses the same Silicon Labs EFR32MG21 SoC chip as the upcoming official Home Assistant SkyConnect USB Stick

Note ZBDongle-P is better supported in Zigbee2MQTT today if want to use that instead of Home Assistant’s ZHA integration, this is as Zigbee2MQTT’s zigbee-herdsman library’s support for EZSP adapters is experimental, for details see ongoing development there →

Also note that if you are using the ZHA integration today then it is now very easy to migrate back and forth between ZBDongle-E and ZBDongle-P (via ZHA integration’s built-in backup, restore, and migration features).

In addition, remember that you can always convert ZBDongle-E and ZBDongle-P adapters into dedicated Zigbee Router devices that can work as stand-alone Zigbee signal repeaters and range extenders if used in USB charger for power to achieve better coverage in large homes.

A tip is therefore to buy both a couple of ZBDongle-E adapters and a couple of ZBDongle-P adapters then reflash the one you are not using as a Zigbee Coordinator with Zigbee Router firmware and use those as dedicated stand-alone signal-repeater/range-extender if simply plug into a USB charger for power. This follows best practices →


One of THE best elaborations about the two Sonoff Zigbee 3.0 ZBDongles P/E! Thank you for that Hedda.

E.g. I have one ZBDongle-P flashed as Coordinator running in ZHA and one ZBDongle-E as Router in the same ZHA. Still fine tuning my Zigbee mesh network, but happy with both Sonoff ZBDongles. :sunglasses:

How did you do that flash?. I mean, just a post before I shared my problems trying to flash a couple of them as routers.

Any updates yet?

1 Like

Yes: ITead’s “Sonoff Zigbee 3.0 USB Dongle Plus V2” (model "ZBDongle-E") based on Silicon Labs EFR32MG21 +20dBm radio MCU now sold for $19.99 - #109 by Arc8dium

Thanks. This helped me get past my issue which turned out to be PEBKAC :rofl:

FYI, noticed puddly is developing a “Universal Silicon Labs Flasher” for Silabs OTW firmware update:

Not tested it myself but that firmware flash image updating tool should be compatible with ZBDongle-E.

Looks like will be used in a Home Assistant Add-on for automatically flashing SkyConnect / Yellow:


Do anyone know the current status of zigbee2mqtt for the ZBDongle-E? I see that it is still in the experimental section, but would it be safe to take it in use now? I cannot seem to able to get hold of the “P” version any more.

Should be safe to use, but don’t think Z2M support Zigbee network backup for ezsp adapter yet(?). See:

Hopefully, stability will improve as more people in the Zigbee2MQTT community start to use it and help with development or as testers to actively contribute with proper and constructive bug reports.

I believe that is due to the still ongoing global chip shortage and global supply chain crisis

1 Like

Thank you for the detailed reply @Hedda. I’ll give it a chance with the “E” dongle then and start replacing my deCONZ setup.

Note that everyone here can also help the developers make this dongle more stable in Zigbee2MQTT.

If you stumble into issues that seem related to this or other Silicon Labs EFR32 based Zigbee dongles then try to help the developer of the ezsp adapter for Zigbee2MQTT’s zigbee-herdsman code by providing detailed descriptions of your problem and logs needed for troubleshooting and debugging. See →

Note! If feeling brave then also consider upgrading to the latest unofficial 7.1.x community firmware builds on the ZBDongle-E to help them with testing the updated EZSP v9 interface with Zigbee2MQTT.

Regardless be sure to follow these generic best practice guidelines which apply for all Zigbee Coordinator USB adapters regardless of Zigbee implementation (including Zigbee2MQTT and the ZHA integration) →

1 Like