ITead’s “Sonoff Zigbee 3.0 USB Dongle Plus V2” (model "ZBDongle-E") based on Silicon Labs EFR32MG21 +20dBm radio SoC/MCU

Hi and all other one seams to be with hardware flow control.
I had try them but it crashed my dongle E. so I had manually to restore SW firmware.

Which firmware you are using ?

Hi. Please read last ~10 posts in this thread. Most of them about HW Flow Control on Dongle-E…

I have big issues with the ZNDongle-E firmware flashing.
I tried to flash the rcp-uart-802154-v4.3.2-zbdonglee-460800.gbl using an Ubuntu VM on VirtualBox in Windows.

This because I want to use both Zigbee and Matter/Thread.

Firstly I tried the web-flasher but with no success, tried on three different window computers.
So I moved to use a Ubuntu VM on windows, and following the instructions on this page (Flashing the Sonoff ZBDongle-E to enable Matter, Thread and Zigbee on Home Assistant | Dialedin) the flashing was NOT working, I got some error messages related to permissions errors.
So I used another tutorial, using Elelabs_EzspFwUtility and it worked fine, the flashing was successfull, but after the flashing, when the utility was rebooting the dongle, the message “couldn’t communicate with the adapter…” appeared

2023/11/22 19:09:40 Elelabs_EzspFwUtility:   Couldn't communicate with the adapter in Zigbee (EZSP) mode, Thread (Spinel) mode or bootloader mode
2023/11/22 19:09:47 Elelabs_EzspFwUtility:   Successfully restarted into X-MODEM mode! Starting upload of the new firmware... DO NOT INTERRUPT(!)
2023/11/22 19:09:59 Elelabs_EzspFwUtility:   Failed to restart into bootloader mode. Please see users guide.

From that moment it’s impossibile to re-update or use the adapter.
Any help?

On windows, you can do it using the web flasher - just click on “FLASH” just below the image on that web page:
image .

When you change from the Zigbee Router Firmware to the multiprotocol RCP Firmware, the protocol changes - you need to use the multiprotocol add-on.

Hey everyone, I just changed from my Conbee2 to the Sonoff -E dongle and flashed the lastest firmware through the web flasher. My need for now is only zigbee.
However, with Z2M, some devices don’t really work well. Indeed if I want to turn on a plug for example, Z2M sends some errors on the logs. The switch works after a couple of seconds or minutes.

For those who made the switch and where the firmware ncp-uart-hw-v7.3.2.0-zbdonglee-115200.gbl works fine, how did you make the migration? Did you re-pair every device?

FYI, EZSP adapter support is still experimental in Zigbee2MQTT’s zigbee-herdsman → [WIP]: EFR32 EZSP adapter implementation and test · Issue #319 · Koenkk/zigbee-herdsman · GitHub (so if want more stable then it is recommended to instead buy a CC2652 based adapter like ITead’s TI CC2652P based “Sonoff Zigbee 3.0 USB Dongle Plus” which was renamed to “ZBDongle-P .

Regardless of the adapter used, be sure you first read and try follow all tips/advice here before troubleshooting any deepder → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

Exact same issue, trying to go to the Sonoff official router firmware. Have tried so many methods, this being the last in a series. Ever get a solution?

I was not having any luck trying to flash my E dongle as a router until I realized the firmware file I downloaded was not actually the correct file.

Make sure you go all the way to this page:

Then download the “raw” file from one of the buttons on the upper right. The file size should be about 280K.

Hope this helps someone feel less foolish than I did!


Arghhhhhhhh I am such an idiot!!
I saw the .gbl file, and figured I had it - meanwhile I’m trying to flash a $%#@ webpage to it!!
You truly are a star - thank you!

Worked first crack on my latest attempt with using the Elelabs python utility.
I’m surprised I didn’t brick it as I’ve tried to upload that damn webpage to this thing with so many uploader systems.

Honestly I’ve come across all the same error messages in Googling, trying to follow leads that I had on all the various method’s failures - so I’m guessing there’s probably more than just the two of us out there - so hopefully this helps others.

Thanks again - I’m now stepping back slowly into the hedge.


I had the same issue with RCP firmware, silabs addon & Z2M, a whole lot of failed commands; unusable. I switched back to NCP (7.3.1), got rid of silabs addon, reverted Z2M config, and somehow Z2M kept all my devices (contrary to switching from factory NCP to RCP where I had to re-pair everything, as expected). It works just fine now… it’s as stable as the factory firmware (6.10.3) I used before (i.e. never crashed, no failed command, 30+ devices on it; been using it for over a month now, no complaint).

port: >-
adapter: ezsp
Zigbee2MQTT version 1.34.0
Coordinator type EZSP v12
Coordinator revision build 176

I also have a router-flashed (Sonoff 6.10.3) dongle that works just fine with the coordinator flashed with 7.3.1; not that it shouldn’t, but just in case anyone was wondering.

PS: for anyone having issues with the download links:

Latest Coordinator firmware (NCP) from Sonoff (6.10.3):

Latest Router firmware from Sonoff (6.10.3):

Oh, and, do yourself a favor, use darkxst’s Chrome-based flasher (thanks for that one!).


hey there,
i am just setting up my HA. Bought two Sonoff-E Dongles. Wanted to make the upgrade to Multiprotocol before anything else.

On Windows 10 (both on desktop and laptop) the web-based Flasher on can`t make a connection to both Sonoffs. (Edge and Chrome tested)

If i press connect, i can choose the sonoff off the given list - The circle just stops halfway through.

Driver are installed, shows up in device manager as:
USB-Enhanced-SERIAL CH9102 (COM3) - which should be fine

So two Sonoffs on two different computers (both WIN10) no update possible.

which way to go from here?

Might be a bug in sl-web-tools or its dependecies so suggest that you first try flashing with other methods/tools to rule it out before reporting the issue to the developer(s) of the tool that there is still a problem with it:

Maybe try following ITead/Sonoff guide but using other firmware image file if you wish to rule that out too:

Perhaps also reinstall the CH9102/CH34 (USB-to-UART bridge/converter) device driver and reboot the operating system to be sure:

I have flashed my 2nd dongle E with the router firmware, restarted and added it to the zigbee devices, do I have to do something else to let this router act as repeater in HA or will the rest function automatically between the two USB dongles?

Once you paired/joined a Zigbee Router device the routing function will work automagically, (each device will evaluate its best connection options and if needed automatically move around once every 24-hours to the best Zigbee Router devices), see → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage


ZHA configuration UI has a tab to view visualized device links in your Zigbee network topology, but you do not have to do anything →

1 Like

Thanks a lot …
i didn´t have luck with any of the methods - did try to build python an my WIN10 PRO - in the ende there were cryptic error messages about not being able to build the “wheel”)

So i gave up for the moment - My SONOFF-E (Ver 1.0) is working “as delivered” - only ZigBee … build 297

:question:Does anyone have a SONOFF-E with higher hardware versions than 1.0?

will try the web-flasher again in some weeks

You can try the web-flasher again now. See Web flasher broken due to missing dependency · Issue #11 · NabuCasa/sl-web-tools · GitHub fix should be included in → Release 0.10.1 · NabuCasa/sl-web-tools · GitHub and looks like Home Assistant webpage been updated Fix connection issue with web flasher by puddly · Pull Request #93 · home-assistant/ · GitHubHome Assistant SkyConnect and also looks like darkxst updated his sl-test webpage GitHub - darkxst/sl-test at gh-pages so check out again at Silabs Firmware Flasher | Web based flasher for ZB-GW04 and ZBDongle-E. MultiPAN RCP firmware enables these devices to be used with Silabs Multiprotocol Addon in Home Assistant. Allow Zigbee and Thread to co-exist on the same dongle. Get ahead of the tech an experiment with Matter!

What would be a reason to advise me to switch from firmware build 297 to the new firmware I have never done any updates, and if I can I avoid it, even if since yesterday a Tuya socket has disappeared from zigbee2mqtt I don’t think it depends on the dongle And for this problem

The old preconception that firmware updates are “risky” doesn’t apply (as much) on recent/decent hardware. Many connected devices will even auto-update firmware by default when a new one is available.
The one thing you should avoid is connected devices that don’t allow you to update firmware. 3-5 years down the road (if not sooner), you might as well hang a sign “Entry Here”. Always check on that before buying!

For “lesser” devices (i.e. stuff without much support…) such as the dongle here, you should check the stability of the flashing procedure (quick net search); if you see a myriad of issues, bricked devices, then only update if there is a good reason for it (security issue, not working properly, etc.). On the other end, if the flashing is easy, then definitely go for it, especially if the current firmware is getting old.

As for the dongle specifically, 6.10.3 is 2 years old and there were about 20 updates since. I don’t think there’s much hope for “official” Sonoff updates at this point. But to know exactly what the updates would bring to the table, you’d have to go through the release notes. On devices like this, that define a communication protocol, you also have to consider the “other side”, ZHA/Z2M, and what they support/recommend; new versions may break compatibility with older ones.

Personally, I flashed two dongles, half a dozen times, including router and coordinator firmware. I used Sonoff’s recommended procedure the first couple of times, then darkxst’s tool recently. I didn’t have a single issue (darkxst definitely easier). And like I said, 7.3.1 has been working with Z2M for over a month without problem.

For Zigbee2MQTT you are best off posting issues and discussions to their community:

Note that it is recommend to instead use TI CC2652P based “Sonoff ZBDongle-P” instead of Silabs EFR32MG21 based “Sonoff ZBDongle-E” for Zigbee2MQTT.

Reason is that the ezsp adapter code in the zigbee-herdsman library which Zigbee2MQTT does not quite yet have feature-parity with its zstack adapter code, and most notable the ezsp adapter code is missing full backup and restore support → Koenkk/zigbee-herdsman#319 preventing restoring backups and migration → FAQ | Zigbee2MQTT

FYI, check out this thread for unofficial method on how to migrate from ZBDongle-E to ZBDongle-P for thoee using Zigbee2MQTT → Koenkk/zigbee2mqtt#16478

Tip is then to reflash the ZBDongle-E with Zigbee Router firmware to repurpose it as a dedicated Zigbee repeater/extender by powering it via a USB-charger in order to make it into a stand-alone product →

Note! Regardless of Zigbee gateway solution I highly recommend to read and follow all the tips here → Zigbee networks: how to guide for avoiding interference and optimize for getting better range + coverage

PS: If where to use Home Assistant’s ZHA integration then would instead recommend Silicon Labs over Texas Instruments based Zigbee Coordinator → Zigbee Home Automation - Home Assistant however that is primarly just because Home Assistant SkyConnect is based on Silabs EFR32MG21 → Quantity Connection Home Assistant Notes
SONOFF Zigbee 3.0 USB Dongle Plus-E 1 USB Zigbee2MQTT Used to control all Zigbee smart bulbs and Blinds. ZHA was becoming un-reliable for me so switched to Zigbee2MQTT


I just wanted to drop a note on this thread in order to be self informed (via email notifications on this thread) of progress about EZSP firmware from time to time.

Here is my setup:

  1. Zigbee network with 79 devices, of which, 51 are routers and 28 are end devices. All end devices are less than 4m away from routers. There is no more than 5m between routers.
  2. Home Assistant, always updated to latest version running on a Raspberry-Pi 4
  3. Zigbee2Mqtt (and the Mosquito broker) in a separate hosts (2 separate virtual machines, they both run in the same hardware with Proxmox)

Last week, I’d a deconz Raspbee Zigbee controller in a dedicated Raspberry-Pi 4 (different from the one running HA) but I decided to migrate to Zigbee2Mqtt because of lack of information about what’s going on in the zigbee network with the deconz hardware/software, lack of support for HTTPS in their web app “Phoscon” (my iPhone refused to connect to their web application without HTTPS, limited capacity to rename devices in the zigbee network as that functionality was removed from their desktop application and some other issues, so I migrated to a SonOFF-E Zigbee 3.0 USB Dongle Plus dongle.

My dongle is running EZSP v8 version build 297. I’m having some issues when disconnecting devices from the network as they re-appear immediately after they are deleted from the net. I’d to repeat the delete process several times to success. Also the touchlink is not supported (lack of support in the firmware). But I like that the serial connection is 115200 bauds because in theory, this can handle more devices and messages. I also suffer from some end devices and routers that don’t like each other in the network (I decided to replace OSRAM bulbs with IKEA ones and SonOFF mini with equivalent Aqara on/off devices…)

I’ve also purchased a second SonOff Zigbee 3.0 USB Dongle Plus (like the one I already have) in order to test new firmware versions with the possibility to go back to the current firmware just switching them.

So, I’m definitively interested to know more and monitor the progress of the EZSP firmware in order to see if I can stabilise my zigbee network.

Re-pairing 79 devices is not an easy task. I’d to review all existing scenes and automations in HA because of the changes in device names…

In the end, a wall switch and a bubble physically connected to the AC is far more reliable than all this stuff :slight_smile: I love technology in general and in my mind I know that there is more potential in this mesh networks than in the old physical wires but it has to prove it can be reliable too.