ITead’s “Sonoff Zigbee 3.0 USB Dongle Plus V2” (model "ZBDongle-E") based on Silicon Labs EFR32MG21 +20dBm radio SoC/MCU

FYI, I posted there to that discussion now too with an idea of a possible workaround by using “zigpy-cli” as stand-alone third-party software to do the cross-manufacturer backup and restore →

If that workaround works then it might be to possibly migrate without needing to re-pair all devices (though some devices will probably still need either be power-cycled, remove battery, or re-paired), regardless be patient as might take many hour for some Zigbee End Device products to reconnect (try force a state change).

1 Like

Thanks @Hedda !

You are fantastic…
I will try on a spare server to see if it works.
And I will post the result

1 Like

@Joel_DE, has your network been stable now for these pair of days after removing Ikea routers?

I’ve had a lot of trouble with E-dongle with ZHA, network was really unstable. I went from Conbee II->Sonoff, tried all the tricks in the sleeve to get the network stable (2-3 weeks of fiddling around, even all the zigby v4-v11 parameter fiddling) but everytime over 70 zigbee device network went somewhat unusable regularly. Now back to Conbee and network seems stable.

It could be same problem you had with E-dongle as I do have also 5 Ikea routers on my network.

Hey itnhas been stable except today it was offline. But it lasted the longest ever. Not sure why it went offline haven’t been able to look yet. But prior it would last only a few hours.

Interesting someone else has Ike’s routers with issues. If it doesn’t stay stable for a week I’m going to put the dongle p back in

1 Like

Moved from conbee ii to sonoff last week… I had serious problems when pairing all devices again but solved it by pairing them near the coordinator… Afterwards i’ve placed them at their location and re-pair some of them due to low signal without deleting…At the end everything works perfectly!! No drop outs or anyting…

Zigbee2MQTT version
1.30.1-dev commit: 0b6040d
Coordinator type
Coordinator revision build 297
Frontend version

  1. Total 23
  2. By device type
    End devices: 18
    Router: 5
  3. By power source
    Battery: 17
    Mains (single phase): 5
    undefined: 1
  4. By vendor
    LUMI: 11
    Bosch: 3
    innr: 2
    IKEA of Sweden: 2
    frient A/S: 2
    _TZ3000_p6ju8myv: 2
    TexasInstruments: 1
  5. By model
    lumi.sensor_magnet: 4
    ISW-ZPR1-WP13: 3
    lumi.sensor_switch: 3
    SP 120: 2
    TRADFRI bulb E27 WW 806lm: 2
    lumi.curtain.acn002: 2
    HESZB-120: 2
    TS0215A: 2
    lumi.sensor_motion: 2
    ti.router: 1

Moved from a Conbee II to the ZBDongle-E few months ago and the migration was flawless.
Devices have been working as they were on the old setup.
However today I tried to add some devices (plugs, door sensors) and they would just not pair… It seems that the interview does not end for the device, as it stays always in pairing mode. The device is added to Home Assistant but, as soon as the pairing mode ends, it cannot be reached anymore.
Does anyone have the same issue?

I may try to get a Dongle P to test if it’s working better

Be sure to read and try to follow all the advice here before troubleshooting any further →

(take note that also contains information/link about selecting Zigbee network channel/frequency range for you →

Then also read and follow these best practice tips for pairing as well →

Combining everything in those three should at least remove any obvious things that can cause issues.

Never had issues with pairing devices beforehand, and I already had a look at all these articles.
As I only changed the coordinator I’m pretty sure it depends on that.

Sorry, I probably misunderstand you, but, that comment makes it sound like you are saying that because it has worked fine before for you in the past without a USB extension cable and using a USB 3.0 port instead of a USB 2.0 port then it should continue to work fine, and therefore you might feel that it is not even worth reading and following the advice for best practice since you assume that your setup should already good enough, so why even bother looking at remaining well-known issues such sources of electromagnetic interference, as or did I misread you wrong?

We are not mind-readers so you need to spoonfeed us detailed information about your exact setup. What Zigbee gateway integration/application are you using and which version/revision/variant of it? Are you using a long USB extension cable to the Zigbee Coordinator USB adapter? Is it plugged into a USB 2.0 port or plugged into a USB 3.x port? What firmware are you running on the Zigbee Coordinator USB adapter?

Anyway, please begin by understanding and remembering that simply ignoring that electromagnetic interference really is a serious Zigbee killer is just a bad idea. It is a fact that interference is well known to cause issues with the pairing/joining process, so please start by following the best practice advice/tips in those by removing all and any known sources of interference in order to make troubleshooting easier.

Honestly, the various different symptoms that can and have been seen from electronic interference interfering with Zigbee make it not even worth trying to troubleshoot any other problems until you have taken some best-effort actions to avoid electronic interference. Please help us help you or we will not be able to help you.

I’ve done a fair amount of ZBDongle-E vs ZBDongle-P under both ZHA and Z2M. Probably more than most, but still limited in the grand scheme of things.

I’m assuming you are ZHA. All comments below are in regard to ZHA, but I would say are even more applicable to Z2M, where ezsp support is not as mature.

This is all personal , N=1, anecdotal opinions, so evaluate them appropriately.

IMO, the “E” has more paring issues than the “P.” After probably hundreds of paring attempts with a couple dozen devices, my general opinion is that “P” pairings seem to go smoother and require less fiddling than “E” pairings, with occasional devices that just would not pair with the “E.” It seemed particularly noticeable greater distances and/or less than ideal conditions. It’s hard to quantify, I wasn’t doing things side by side with timers and strict controls.

All the interference, best practices, etc advice applies, but testing was adapter vs adapter in the exact same location, same channels, same signal strength settings, etc. For my environment I consider the “P” the better behaving stick.


Hey, sorry for being negative, it’s just that I spent so many hours troubleshooting issues with ZHA and I feel like hitting a wall every time: I fix a weird problem and a new one pops up; so far my experience has been like that.

Anyway, what I meant is that I had a working setup with a Conbee II stick. I chose a channel to avoid wifi interference, had an USB extension cable on a USB 2 port, away from other devices, network with many routers but not so many devices (about 20 in total)… I really tried everything to make it work as good as possible and it was working ok. Some quirks with switches but plugs worked out of the box without issue and they were pairing immediately.

I switched to the Sonoff Dongle E because of some issues with the zigpy-deconz library that I wasn’t able to fix. The migration was flawless and the devices of the network were immediately recognized and working. Again, I’m using the same setup (extension cable…) that never had signal issues.

Now, when I try to add new plugs or motion sensor the device is recognized and added to HA but stays in pairing mode (its led keeps blinking), thus making it unavailable in HA when pairing mode finishes. I tried today with different devices and they all exhibit the same behaviour.

To confirm this I even tried to take a plug that was already in the network and that never had issued. I removed it from the network, reset it and put it in pairing mode. Now, no matter what I do, I cannot make it available in the network as before: it will stay in this pairing mode forever and no matters what HA tries to do, it will be unavailable when it comes out of the pairing mode. Tried many pairing cycles, still the same issue. Again, this plug paired perfectly with the old dongle.

That’s why I tend to believe that the problem is the dongle.

Anyway I ordered a -P dongle and will try this weekend if the problems are gone after a migration. I really don’t feel like resetting my network and re-adding all devices one by one at this point because I fear it will be a lot of work for nothing.

Yep, that’s the impression that I got from reading this thread, and the reason why I ordered the -P dongle. I will do some tests over the weekend and see if the connectivity improves with that.
At the moment I cannot add devices to the network because of this pairing issue, which is a bummer. These are the same devices that paired without issues with an old adapter so I tend to think that the problem is indeed the new dongle.

It would be good if I can confirm that the dongle is the problem so that hopefully it will help other people here to make the right decision.

Some swear by the SI Labs chip, and specs are arguably better than TI. Likely both have various strengths/weaknesses. Like everything zigbee, I think it can be highly install specific.

Be aware you will not be able to re-flash the “E” with router firmware and use it in the same network, or anywhere within range of your network.

Changing the ieee on the E’s SI Labs chip is a one time only, irreversible change. If it was already assigned the ieee of the Conbee during migration it cannot be changed again. The conbee ieee can again be migrated onto the “P” without issue, but you won’t be able to have both E and P powered up at the same time.

The ieee for TI chip in the “P” can pretty much be changed at will, as often as you like. If you decide to keep the E as coordinator, you can add the “P” back as a router device.

For the record, while that is not not quite technically true, it is almost true in practice for most laymen, as to change the IEEE can be changed more than but it requires you to reset it by manually flashing the firmware again with a JTAG debug probe, which is something that will usually cost as such as the whole Zigbee adapter on its own (though a JTAG debug probe can of couse be reused many times with different devices, and not only Zigbee adapter, so can be useful for other things for DIY tinkerers).

I can confirm that, after a quick flashing of the new firmware on the -P dongle and its installation in ZHA, I don’t have any pairing issues anymore and everything seems even more responsive.
For now it seems to have fixed everything.
Let’s see if it stays like that :slight_smile:


Apologies in advice…
Can I get a friend who can help 30 years IT vet disabled; guess I am the old confused guy which is embarrassing AF…

I have smartthings v2 hub, 73 zigbee/z-wave devices nest&alexa devices. Saw the Sonoff no neutral required to add a switch badly needed to use the ceiling light for the pantry (previous homeowner remodel.)
Cool, so I bought a SONOFF ZBMINI Extreme Zigbee Smart Switch to finally fix this issue. Tried adding to smarthings/google/Alexa. No worky.Researched for days - confused still so posted for help on Sonoff site, and was told I need a Zigbee dongle. OK, added that today, but looks like it only works with Home Assitant? I spun up a VM and installed HA, but god I have to learn a variant of Smartthings IDE. I will eventually, but my wife needs this light as she is also disabled.

Takes me weeks to implement things that took hours in the past.

Can someone point me in the right direction? I want to be able to adopt matter and it looks like I need the v2 for that? I need to update firmware to file discovery I read, but Ideally just need no neutral “miracle” working on my ST/G/A setup, or am I in for an uphill battle?
thank you all greatly

@Cocokola please understand that questions about help on the setup of Home Assistant and assistance with getting started with Zigbee in Home Assistant are both at the very least slightly off-topic here.

In order for you to get better help with getting started to suggest that you instead start your own separate new topic as a dedicated discussion for all your specific questions regarding your personal setup. Suggesting this as sounds as if you will probably have many follow-up questions and how to get started with different general things Home Assistant, which is either generic or setup unique questions is a little too off-topic for this discussion. This existing discussion which already has around 200 posts is not the right place to ask for step-by-step instructions and try to start a dialogue for help with your unique setup.

Anyway, generally recommend that beginners start by installing the ZHA (”Zigbee Home Automation”) integration under Home Assistant. See →

A tip is to search on YouTube for videos on how to set up the ZHA integration for Zigbee, (no need to search for help there on any compatible Zigbee Coordinator adapter as the ZHA integration is more or less hardware agnostic). Getting started with the ZHA integration should not be hard at all as long as the Home Assistant can see the Zigbee Coordinator USB radio adapter, however getting USB pass-through working to a Virtual Machine can be complicated and is totally off-topic here for sure, which again is another reason why you should really start a separate new topic, (for getting USB passthrough working to a VM you should post to other external third-party community that helps with the virtualization hypervisor / virtual machine manager that you are using. As for getting started with the ZHA (Zigbee Home Automation) integration in Home Assistant, there are basically just a few written guides like this →

Also to make it easy for yourself recommend subscribing and make use of the paid “Home Assistant Cloud” service which makes it much simpler to connect to Amazon Alexa (e.i. Amazon Echo devices) and/or Google Assistant (e.i. Google Home devices) as well as remotely connecting and controlling your Home Assistant instance via the official companion app and/or proxy in via Nabu Casa website →

“Home Assistant Cloud” service is provided by Nabu Casa, which is a company that is operated by Home Assistant founders and employed some of the lead developers to work full-time for Home Assistant (so you are sponsoring the project by using their paid service), and getting remote access and Amazon Alexa or Google Assistant working with that “Home Assistant Cloud” service can be a hassle.

Regardless, YouTube is your friend for step-by-step guides. For example, check out these for starters:

This community forum is more for deep-diving details issues once already tried and then got stuck.

Suggest that just stick with only Zigbee for now. As most people say today ”Matter does not yet matter”. Trying to get started with Thread/OpenThread (with or without Matter) now is a sure way to stumble in the dark with sharp objects (and there are not even any available Thread/OpenThread devices that can do anything that existing less inexpensive Zigbee devices can not already do).

This dongle also ships only with Zigbee Coordinator firmware and Zigbee should be enough to get you started, and regardless there is no official Thread/OpenThread firmware for this radio dongle, even though the hardware supports Thread/OpenThread and there is unofficial Thread/OpenThread firmware for it I would not bother looking at that yet as it is very bleeding-edge stuff that is likely to change a lot in the coming year or so, so at least that will be an uphill battle if you want to jump on that today. See →

If you only want to use Zigbee then is very probably there is no need to update the firmware right away.

Anyway, if you wanted Thread/OpenThread support today then you should instead really have bought the Home Assistant SkyConnect USB dongle which has official support for it but even it only offers very early beta support for it.

Personally, I recommend that when you think you are ready to experiment with Thread/OpenThread (including Matter over Thread/OpenThread) just buy a separate radio USB dongle dedicated to only Thread/OpenThread so as not to risk messing up your stable Zigbee network, and the official the Home Assistant SkyConnect USB dongle is the obvious choice there as it will be the best-supported adapter.


FYI, for those wanting to experiment with Multi-PAN RCP firmware for OpenThread/Thread on ITead’s Sonoff ZBDongle-E USB dongle you should know that user skgsergio on GitHub has compiled and published unofficial SiLabs Multi-PAN RPC firmware images for ZB-GW04 USB dongle (competing Zigbee Coordinator USB radio adapter from EasyIoT / eWeSmart Store) which used the same EFR32MG21 SoC and has a board that is pin-compatible so theoretically if flashed to Sonoff Dongle-E it should enable you to use Thread/OpenThread with the Home Assistant’s Silicon Labs Multiprotocol Addon, and while not optimized for the antenna used on the ITead’s Sonoff ZBDongle-E USB dongle board it should at least on paper technically work for a lab if want to test it. Check out → [REQUEST] ZDongle-E Silicon Labs RCP (Radio Co-Processor) firmware concurrent multiprotocol Zigbee and OpenThread · Issue #5 · itead/Sonoff_Zigbee_Dongle_Firmware · GitHub

More specifically read post 5 there →

Disclaimer for this is that I have not tested this myself, and keep in mind that unofficial firmware and use case is of course all highly experimental so use at your own risk and do not expect anything around Thread/OpenThread or Matter and HomeKit devices that uses Thread to work out-of-the-box even with the right type of firmware. To look at native Thread support in Home Assistant right now at this time you really need to be willing to go down the rabbit hole. For diving deeper see:



I am struggling to get the router firmware flashed on my Dongle-E. I have managed to flash coordinator firmware with no problems (v6.10.3) using secureCRT. with the file downloaded from ITEAD git for the router i get nowhere though (it gets stuck on transferring)

I ended up trying to use ELELABS utility to get a better log here is what i get back:

C:\elelabs>py flash -f Z3RouterUSBDonlge_EZNet6.10.3_V1.0.0.gbl -p COM3
2023/03/09 16:44:49 Elelabs_EzspFwUtility:   EZSP adapter in bootloader mode detected:
2023/03/09 16:44:49 Elelabs_EzspFwUtility:   Gecko Bootloader v1.12.00
2023/03/09 16:44:49 Elelabs_EzspFwUtility:   Allready in bootloader mode. No need to restart
2023/03/09 16:44:50 Elelabs_EzspFwUtility:   Successfully restarted into X-MODEM mode! Starting upload of the new firmware... DO NOT INTERRUPT(!)
send error: expected ACK; got b'\x18' for block 1
send error: expected ACK; got b'\x18' for block 1
send error: expected ACK; got b'\x18' for block 1
send error: expected ACK; got b'\r' for block 1
send error: expected ACK; got b'\n' for block 1
send error: expected ACK; got b'S' for block 1
send error: expected ACK; got b'e' for block 1
send error: expected ACK; got b'r' for block 1
send error: expected ACK; got b'i' for block 1
send error: expected ACK; got b'a' for block 1
send error: expected ACK; got b'l' for block 1
send error: expected ACK; got b' ' for block 1
send error: expected ACK; got b'u' for block 1
send error: expected ACK; got b'p' for block 1
send error: expected ACK; got b'l' for block 1
send error: expected ACK; got b'o' for block 1
send error: expected ACK; got b'a' for block 1
send error: NAK received 17 times, aborting.

2023/03/09 16:44:57 Elelabs_EzspFwUtility:   Firmware upload failed. Please try a correct firmware image or restart in normal mode.

I’m guessing that the firmware version is not correct for my device although i have downloaded this from the ITEAD git. Any help appreciated…

All recommendations I read online suggest to connect these ZigBee dongles to USB 2 ports, however, my server is equipped only with 3.0 USBs. Therefore, I used a USB 2 extension cable. Is this supposed to work and fix the interference?