ITead's "Sonoff Zigbee 3.0 USB Dongle Plus" (model "ZBDongle-P") based on Texas Instruments CC2652P +20dBm radio SoC/MCU

indeed. :+1:

Thanks, and thanks for pointing out which firmware to use… today while bumbling around getting ready to try it I stumbled across a link to instructions on Sonoff’s page also (at the bottom) How to add Zigbee devices to Home Assistant via SONOFF Zigbee 3.0 USB Dongle Plus? How to flash firmware to Cc2652P? - SONOFF Official

EDIT: So when I woke up this morning TONS of devices are routing through it now :+1:

1 Like

I just got mine in the mail. I’m trying to flash the router firmware by following the steps on Getting started with Sonoff ZIGBEE 3.0 USB DONGLE PLUS - NotEnoughTech but holding boot while inserting the device into my laptop yields nothing in the texas instruments flashing utility (v2). I have two and haven’t had any luck getting it into flashing mode. Anyone else have this issue or any pointers?

Have you installed the device drivers for Silabs CP210x USB-to-UART Bridge Virtual COM Port (VCP)? Performing update on MS Windows 10 I had to first install those drivers and then reboot my computer.


There is a link to a python program called in the flashing docs that worked well for me. Just enter your com port number at the prompt that shows up (the docs say “55 55”) I just did the single digit for the com port it came up on and it worked on 2 of them.
How to flash firmware to Cc2652P? - SONOFF Official


That did the trick! Thanks. I followed the guide above which mentioned drivers from a Chinese website. This didn’t work for me, but your link did.

1 Like

FYI, omerk (from Electrolama of zzh fame) has forked popular cc2538-bsl firmware flasher by JelmerT cross-platform firmware upgrading/downgrading tool for Texas Instruments CC13xx/CC2538/CC26xx based adapters and he is working on extending it with additional features with a goal of making it more user-friendly and reliable for new users, check it out at:

The first new feature he plans on adding is automatic download of firmware for specific board/roles:

Other enhancements he also has plans to implement is NVRAM backup and restore during upgrade:

PS: He mentions there that he would appreciate some expertise GitHub/PyPi help with packaging for Windows (issue) and prettifying PyPi releases via Github Actions (issue) for automatic releases, etc.

FYI, Koenkk from the Zigbee2MQTT project must have tested as he now added it to their supported list:

He also added it to his repository of precompiled Z-Stack 3.x.0 Zigbee coordinator firmware images:

It has been confirmed to also works as a Zigbee router if flash it with this Z-Stack 3.x.0 router firmware:

1 Like

Mine arrived yesterday. Will do some tests this weekend.

Btw I never had luck with this script. The only way works for me is to press the boot button while inserting the USB dongle

Is flashing possible using Linux? should be possible (if you can translate the serial port naming convention), but what about a flashing tool? should work

Thanks! Unfortunately, it asks to install pyserial, though it is already installed. I think there might be some version conflict with esphome.

I upgraded the firmware to the 20210708 version but cant pair anything anymore.
Anyone know where to find the original firmware? Should be 20210120. All links to it on Koenkk’s GitHut no longer work.

EDIT: A few reboots later it just started working. No idea what was going on. Still interested in getting the original firmware just in case though.

Should we be switching hardware flow control on? Or do we not care about that?

If so does the latest z2m firmware enable hardware flow control?

Did it work with the original firmware? (the one when the stick was shipped to you)

Yes. Only tried a bulb and sensor. Figured Id start fresh with upgraded firmware.

According to Koenkk his came with C1352P2_CC2652P_launchpad_coordinator_20210120 firmware.

So that should be coordinator/Z-Stack_3.x.0/bin/ here:

All of Koenkk’s older firmware that has been uploaded can be found in the commit history on GitHub:

1 Like

I am using the original firmware - some devices pair but not all. It seems to ignore all my aqara temp sensors.

Has anybody had success creating groups? I’m trying to add 2 hue bulbs to a group via the zigbee2mqtt UI and they just wont show up despite getting the green ‘ok’ dialog after adding.