JQ-300/200/100 Indoor Air Quality Meter

Yes, my device is working correctly. All data is correctly transferred to the system through this integration. But this is a very unreliable device. In particular, I have already burned out all the LEDs. I admit that you could have a defective or simply burnt out dust sensor.

I can’t work out what the problem is but I’ve not been able to get this integration to work for me. What am I doing wrong?

"2020-09-24 00:46:27 INFO (MainThread) [homeassistant.setup] Setting up jq300
2020-09-24 00:46:27 INFO (MainThread) [custom_components.jq300] Version dev
2020-09-24 00:46:27 INFO (MainThread) [custom_components.jq300] If you have ANY issues with this, please report them here: https://github.com/Limych/ha-jq300/issues
2020-09-24 00:46:27 DEBUG (MainThread) [custom_components.jq300] Connecting to account ne <strong><strong><strong>****[email protected]**** l.com
2020-09-24 00:46:27 DEBUG (SyncWorker_7) [custom_components.jq300] Querying http://www.youpinyuntai.com:32086/ypyt-api/api/app/loginByEmail
2020-09-24 00:46:28 DEBUG (SyncWorker_7) [custom_components.jq300] _query ret 200
2020-09-24 00:46:28 DEBUG (SyncWorker_7) [custom_components.jq300] b'{"action":"loginByEmail","code":2000,"uid":31062548,"safeToken":"DD8B48EF0E25432B8CE21205605B7C00","expireAt":0,"systime":0}'
2020-09-24 00:46:28 DEBUG (SyncWorker_7) [custom_components.jq300] Updating devices list for account ne</strong></strong></strong> ****[email protected]**** l.com
2020-09-24 00:46:28 DEBUG (SyncWorker_7) [custom_components.jq300] Querying http://www.youpinyuntai.com:32086/ypyt-api/api/app/deviceManager
2020-09-24 00:46:28 DEBUG (SyncWorker_7) [custom_components.jq300] _query ret 200
2020-09-24 00:46:28 DEBUG (SyncWorker_7) [custom_components.jq300] b'{"action":"deviceManager","code":2000,"deviceInfoBodyList":[{"circleid":"57bc22e972f9d27416581187","pt_name":"Living Room Air Sensor","pt_model":"JQ_300","brandname":"\xe5\x93\x81\xe4\xbc\x98","logo":"mlLogo.png","onlinestat":2,"flag":1,"id":28559,"deviceid":19829,"devstatus":6,"deviceToken":"35635B35654583595765","status":1,"href":"/resource/page/hcho/indexPm25.html","pic":"20161026101634psgscf591477448194","weburl":"http://market.cmbchina.com/ccard/xyksq/xyksq.html?WT.srch=1&WT.mc_id=N3700BD1057Z074200BZ","updtime":"1477448195","repairstatus":null}]}'
2020-09-24 00:46:29 DEBUG (MainThread) [custom_components.jq300] Finished fetching ne <strong><strong><strong>****[email protected]**** l.com devices list in 1.624 seconds
2020-09-24 00:46:29 DEBUG (SyncWorker_5) [custom_components.jq300] Updating sensors state for account ne</strong></strong></strong> ****[email protected]**** l.com
2020-09-24 00:46:46 ERROR (MainThread) [custom_components.jq300] Timeout fetching ne <strong><strong><strong>****[email protected]**** l.com device's sensors
2020-09-24 00:46:46 DEBUG (MainThread) [custom_components.jq300] Finished fetching ne</strong></strong></strong> ****[email protected]**** l.com device's sensors in 17.132 seconds
2020-09-24 00:46:46 INFO (MainThread) [homeassistant.setup] Setup of domain jq300 took 18.8 seconds
2020-09-24 00:46:46 ERROR (MainThread) [homeassistant.setup] Setup failed for jq300: Integration failed to initialize.
2020-09-24 00:53:49 WARNING (Recorder) [homeassistant.components.recorder] Event is not JSON serializable: <Event platform_discovered[L]: service=load_platform.sensor, platform=iaquk, discovered=name=jq300, sensors=dict_keys(['iaq_index', 'iaq_level'])>"

My configuration.yaml entry is as follows:

jq300:
  username: n*************@hotmail.com
  password: *********
  devices: jq300
  
iaquk:
  jq300:
    sources:
      humidity: sensor.jq300_humidity
      co2: sensor.jq300_eco2
      tvoc: sensor.jq300_tvoc
      hcho: sensor.jq300_hcho
      pm: sensor.jq300_pm25

This component is in beta. Including because, unfortunately, some time ago the authors of JQ-300 began to actively block attempts to receive data from their cloud bypassing the official application.
Judging by the logs, it looks like you also fell under this block.

There is only one cure: change the public IP address. If you do not have a fixed IP address provided by your ISP (usually this is the case), it is usually enough to simply reboot the router through which you get the Internet.

Unfortunately, I still cannot free up enough time to study in detail the protocol of the official application in order to fine tune this component for it. Sorry.

Thanks for taking a look at my query, Andrey. Unfortunately changing the Public IP address did not resolve the issue. Not sure if there’s anything else that you think I could try?

Sometimes just waiting helps.
Unfortunately, there are no other methods of correcting the situation. I’m sorry.

Try new version: https://github.com/Limych/ha-jq300/tree/5fd58ac5d3601b8383ce1aa43691de14972a03a6

Hi, 6 days ago I have this device working properly, but since yesterday it does not change any value, they are always fixed.
It always marks the same value. I tried to calibrate, link to another account, but always with the same result.
Any solution?

Did you fix this? I’ve connected one today for the first time and the values do not change. Maybe some problem with the cloud?

@rogodra, @McGiverGim,
Do you see any values changes through the official app?

I also do not have values updates on my device either through the component and through the official application.
I thought at first that it was a malfunction of my device. Everything happened simultaneously with my experiments on the component code. If you have a similar picture, then the reason is in the cloud. I hope this is not yet another attempt by the cloud authors to block access to cloud for that component — to be honest, I’m already tired of digging into their application :slight_smile:

No, I don’t see any change in the official app neither.
This is a new installation so I’ve never seen values.

I hope it wasn’t me who broke this cloud. :innocent:

@Limych In the official app is not updated either. I linked it to a new account, and the values remain fixed.

Here the question is: is it not working for nobody or only for us? Someone has it working since yesterday?

Same problem here, for a brand new JQ-200 in Spain, no value is changing. You are not alone. We need a cloud independant integration!

Did you try to integrate it in Home Assistant? I want to know if this is some kind of ban or it simply is a general problem affecting all the users.

Is not working neither in the app and in home assistant, the values are fixed allways.

It has started working, at least from the app.

Yes, that’s right. Updates from the cloud began to arrive today, including through the component. The first data I have recorded 02:02:35 UTC.

In addition, a few minutes ago I published a new version of the component, which added several minor improvements.

It has stopped working again. At this moment I’m using only the app, so is clear that is not a ban, more a cloud bug.

If you enable debug mode in the component, you can see that the connection with the server is not lost and some events (device availability) continue to arrive. As I understand it, the failure occurs in the cloud somewhere at the internal level, which calculates the values of the sensors.

1 Like