KNX Dimmer support


Thank you for the fast answer.
I think I figured out the problem is not HA but KNX related.
I don’t have a brightness_state_address configured, any tips on how to configure ETS are welcome. I will also try to figure out a solution myself :slight_smile:.


unfortunately I dont have access to my installation right now, so I cant check my settings…

maybe try activating “send dimming value after change”.

Chapter 4.6.2 of the MDT manual.

Edit: Manual actually says about this setting: activates the status object for the
dimming process


I was able to activate the state dim value and HA is sending values to the groupadresses. Dark grey is my HA.
image The light (Dim actuator) only doesn’t pick up these values and won’t change the appearance. It definitely is a KNX-ETS issue. In some way I can’t find the right combination for address,brightness_address,brightness_state_address,state_address.
My former KNX-programmer programmed everything to dim relatively, but for HA it has to be absolutely.

Maybe with some ETS - HA examples I can figure it out.


I have in my HA config:

  • platform: knx
    name: Schlafzimmer
    address: ‘1/0/5’
    state_address: ‘1/1/5’
    brightness_address: ‘1/3/5’
    brightness_state_address: ‘1/4/5’

The 1/3/5 is the “dimmen absolut”.
<GroupAddress Name=“Licht Decke Schlafzimmer OG 68 dimmen absolut” Address=“1/3/5” DPTs=“DPST-5-1” />
Working as expected.

Screenshot from the ETS I can maybe provide during/after the weekend. I have the same MDT actor.


Thanks for your effort moe.
I think I was able to find the right addresses, with the information you gave me.
However the KNX bus still doesn’t pick up the single.
I made a little movie of the problem, when you have time will you be so kind to compare the settings since you have the same actor?


Problem solved, found the right configuration for my installation! Thanks community :slight_smile:

  • platform: knx
    name: Living Rechts
    address: ‘1/1/10’
    brightness_address: ‘1/5/10’
    brightness_state_address: ‘1/3/10’
    state_address: ‘1/4/10’


Good to hear! :slight_smile: