Kogan Smart Kettle

I’ve just done Tuya convert, but all I get is a switch and its just marked as on all the time. Toggling does nothing.
What type did you set this as to get these?

Hi Sean, I didn’t tuya convert, instead used LocalTuya with the stock firmware that ships with the kettle, so I can’t help you.

Sorry stupid auto-correct, I’ve just done Tuya Local, what did you set the device type too when you added it?

I bought one of these in October last year, any ideas if it can be flashed OTA?
Not done any flashing before, and can’t seem to find much in the way of a guide for this device, if anyone can help?

try this way

it mite work

This is what I get when using local tuya and setting it as a switch.
I’ve tried binary sensor too, how did you get the two, and what type did you set it up as?

Hi mate, here’s my yaml config. Sub your local key, ID and IP address

The kettle switch is a switch, the temp is a sensor.

1 Like


Interesting, mine is only showing id:5, which is what I got in the config flow too.

Don’t seem to have id 1, or any other ID to then control the switch.

What happens when you configure as I shared? If you have the exact same kettle (they may be shipping variations at any point in time), then 1 should work for the on/off switch.

Done your way and the config flow.

If I do in yaml, just get errors in the log saying that it is trying to get an ID that does not exist.

Hi Sean, when you add it the first time there is a tick box about adding an extra sensor but it is a double negative question, extra to misread it.
Simple solution is to run the process of adding the device again in local tuya (don’t delete the one you have) this time round it will provide you the next sensor.
Can be a while between the days I check in on this forum but I will check over the next few days to see if you have sorted this or need a extra hand.
Also the other thing I have found it that if you had the standard Tuya, I had issue is a device was in this plugin even if the plugin was disabled so delete this plugin if not required.

Thanks Myle, I connected support and they were super helpful and sent me a replacement, once the replacement came I open up this unit to see what the issue was and tracked it down to this, thought I’ll see if I could get the replacement this part and have this in the garage. It’s so funny as I reuse it today to test a possibly fault I found and couldn’t remember how bad it was, like a dog whistle:). Might try epoxy on it to enclose the sound, nothing lost as it is only for parts.

Cool bro good u getting a new one

Thanks John (from another kiwi).
I have done this already and this is why I was so confused in the first place getting it working, I literally only get id “5” show up in the list.
If i run through it again, as thought perhaps that was the temp (and it is) the switch would appear second, it does not. I can’t even manually enter “1” as the id or leave it blank. Just throws errors about id already being added (correct) and can’t leave it blank.
I do have the Tuya integration on there, I also did try removing it and re-running the whole thing, but same result.
Think it is worth resetting the kettle? If I do, any ideas if it then changes the device key?

Hi Sean, over the last few days I’ve been tracking down another bug in the Kettles firmware and yesterday I went to re-add it back to Tuya local. I can confirm I’m now seeing the same issue as you (only id5). if I manually add the config of the kettle to the configuration file it will add id1, but the state is Unavailable. I’ve tried different browsers, redownloaded Tuya local and tried that as well. At the moment I’m not having much luck.

I’m wonders if something ahs changed in Tuya IoT environment??

Resetting the kettle doesn’t appear to alter the device key but resetting to factory settings in Tuya IoT does reset the local key.

For reference this is what I have in Tuya


  • host:
    device_id: 7XXXXXXXXXXXXXXXXXd
    local_key: 6XXXXXXXXXXXXXXXXX4
    friendly_name: Tuya Device
    protocol_version: “3.3”
    • platform: switch
      friendly_name: kettle
      id: 1
    • platform: sensor
      friendly_name: kettle_temperature
      id: 5
      device_class: temperature
      unit_of_measurement: C

Update: I now have it back but don’t know which of these work
I changed a few things and when I rechecked I noticed the kettle was back, I’m unsure which of these helped

  • Change my login to Tuya (smartapp) to a simple login without any special Characters.
  • set up the native Tuya Integration in Home assistant and configured it.
  • Restarted my phone during logging into Tuya incase my phone had a log on how many connections could log into Tuya at once.
  • While phone was still restarting, restarted Home Assistant

All weird stuff but both kettle sensors are back and I deleted the native Tuya Integration

1 Like

This is the exact issue I am having, after a couple of goes, I managed to get a DPS index of 102.
Not sure what this was, but thought it may have been the switch, but apparently not, since after adding that index, I am getting a bunch of log entries saying the DPS doesn’t exist.

My config if I do it in yaml is the same.

Will give these a go, thanks! Glad to know at this point its not just me.

Ok, just given that stuff a go and at first the switch didn’t work, just showed unavailable, but it now appears to be working!
I think what it maybe is too many connections. As I’ve logged out on my phone, then connected using the Tuya integration (again), but that always hits the rate limit when first adding. Now that the phone is logged out, the rate limit must be down enough that local works.
That is just my best guess at this stage, but its working :slight_smile:

Great to hear I thought it could be the phone as well hence why I reset it. But as you say you have it working.

I also saw another DP of 102 which just returned the work current temp, didn’t use it.

Yer it didnt re-appear on re-adding it, but as you’ve said its the work current temp, it will only appear when it’s boiling, which makes sense as I turned the kettle on in a hope to get it to add.
Will ignore it, rather not have all those log entries.

Thanks so much for your help on this one :slight_smile:

I had the same problem and found that DPS 1 gets accessible (and the switch becomes available) after I used the app to turn on the switch. This seems to survive a restart of HA when the restart is done via Server Controls.