Life360 update 0.95.4

Hi Everyone,

I realize that Life360 is now a standard integration and I’m having a lot of trouble setting it up. I have stripped it right back and still getting errors.

Forgive me but I’m unsure how to share the code correctly but it is as follows.

life360:
(two spacess)accounts:
(four spaces)- username: way*********@gmail.com
(six spaces)password: ******

As the instruction say and its still not working. Can anyone please help?
Some advice on how to share code would be great also!!

Section 11 and 13 of this post will help with formatting code and sharing error message: How to help us help you - or How to ask a good question. You said you’re getting errors but didn’t actually say what those errors were.

But the easiest way to get up and running is setting it up through the Home Assistant UI. Open the sidebar and select Configuration > Integrations > + button in bottom right > select Life360. All you do is enter your Life360 username and password and you’re done. It’s impossible to mess up the YAML when adding it through the UI.

1 Like

True, but an account entered via YAML will take precedence over (the same account) entered via the UI. So the easiest way is to delete all life360 related configuration from the YAML files, restart, and then enter the account(s) via the UI.

@Wayne_Perryman, if you did set it up like you said, it should be working. Unless you have remnants from the original custom integration. If you do, you have to delete all of that.

I commented them all out (so effectively deleted them).

The error is this: Setup failed for life360: No setup function defined.

I’ll try through the intergrations.

Did you use the custom integration before? Is anything named life360 anywhere inside <config>/custom_components, or even inside <config>, or any sub-folders? You need to delete that, not just move it or rename it.

ok I’ll try that.

BTW there is no intergration option in my list.

Classic symptom of remnants of the custom integration lying around inside <config> somewhere.

this
  is
    a test

Thanks mate I was putting ’ instead of `

THANKS PHIL!!

I never knew the old custom components would affect it like this, a very valuable lesson learnt!

integration is showing up now and working a treat, thanks again

1 Like

It is step 1 in the transition instructions. :slight_smile:

so it is, sorry.

How do I get the “place” to display instead of ‘away’ or ‘home’?

You create HA zones from the Life360 Places. See the doc page. The feature to automatically create/update HA zones from Life360 Places was removed during the “standardization” process.

Or you can create a template sensor that shows the place attribute.

This did it, thought I’d share…

sensor:
  - platform: template
    sensors:
      wayne_life360:
        friendly_name: "Wayne Location"
        value_template: "{{state_attr('device_tracker.life360_wayne', 'place') }}"
2 Likes

Hi, can i just check regarding what states are available for automation’s?

Before the integration was released i was able to use ‘home’ and ‘not_home’ to trigger automations. This appears to have been altered (based on my old automations not working) and from what i can gather from the integration page is that is now ‘moving’ or ‘driving’ as the alternative states to being home?

any help appreciated.

This is the portion of your Life360 configuration where moving and driving are set:

  show_as_state:
    - driving
    - moving

If you don’t want that behavior you can safely delete (or comment out) those lines from your configuration.

Question. I’ve never setup Life360 before, so I went integrations added my account, but it doesn’t work.

I get this error

HTTPSConnectionPool(host='api.life360.com', port=443): Max retries exceeded with url

any thoughts?