Lifx Integration Implementation Issues

I recently updated my hass install from 75.3 to 83.2. In doing so I have run into issues with a few of the large changes that have occurred within hass. One of my biggest issues is my Lifx lights no longer are detected by Hass. I have read over the new lifx docs and have removed the old lifx platform under lights and activated lifx under integrations. However when i reboot hass i receive the below error on start. I’ve googled around and asked on the hass discord channel but I have been unable to find any resolution or any actual information regarding the error. Anyone have any ideas? Thanks

2018-12-02 15:32:21 ERROR (MainThread) [homeassistant.components.light] Error while setting up platform lifx
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/", line 128, in _async_setup_platform
    SLOW_SETUP_MAX_WAIT, loop=hass.loop)
  File "/usr/local/lib/python3.6/asyncio/", line 358, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/light/", line 151, in async_setup_entry
    lifx_ip_addresses = await aiolifx().LifxScan(hass.loop).scan()
  File "/mnt/config/deps/lib/python3.6/site-packages/aiolifx/", line 1283, in scan
    (done, pending) = await aio.wait(tasks, timeout=timeout)
  File "/usr/local/lib/python3.6/asyncio/", line 304, in wait
    raise ValueError('Set of coroutines/Futures is empty.')
ValueError: Set of coroutines/Futures is empty.```

Wowsers that’s a jump, I’m normally a release behind, but wow.

If possible (i.e. easy) spin up a test clean install on the lastest version and copy your config over.
I’m thinking maybe something was missed jumping that far up the chain…

Ya tend to stick to working versions for long periods because I always run into some sort of issue when I update. I’m sure the waiting only causes more issues though :man_shrugging:

So I more or less did what you suggested. I’m running on a FreeNAS box and spun up a new jail with the latest version of hass when I did my upgrade. My old install is on a separate jail so if things got really nasty I could just spin the old one back up. I am sharing the same configs between both jails though (but only 1 hass jail is running at any given time)

NFS share mounted/passed through ?

I tend to upgrade once the release changes to .1 or .2 rather an .0 at the very end

The share is handled by FreeNAS itself so I don’t believe its an NFS share but more just a drive mapping within the jail to the box’s local disk. Honestly I’m not super in touch with the nitty gritty details of FreeNAS.

It does basically work the same way as a NFS share would though.

See here: LIFX intergration unknown error

@amelchio Oh snap! This totally worked, thanks a ton! Felt like the stone age again having to use the lifx app w/o my automations. :smiley:

In the event someone stumbles on this to fix a similar issue below is a more in depth report on what I saw.

  • Updated to 83.2
  • Removed lifx.yaml file that included the old platform: lifx configuration
  • Attempted to activate Lifx under integrations - Resulted in error seen by op at @amelchio’s link
  • Restarted hass
  • Retried activation Lifx under integrations - The UI showed it as working
  • No lights were found
  • Restarted hass
  • Still no lights
  • Let it sit for a day - previous Lifx component wasn’t always fast to discover lights sometimes takin an hr or more. hoped it was related
  • No lights showed up
  • Checked logs, noticed error on start up
  • Restarted hass
  • Confirmed the error persisted
  • Restarted hass
  • Yep deff still there :slight_smile: