List of working ZigBee Bulbs for deconz / zha (without special manufacture gateways)

Hello, I was looking for an up to date summary of cheap (or moderate cheap) ZigBee Bulbs (pretty basic, so no RGB or anything) that I can directly integrate over deconz or zha with my ConBee ll stick. I’d like to avoid Bulbs which use Wi-Fi.
I recently bought an OSRAM Smart+ E27 LED and I can’t even get it connected / show up in deconz or zha without their corresponding gateway, which is not what I expect when using a standard communication like ZigBee. Other people seemed to achieve a pairing, but even when I reset the bulb and put it in pairing mode it will not get connected. To avoid such things in the future, especially when buying larger amounts of bulbs, I’d love to have a list or a recommendation of bulbs which usually works out of the box with HA and a ZigBee stick. Thanks in advance!

Your best bet is the list you can see at Zigbee2MQTT You can find it here.

The problem with such a list would be, that someone with time has to update and maintain it, and I’m sure, that will be kind of a nightmare. That has to do with the way these zigbee handlers are implemented.

Normally the first is Zigbee2MQTT. If the device is recognized by Z2M, it takes a few weeks/months for these devices to get supported by ZHA or deConz. Problem is, the hard work is done by Z2M and not the other platforms. They “simply” take the handlers from Z2M and fit them into their code.

That would mean, you would have to monitor the list from above and try the different devices yourself… :wink:

IMHO you should simply move from ZHA to Z2M. There you’re up to date, even the Osram bulbs work without any problems. Couldn’t for the life of me get them to work with ZHA.

The thing is, why wait for someone to update ZHA, if the devices already run with Z2M. In a year or so, if you haven’t gotten some new bulb models, you can move back to ZHA or deConz. In Germany we have a saying, “why talk to Hänschen, if you can talk to Hans as well”, meaning “why talk to lower level, if you can as well talk to the big boss right away”. Why trying something like ZHA, if you already have Zigbee2MQTT? :smiley:


Thank you for the extensive answer. I did not know that, so I will probably give Z2M a shot, since I haven’t used it up to now.

yeah, but this list is not really up-to-date… The Osram bulbs we are talking about here are not listed for Z2M nor ZHA. The Tradfri remote isn’t even listed at all… :slight_smile: It’s always the maintenance that lacks… :wink:

Are you using HassOS or supervised install? The Zigbee2MQTT addOn is really good, works like a charme. I have Zigbee2MQTT as addOn running on my HA machine and two times as a Docker container on plain RaspberrryPis. All three work without notice, that’s always the best. :slight_smile:

I have been using a supervised docker up till today, but I switched to HassOS today (both on a RPi 4 8 GB).
Currently, have Z2M with the Conbee ll and latest firmware, but cannot connect to my stick. Seems like this is not an uncommon issue. Have you also encountered such an issue?

I’m with @DurgNomis-drol. I always check Blakadders site for things zigbee related

1 Like

Yeah i know, but i a least gives a some one a good idea if it is supported or not. I use usually just do a google search before i buy a device to see if its just plug and play or if there is something that is need to be done.

I use deCONZ by the way :smile:

Fortunately not, but I’m using three dirt cheap CC2531 I got from Amazon for seven Euros… :smiley:

But the first issue you mentioned seems to be, because there is ZHA and Zigbee2MQTT running, that can not work.
The second one suggests that reflashing the CC2531 with a new firmware solves the issue, but this is from an openHab user, so maybe not affecting HA?

I’m running the “unsupported” supervised install for HA on a RPi4 with 4GB. But as long as it’s running, I won’t change it. If the time comes I’ll change either to “supervised on Debian” (supported) or to Docker install. :slight_smile:

It seems that the Conbee ll and some other sticks need an extra line in the config:

If anyone else struggles here, just add this:

  adapter: deconz # deconz for Conbee II OR "zigate" for the ZiGate USB-TTL

now I can connect to the adapter over HA

You said, you were able to connect OSRAM over the Z2M Integration? I am currently trying to connect my OSRAM E27, set it to pairing mode, but I can’t find it in Z2M either. Could it be a newer model and therefore not be supported yet? But as far as I can see in the docs, it should be supported: OSRAM SMART+ classic E27 TW (light), It’s this one:

Strange, that is exactly my type of bulb. I even ordered it from (i checked my orders) for €7.99… :rofl: :rofl: :rofl:

It’s working for a few months now and I can’t remember, that there was anything unsual. I waited a few weeks until it came up as supported and then tried again to pair and all worked without a hickup… :slight_smile:

Describe the process you’re going through with reseting and pairing, maybe there is something off…?? :thinking: :flushed:

This is indeed very strange. I’ve set up Zigbee2Mqtt on a fresh RPi 3 install, to check if the stick was working. Now I tried to pair the bulb, and it took less than 1s to discover / pair it without Home Assistant, just on Raspbian.
Resetting and pairing is switching the bulb on - off for 5 times, at the 6th time the bulb flashes shortly after turning on, indicating it’s reset and ready for pairing.
Both, the clean Pi3 and the Pi4 for HA have the MQTT stick directly in the USB2 (Grey/Black ones, not the blue) port. The only difference was, that now in this test the stick was literally at the lamp, while my HA Pi4 is 1.5 m away mounted at the wall. I’ve read other people having issues with the stick when not using a USB dongle, while also booting the pi from an SSD (I don’t use SD but SSD over USB3). If I manage to get a USB dongle I could try using one.

Well, now I am out of ideas. I also tried with a USB dongle, as well as removing my wyze gateway from the other USB port and bringing the lamp very close to the zigbee stick but had no success pairing it over the Zigbee2Mqtt integration in Home Assistant. However, as previously mentioned, I can pair the lamp by directly using a Pi without HA. Maybe I will get another ZigBee stick for further testing. The CC2531 should be a good one?

The CC2531 has Z-Stack issues (and has had them for awhile now). I’m using the CC2652P2 from here: Tube's ZB Coordinators and Routers (was Zigbee router on steroids?) ( The best thing about using a Zigbee router with an ethernet connection is that if there is a device that I have to pair in place with a weak signal, I can literally move the router anywhere I need to.

I think your issue might actually be due to power issues at the stick. If I’m reading this correctly, you have a SSD along with a wyze gateway plugged in? It could be that your other two devices aren’t leaving enough nominal power for the Zigbee router. rPis are very finicky when it comes to supplying power to USB2/USB3 devices. The fact that you had a successful pairing off another rPi with just the Zigbee router plugged in leads me to believe that it’s a power problem.

This idea occurred to me as well, therefore I already removed the Wyze Gateway. In theory, the SSD and the ZigBee should get enough power, but is there a way to verify this?
Shouldn’t also the Zigbee2Mqtt integration throw any errors if there is an issue with the power?

Anyway, I’ve set up a plain installation (edit: An installation of Home Assistant if that was not clear) with a SD Card and only the ConBee ll plugged into the RPi 4. With this setup I was able to connect the bulb, which confirms the assumption that the Pi seems not to be able to handle both, the SSD and the ZigBee Stick (even without the Wyze GW, only ZigBee + SSD it was not possible). I’d love to have a solid measurement to verify this theory. I’ve seen other people using the ConBee ll + external SSD over USB without any problems. Furthermore, I am using the Official RPi4 power cable, so this shouldn’t be the issue.

Using a SD seems to fix this issue, but I’d love to use a SSD because it’s faster and more important: more durable than a SD (using a Kingston A400 SSD with an Inatreck Case).