Little help needed by a newbie

I joined so that I could post and ask a couple of questions, having started using Home Assistant this week. Might you be able to point me in the right direction or help answering the following queries please?

  1. Is there a way, thought the HA web panel, to configure wireless connection settings for my home network? I don’t have a USB stick handy, and I’d really like to find a quick and easy way to get my Pi hosted Home Assistant instance, connected to my wifi. This mainly so I don’t have to have the network cable trailing across the floor while I get started. Problem is I can’t find anywhere in the panel that seems to enable me to do this, I’m sure that it must be there somewhere! I’d be surprised if the only way to configure a wireless connection, is to create separate partitions and create a CONFIG folder on a usb drive?

  2. I’m trying to get ssh working (partly related to the point above), I’ve installed the ssh and Terminal add-on. I’m unable to access the web terminal and ssh-ing from my Macbook says connection refused. So far I’ve tried adding password and auth keys… but no luck. I’m getting 502 Bad Gateway errors when I try to access the terminal web panel, ssh-ing from MacBook just gives me connection refused, have the below trace in the add-on log. I’d really appreciate some help/support please!!!

Many thanks, Matt

[s6-init] making user provided files available at /var/run/s6/etc...exited 0.
[s6-init] ensuring user provided files have correct perms...exited 0.
[fix-attrs.d] applying ownership & permissions fixes...
[fix-attrs.d] cli: applying... 
[fix-attrs.d] cli: exited 0.
[fix-attrs.d] profile: applying... 
[fix-attrs.d] profile: exited 0.
[fix-attrs.d] ssh: applying... 
[fix-attrs.d] ssh: exited 0.
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts...
[cont-init.d] executing... 
[07:29:09] INFO: Restoring host keys...
cp: can't stat '/data/host_keys/*': No such file or directory
[cont-init.d] exited 1.
[cont-finish.d] executing container finish scripts...
[cont-finish.d] done.
[s6-finish] waiting for services.
[s6-finish] sending all processes the TERM signal.
[s6-finish] sending all processes the KILL signal and exiting.

Funnily enough there is a new component to the supervisor which should help with this! The Supervisor joins the party

As for the ssh & terminal addon, perhaps post your config (with the passwords or other sensitive info replaced)

Thanks for the reply Nick. I took a look at the Supervisor, looks like it’s heading in the right direction… but I don’t think that there’s anywhere that I can set wireless settings yet, is that right? If so, any idea how long it’ll be before it’s there?

I’ve attached a screenshot of my config for ssh - it’s basically the default config, with a password added. I’m then using ssh (command below) to try to access it:
ssh [email protected]
… I get connection refused. I’ve tried restarting etc, no joy. I’m getting “502: Bad Gateway” when I try to access the terminal web panel.

Any help very much appreciated!

Cheers, Matt

That may be so, it is new and I haven’t actually used it. Your post made me think of this new feature.

The ssh stuff looks right, but I think you may need to restart HA.

Have you tried the other SSH add-on - SSH & Web Terminal?. I’ve found that easier to get working.

OK so, after some tinkering I managed to get it working!

I removed and reinstalled the SSH & Web Terminal add-on. Then took a more detailed look through the log, it seems that the temporary password I had entered while initially setting this up, had been found in the haveibeenpwnd database, meaning that (despite the config panel telling me otherwise) the service wasn’t actually starting. I’m now able to ssh in from my MacBook and via the terminal web panel.

Cheers for the help with this one. Next job is to get wifi settings sorted, I think that I’ve seen a HA config file change, that I can make via ssh to do this??

How is it best to report ssh issue that I was having to the developers/community, with suggestions of how the UI/reporting could be improved?? Is the GitHub the best place to do this? Or is there some other mechanism perhaps?

Cheers, Matt

Further to the topic above, I’m still having issues getting Wifi working. Is there a way, through the web-panel, to tell if (and if so, what) config has been loaded from the USB at boot??