Login For Web Front End

Hi Guys,

For some reason, my bookmarked HTTPS address of no longer works so I had to go back to the HTTP address.

When I tried to login using my email address and password, it failed, so I logged in using the API password. The API password is in my configuration.yaml file and is similar to my password for when I use the email address (the case is different for one character).

I’m not sure why my email address and password combination isn’t working. Once logged into the front end via the API password, I can click on “Configuration” on the left hand menu and that shows my email address. If I click on the Home Assistant Cloud option and choose “Manage Account”, it takes me to the nabucasa website where I can log in using the email address and password. Wouldn’t this be the same combination used for logging into the web front end?

To clarify:
API Password: Notmyrealpassword

Home Assistant Cloud:
Username: [email protected]
Password: NOtmyrealpassword (the only difference to the API one is the capitalisation of a character)

Logging into
Username: [email protected]
Password: NOtmyrealpassword (doesn’t work)
nor does
Password: Notmyrealpassword
nor does
Password: notmyrealpassword

When I first set up HA, everything was over my head and I can’t recall everything I did. Is it possible I never created a username/password combo, but if so, where did the home assistant cloud email/password combo come from?

How do I update my account so I can log into using a username/password rather than an API, or should I not worry about it and just use API?

Thanks in advance.

Go to the site below and scroll to where you see “troubleshooting” and likely more specifically “lost owner password” and follow the instructions to delete your account and start over.

Logging into the frontend has nothing to do with your cloud credentials.

You created a user/password at some point in your home assistant install or upgrade. It was forced after version 0.77.x(?).

You can actually see your usernames in your config directory, under a .storage directory (note the period in front of the name, it is a hidden directory). Open ‘auth’ file in a text editor and you will see your username there.

I must be as thick as 2 bricks as I couldn’t get to this directory. I went to Windows Explorer and tried to “force” it to open the hidden directory by adding it into the address bar (this usually works for hjidden Windows folders). Here’s a screenshot of the error message when I tried it.

It then suddenly dawned on me that perhaps I should try a “name” for username rather than my email address (I thought either would have worked).

I’ve managed to log in using my username and a variant of the password. It looks like the password for my username, cloud and API are all slightly different as to caps, but using the same characters. I’ve now recorded all 3 combinations down in a file so I won’t forget.

Speaking of authorisations, my HomeAssistant app no longer works but this isn’t a surprise since my web front end doesn’t work with the HTTPS address now. The address is still the same: https://MyHouse.duckdns.org:8123 but I get a message saying javax.net.ssl.SSLHandshake Exception

Why has HTTPS stopped working and what are my options to get both:

working again?

Should I remove the security layer, and if so, how?
Do I need to pay the $5 month for access?

Thanks in advance.

Notice how I said the period in front of the name is important? Your screenshot doesn’t show that you tried to go to .storage.

But your login for your Home Assistant install (the local install) has no knowledge of your email address. It has nothing to do with your Cloud account.

Did your certificate expire? Only you would know that.
If you are forcing certificates, you will have to use https. http will not work if you are forcing SSL.

It’s all in your home assistant configuration.yaml

What? No. Please read what the Cloud account is for…

I thought I had tried both (with and without the period) but I must have been mistaken. As for the screenshot, I just took the last attempt (ie first attempt was with the period (or so I thought), 2nd attempt was without). My bad. I just tried again and it worked.

But I didn’t know this. Many sites use an email address for a username, so I mistakenly thought my username was my email address.

As I originally wrote, when I first set up Hassbian I was dealing with a lot of new stuff (including working with a Pi), so I was just following instructions and did it over a few days and simply forgot what I had done at that time. Then when it asked for a username, I thought my email address was the username. Sorry.

I’m just a “average” user who’s trying to get my home a bit more automated and do some cool things using Google Home and other “smart home” devices eg wi-fi plugs, lamps etc.

I had followed the instructions on how to set up port forwarding and a duckdns account plus encryption and it was working, but since I’m not knowledgeable in computer security (other than installing security software packages), knowing anything about certificates, including their expiry, is over my head.

I am now going back over this page to learn about renewing certificates. I’m currently at the point of trying to work out whether I’m a one-rule or both-rule setup.

I did hash out the 2 lines, but this was only because I was trying to get TTS to work and did this based on a previous post I made. Once again, I didn’t understand (or know) that perhaps my underlying problems were due to my security certificates being expired.

In the post linked above, I expressed my confusion as to what it truly offers. It says:

With the Google Assistant integration for Home Assistant Cloud you’ll be able to control all your Home Assistant devices via any Google Assistant-enabled device.

Now I gather “Home Assistant Devices” are things like my Yeelink Lamp etc.
I gather “Google Assistant-enabled devices” are my Google Home and Google Home Minis.

Well currently I’m not a subscriber but I can ask my GHM to turn on my Yeelink Lamp, but the above statement seems to imply that it’s the subscription that will allow this. Hence my confusion since I can do this now.

Once again, I apologise for my lack of computer programming and security knowledge. I come across something that looks interesting (eg currently I’m trying life360 to get it to automatically send messages to the wife such as when I’m leaving work) so I muddle through the tutorial or YouTube video and hopefully it works. When it doesn’t, I try to figure it out but when I can’t, and I’ve given it a good go, I come to the forums looking for guidance.

Thanking you.

did you setup the yeelights in Google Home independently of Home Assistant? (This is the way I am setup and I can control yeelights directly even if my HA shits the bed)

Yes. I installed their app and created an account and then in the Google Home App, I linked to that account.

I had these before I started dabbling in Hassbian as my initial venture into Home Automation was with a Vera Edge hub and Z-wave devices. Vera’s linking to Google was problematic and many others were having similar issues and after 6 months of no performance improvement, I looked around for alternatives and heard of Hassbian.

My issue with Vera was that when it did work, it took up to 20 seconds from asking Google Home to turn on a lamp (plugged into a z-wave socket controlled by Vera) and often I would wonder if it had failed since it was taking so long.

I was referring to that… If they are setup in Google directly you don’t need a subscription to control them via Google. To control via Home Assistant you need to set them up in Home Assistant as well.

The Cloud account is nothing more than a simplified way to connect Home Assistant (not your random devices you have connected to Google Home), to Alexa or Google Assistant. There are a couple of things you need to know about it:

  1. You can absolutely set up a link between Home Assistant and Google or Alexa for free. It is a component that you enable but it will require a few brain cells to set up (even I had a rough time the first go-round).
    Google Assistant - Home Assistant

  2. You don’t need it to control your devices that are connected to Google or Alexa outside of Home Assistant. It is ONLY a link between YOUR Home Assistant and Google or Alexa. It is not mandatory, and if you don’t feel like you need it, you don’t have to bother with it.

  3. If you DO want it, you do NOT have to expose your Home Assistant to the internet. It is a secure link between your HA install and HA’s Cloud Service that will connect to your Google or Alexa account.

Correct. It is stating that you will be able to control your Home Assistant devices via any Google Assistant enabled device. It does NOT mean that it is the only way, nor does it mean that you HAVE to connect to the cloud to USE Google Home devices (as media players for example)

I just read your other post. You seem really lost at this point.

Honestly, if I were you, I would save my configs somewhere, and start over. Install hassio or something super simple and then set up your devices again. You need to be reading the documentation on the components and how to configure them wherever possible. The frontend (http) is a component that has most of the answers you have been asking about in regards to http/https/base_url/etc. You had a Cloud account and the free trial expired, so you should just comment out the line in your config that says cloud:

You should consider moving to something easier to manage, and going through everything step by step. Start anew and you will probably learn a lot more than fumbling around with errors you don’t understand right now.

1 Like

Yep, I probably am.

I guess my problem was that I didn’t know which “flavour” to use and I saw lots of people talking about Hassbian so I went with that.

After installing it, I watch various YouTube clips such as this one which shows how you can use Life360 to do cool things such as send a notification to the missus when I leave work. Since I finish work late at night and sometimes have to work overtime, this would be good, rather than having to type up a message.

I can also use it in the future when I give my 11 year old daughter a phone so I know where she is at any point in time.

I guess my confusion comes about because most tutorials/YouTube etc talk about what you can do with “Home Assistant” and it appears that Hass.io, Hassbian etc look similar (from what I can tell), so it’s hard to know which “flavour” to use.

I had started also playing with a “lovelace” yaml file. What my ultimate goal would be is to have a cheapish tablet that has a “static” view - perhaps a rotating background of family snaps from a Google Photos folder with the current date/time, weather and forecast on it.

Then you could swipe/press (whatever) to go to various screens such as one for the Master Bedroom etc where you could turn on and off lights in that room.

Lastly, I plan on having a couple of HikVision cameras installed plus a SkyBell HD Door Bell. It would be good to be able to swipe/click on a tab to see those feeds, and with the doorbell, perhaps for it to automatically show the feed when activated.

I can see the possibilities, but with limited time and not much programming knowledge, it’s hard to know the best path to go along. So in this case, I picked Hassbian and I find little projects (eg Life360) and might spend a hour here and there (sometimes weeks apart due to other commitments) trying to get it to work.

So if you reckon Hass.io is the way to go, I’ll give it a go.


Just to show how useless I am, I tried following the instructions here under point 8 to give me a badge to show how many days left for my security certificate so it doesn’t happen again and after multiple restarts, still no badge.

I PuTTY’ed into my Pi and ran the 2 commands:

$ sudo apt-get update
$ sudo apt-get install ssl-cert-check

(shows version 3.29-1 is now installed).

I then put the following in my configuration.yaml file:

  - platform: command_line
    name: SSL cert expiry
    unit_of_measurement: days
    scan_interval: 10800
    command: "ssl-cert-check -b -c /etc/letsencrypt/live/examplehome.duckdns.org/cert.pem | awk '{ print $NF }'"

changing just examplehome on the last line to what my duckdns address is.

Saved the file and did a restart and no badge. Boy I’m useless.

  1. Stop looking at YouTube and random tutorials on the internet. My guess is 99% of them are outdated because of changes in Home Assistant from release to release.
  2. HASSIO and Hassbian are merely different WAYS to INSTALL Home Assistant. Once installed, it’s the same Home Assistant. HASSIO is more ‘appliance like’ similar to buying a router, you plug it in, and it works. You enable the features you need (add-ons) and use it.

You don’t have to know how to program. You just have to know how to edit text files. You are not writing any code here, the devs have done all that for you.

Are you using GROUPS or LOVELACE? You have to add the badge to a view if you are. Do you have other sensors? If so, you can’t list each one out with sensor: You have to put them all in a list or use separate files. Literally all of which is covered in the official documentation, which you should read rather than relying on outdated tutorials on the internet.

1 Like

I went through my known_devices.yaml file and changed the track option to alot of them from True to False to reduce the number of badges at the top of my page.

I now have the badge but it just has text showing - screenshot. If I click on it, it shows this.

Well I was using this documentation which says:

Save the configuration.yaml. Restart Home Assistant.

On your default_view you should now see a sensor badge containing your number of days until expiry.

So I’m following instructions but when it doesn’t work, I come here looking for help as to why. I’ve followed the instructions (not outdated tutorial) but my badge doesn’t show the number of days remaining, but the documentation doesn’t say what to do if it doesn’t. It assumes it will work.

I wasn’t even referring to that piece…

I was referring to all the other questions you have about configuring Home Assistant.

I guess there really isn’t any way for me to relay my thoughts to you, so I will bow out of the conversation. It seems no matter what I say, you aren’t really getting it.

Ignore your certificate, and start over!

Sorry, I thought you were since it was immediately after my quote about the badge not working.

Sorry I upset you. Thanks for your advice.