Lovelace: Bringing back entity-filter (monster-card)


#61

Is it possible to sort the items in the list according to a value?
For instance I want to sort the battery list of my sensors depending on the battery value.


#62

monster-card appears to be broken in the latest version of HASS (0.80.3). There is the following Javascript error:

Uncaught (in promise) TypeError: localize is not a function
    at computeStateDisplay (app-9adb0896.js:2830)
    at HTMLElement.renderEntity (b79a536a7632adf704c1.chunk.js:1091)
    at lit_element.c.entityConf (b79a536a7632adf704c1.chunk.js:1043)
    at containerPart (3e07c1dec7bef00d5ca3.chunk.js:221)
    at NodePart.commit (a889fa21cf4c29228072.chunk.js:133)
    at TemplateInstance.update (a889fa21cf4c29228072.chunk.js:169)
    at NodePart._commitTemplateResult (a889fa21cf4c29228072.chunk.js:133)
    at NodePart.commit (a889fa21cf4c29228072.chunk.js:133)
    at render (a889fa21cf4c29228072.chunk.js:181)
    at Function.shady_render_render [as render] (a889fa21cf4c29228072.chunk.js:61)

Edit: Was getting this error when using the glance card. It appears to be fine when using the entities card. I don’t know if other cards are affected.


#63

so i’m torn between whether i use built in entity-filter or monster.

my understanding is if you want an easy catch all (all lights that are on) to be displayed, monster may be easier because of the include / exclude feature that entity-filter doesnt have right? i see it being a huge PITA having to list every single entity manually. this becomes more challenging and problematic if you add new sensors, ad you would need to manually remember to add it into the card every time a new device is added.

isn’t the “unused entities” view essentially like a monster card that is a catch all?

could i use a built in entity filter to list all light that are currently on without having to statically assign every light i have? from what i’ve been reading i think my answer is no, but things seem to change fast, so i figured i’d check before diving deep into the config


#64

I’d like to create a card that shows any guests in my house.

I use DHCP and all of my devices either have a static IP or a reserved IP.
If a guest gets on my network, they will get a DHCP address in a certain range… x.x.x.220-240
Can a monster-card show all devices with a certain range or is there any other way to do this?

thanks


#65

I’m interested too in this awser.

The only way I found to do this is to create template sensors for each battery and filter on these template, but I’m too lazy to create +30 template sensors :slight_smile:

Any idea ?


#66

I guess this could be done with some update to the card logic to allow some sort of rudimentary regex to the card patterns. Can you please raise an issue on github?


#67

I’ll have a look. Can you please file a bug report on github?


#68

Thanks, I had raised a bug regarding this, and it appears to have been fixed in 0.81.1


#69

Done -> https://github.com/ciotlosm/custom-lovelace/issues/219
Thanks for your support.


#70

Something happened with the recent update to 0.81. Until 0.80x everything was perfectly working for the below configuration: whenever a light or an entity_id starting with switch.lightxxxxxx was ON, would appear in frontend.
After updating to 0.81.1 wy light “switch.light_master_bathroom” when is ON does not show up … any clue?

  - id: bc6d27ee ccef05219  # Automatically created id
    type: custom:monster-card
    card:
      type: Entities
      title: Lights that are ON
      show_header_toggle: false
    filter:
      include:
        - domain: light
          state: on
        - entity_id: '*switch.light*'
          state: on
      exclude:
        - entity_id: light.garden
        - entity_id: light.hallway

#71

Also tried to change as below, but same problems

include:
        - domain: light
          state: on
        - entity_id: switch.light*
          state: on

#72

Hello,
I want to show my climate devices only if the weather temperature is higher than 24 degrees. As I only use them for cooling.

  - type: custom:monster-card
    card:
      type: entities
      title: Climate Monster
    filter:
      include:
        - domain: climate
    when:
      entity: sensor.dark_sky_temperature
      state: '>= 24'

It seems that the state requires static numbering. Is it possible to have a number comparison?


#73

Is it normal the monster cards don’t support media-control cards (or any other than entities and glance)?
I finally was able to create a card displaying any media_player.plex playing but I seem to be stuck using entities or glance which isn’t great for media players…

  - type: custom:monster-card
    show_empty: false
    card:
      type: glance
      title: Plex players
    filter:
      include:
        - entity_id: "media_player.plex*"
          state: 'playing'

#74

no more support for this card? :grimacing:


#75

Does anyone has any idea why the when option is not working? I have the following card and it is not working properly. It should hide all the card when my sensor is in that state, but nothing happens:

      - type: custom:monster-card
        show_empty: false     
        card:
          title: You forgot to turn off
          type: entities
        filter:
          include:
            - entity_id: switch.*
              state: 'on'
            - entity_id: media_player.*
              state: 'on'
          exclude:
            - entity_id: media_player.*phTV* 
            - entity_id: switch.*phTV*
          when:
            entity: sensor.who_is_home
            state: 'nobody'

Card is displayed as you can see:
image

but it should be hidden because the sensor is in it’s value:
image

Let me know if someone has any idea or if i configured wrong something.
Cheers!


#76

Found the problem, there was wrong indentation for the when condition.


#77

Loving the monster card. I’m about to make the empty cards hidden but before I do this is what I’m using it for:

EDIT:

Is there a better way to include all unavailable entities?

type: 'custom:monster-card'
show_empty: false
card:
  type: glance
  title: Unavailable
filter:
  include:
    - domain: sensor
      state: unavailable
    - domain: light
      state: unavailable
    - domain: switch
      state: unavailable

#78

HI @ciotlosm,

I’ve tried to combine your monster card with a custom:mini player from @kalkih but without success.

My goal is to have a filtered card that show which media player are playing arond the house.

This is the error I get:

http://myIP:8123/local/monster-card.js?v=0.2.3:112:22 Uncaught TypeError: this.lastChild.setConfig is not a function

Can you please help me?

Thank you in advance


#79

Good day, using this card to automatically pull switches generated by ha-dockermon. all switches have the following syntax:

switch.ha_dockermon_appdaemon
switch.ha_dockermon_booksonic
switch.ha_dockermon_cloud9

using this configuration:

- type: custom:monster-card
  card:
    type: glance
    show_state: false
    title: Support Services (HASS)
  filter:
    include:
    - entity_id: "*dockermon_*"

the UI presents them as such:
HA Dockermon appdaemon

is there any configuration in the card that would allow removing the “HA Dockermon” part?

thank you


#80

Hi All,

I’m trying to use the monster card but since updating Hassio I don’t have the ui-lovelace.yaml anymore. How or where do I insert the “resources:” portion of this. Thanks for any help!!!

Scott