Lovelace: Firemote Card - Remote controls for Amazon Fire / Android devices

@maurizio53 - Could you copy/paste your YAML config here so I can better understand what the issue might be?

@jlt1267 - You shouldn’t need to use “strong” mode, unless you’re OK with the degraded response time. Instead, I suggest making sure you’ve downloaded the latest version from HACS, selected the proper device type (in your case, the 4K Max), and read through the FAQ section on the GitHub page that discusses this very topic:

Here it is:

                          - type: custom:firemote-card
                            entity: media_player.fire_tv_camera_letto
                            device_type: fire_stick_first_gen
                            compatibility_mode: default
                            app_launch_1: prime-video
                            app_launch_2: netflix
                            app_launch_3: hdmi_1
                            app_launch_4: paramount-plus
                            scale: 85
                              script: script.panasonic_mute

My question is: How to have the app_launch options visible in the card?

This is the part that is preventing you from seeing what you are hoping to see:

Selecting any device type will display the remote control that was shipped with that device. Since the Fire Stick 1st Gen did not have app shortcut buttons, they will not be available to use when you configure your card this way. The image and image labels at the top of this thread might help you to understand what I mean by that.

There is a chart in the read me section that lists the available options to use for the “device type” option. I’ve also noticed that you’ve included an HDMI input in your configuration, so I’m guessing that you actually own a TV or a Fire Cube 3rd Gen since those are the only Amazon Fire products that currently support HDMI inputs. Along with the Firemote Wiki help documents, you can also find help determining which Amazon Fire device you own on this Amazon page.

I hope that helps.

Hi Doug,

thanks for the great UI.
I have an issue adding the card to my Dashboard.
I used the automatic install and found the location on config/www/community/HA-Firemote/HA-Firemote.js.
When I hit add on a dashboard, there is not “firemote” card available. I tried a manual yaml but get as error

  Custom element doesn't exist: firemote-card.
    type: custom:firemote-card
  No visual editor available for type 'custom:firemote-card'.

Any idea, what went wrong?


@Markus77 - I’ve seen this behavior in the past sometimes when the Home Assistant Cache needs to be cleared. Sometimes, the issue can be resolved by restarting your home assistant instance, or the device that you are using to access home assistant.

If you are using a web browser, I suggest clearing the browser’s cache and trying again.

In the event that you are using an apple or android device to interact with your Home Assistant instance, and a simple restart does not solve the issue, please let me know. I might be able to provide some additional device specific help for you.

Thanks for the quick reply.
So it means i can disable those options regarding buttons as my fire tv remote doesn’t have those buttons?
I have one fire stick 4k 1st gen and a fire stick first gen.
Which options are the best for these devices?

Hi Doug, I cleared the cache of all browsers. But still the same result. I use Firefox and Edge. Reboot of my PC also didn’t change anything. Very strange…

@Markus77 - Did you also restart your Home Assistant instance?

  1. Click on Settings in the left hand panel
  2. Choose “System” (not pictured here)
  3. Click the RESTART button in the upper right hand corner

@maurizio53 - The options for the Fire TV Stick 1st Gen (2014) and the Fire TV Stick 4K 1st Gen (2018) are minimal since their physical remotes are more simple. You are safe to remove the app launch button options in those YAML configs. The button override options will still work no matter which device type you choose.

If you are able to use the UI editor, you might notice that the App Launch Button options will appear and disappear depending on what type of device you are attempting to configure:

With all of that being said, there actually IS a way to choose a different remote style than the one that came with your device, allowing you to have some app launch buttons if you’d like. Keep in mind that configuring your card in this manner might not work 100% of the time.

Here’s an example that might work well for your Fire Stick 4K:

type: custom:firemote-card
entity: media_player.fire_tv_camera_letto
device_type: fire_tv_4_series
compatibility_mode: event4
app_launch_1: prime-video
app_launch_2: netflix
app_launch_3: youtube
app_launch_4: paramount-plus
scale: 85
  script: script.panasonic_mute

The important things to note here are the device_type and the compatibility_mode options that have been changed. The Device Type option is what is responsible for changing the remote style to something other than the physical remote style that came with your device. The Compatibility Mode option changes the set of commands that are used when communicating with the device.

To see the proper compatibility mode for any of the supported devices, please find your device in this chart, click on it, and scroll down to “Firemote device specific settings and button overrides” to find “Default Event Setting”. The default event setting you will find in that documentation will tell you which one is recommended to use in your YAML config.

I hope this helps!

1 Like

Yes. Sorry for not mentioning that. I just tried from newly installed chrome. Same result.

Interesting. Do any other custom cards that you’ve installed through HACS have the same issues? Have you tried to remove and re-install the Firemote card through HACS yet?

1 Like

lets give it a try. :slight_smile: I am new to HA. Do you have an example for a custom card?

Yay! Now it is working… Cheers :slight_smile:

1 Like

Thanks, this means i can set the power-button to open or close the fire tv with media_player.turn_on or .off service?
Can you give me an example how to set this button with those services?

I suggest writing a script that can determine the current state of your Fire TV Stick, and then choose to turn the media player on or off based on that.

The other option is to use device_type: fire_tv_stick_4k_max which already uses that logic for the power button.

1 Like

Hey this is awesome and thank you, I am actually using it with my Mi Boxes and it works great. I am trying to add a couple of quick launch apps for NZ like TVNZ+, copied the correct commands, they work and added them into the .js file, copied the other app buttons but it will not show in the list after reboot, I could add separate buttons underneath like other remotes but just thought I would be clever, even if the commands didn’t work I would have expected he app to show in the list?

const fastappchoices = {
  "tvnz-plus": {
      "button": "tvnz+",
      "friendlyName": "TVNZ+",
      "appName": "",
      "className": "tvnzPlusButton",
      "androidName": "",
      "adbLaunchCommand": "adb shell am start -n" },


          .tvnzPlusButton {
            font-size: calc(var(--sz) * 1rem);
            color: #919191;
            font-weight: bold;
            background: rgb(14 26 90);
          .tvnzPlusButton:active, .tvnzPlusButton.appActive {
            color: #ffffff;
            background: rgb(199 0 0);
            box-shadow: 0 0 calc(var(--sz) * 0.857rem) calc(var(--sz) * 0.142rem) rgb(255 255 255 / 20%);
            text-shadow: 0 0 calc(var(--sz) * 0.2857rem) black;

any ideas?

1 Like

Oh yes! I have the distinct privilege of dealing with this specific “feature” all the time while doing development work. There is a very good chance that you’ve done everything 100% correctly, but your home assistant mobile app, or your browser itself is hanging on to some extremely sticky cache.

The easiest way to test this theory is to use your browser first. Do everything you can to clear your cache, and/or even try opening the home assistant UI in incognito/private mode. If that doesn’t work… try it again. No, seriously. Try it again.

If your browser now shows your new item in the list, then that’s the issue and solution. Clearing the companion app cache is a little trickier on mobile, but it is possible. It’s a bit easier on IOS, and I’ve found that on my Samsung Andriod phone, I have to hit the clear button at least twice before it clears. I can offer help if you want it.

If none of that works, it could be possible that you actually have two copies of this card on your system. Perhaps you’ve loaded one via HACS, and another copy into your www directory and attached it as a resource. If that’s the case, you’ll want to remove the one that you didn’t edit, then clear the cache and/or restart your home assistant instance, and take a look.

I hope that helps!

Also, out of curiosity, which remote style do you use? What settings are working for the Mi Box? I don’t own one, so I’ve never tested it.

thanks for the quick reply. I have done all of that, even removed the other quick apps and rebooted, cleared cache and used incognito and even used a different browser that I have never used before. I will let you know which mappings work, I have been using 4 series 2021.

@bjm - Strange… I’m not sure exactly where your issue might be. Hopefully this can help you.

I’ve just released version 1.10.3 using your JSON data, and a tweaked version of your CSS. (I changed the colors only to match what I found on the TVNZ website) The app shortcut shows up on the list, and when selected, the button appears as expected. I can’t test the functionality since that app is not available in my region.

Please let me know if this update works for you, and if the button launches your app as expected.

For a quick reference, here is a github link to the changes that I made in a side by side diff format:…v1.10.3?diff=split

I hope that all of this helps! If it doesn’t set you on the right track and/or if you’d like to contribute to the project by requesting official app shortcut support, I’d encourage you to submit an app shortcut request here: