Lovelace: Mini Media Player

The volume stateless option is primarily there for entities that doesn’t have/support volume state, so that’s why there’s no volume level indicator.

No, the volume_up and volume_down services doesn’t accept a step parameter unfortunately (again, for stateless reasons I suppose).

Yeah, I feel you… but check out the max_volume and/or min_volume options, should work great for your use case. And you could then always press the entity to bring up the more info popup if you ever need to override the min/max.

Ah… no, should break the Sonos functionality in this card, so I would probably need to tweak a few things.

Try the background option, should do what you want i think!
You could then always combine this card with the custom template card or conditional cards to change the background by state.

I’ve now adopted the new Sonos service calls,
This means the next version of this card will no longer be compatible with Sonos group management on HA < 0.93.0.

Would be great if someone with Sonos & HA 0.93.0 could pm me and help me test these changes.

I’ll try and test it tonight, I blew away my HA and started from scratch with 93

1 Like

Thanks, and sorry that I did not think to use those before…

Well, the amount of options are really starting to pile up lol… easy to miss one :wink:

New release v1.1.3


  • Sonos group management is now compatible with HA > 0.93.

  • Sonos group management is no longer compatible with HA < 0.93.


  • New mini-media-player-overlay-color theme variable, artwork cover overlay color (#118)

  • New mini-media-player-overlay-base-color theme variable, artwork cover base UI color (#118)


  • Adopted the new Sonos join/unjoin service calls (home-assistant#23670)

  • Adjusted clickable/touchable seek area of the progress bar


  • Fixed progress bar and full-cover artwork incompatibility

  • Added guard if hass is undefined

Example of the new overlay theme variables in action

1 Like

I noticed in your 1.1.2 release notes above that you show a player with the sound mode name show next to the down arrow and power button. I can get the selection arrow to show up, and it works great. However, I haven’t figured out how to get sound mode name to show, always blank…

Got attribute and lable set. Any suggestions?

Hey, the sound mode select next to the power button is not connected to the shortcuts options, it’s a “standalone” component similar to the source select.

With a config like this, active sound mode should show up.

# example of visible sound mode
- type: custom:mini-media-player
  entity: media_player.example
  sound_mode: default # or full or leave empty
    sound_mode: false

The sound mode is automatically hidden in collapsed view (if either controls/volume is hidden) or if horizontal card space is less than 390px.

After latest update, my shuffle button is missing.

Previous working configuration command was

show_shuffle: true
have tried toggling shuffle etc

Any idea?

Yeah, show_shuffle was removed a few months ago.


  • REMOVED: show_shuffle option, see new hide option (#50) (BREAKING CHANGE)

So new config should look like this:

- type: custom:mini-media-player
  entity: media_player.spotify
    shuffle: false

yeah i think it has to do with me not updating the plugin for a while :slight_smile:

Applied your fix, works fine now, thanks again, i really like this card.

1 Like

any way to use custom Icons for the shortcut buttons? for example the Spotify thumb as png or so.

No, not unless you do something similar to this:

But for more advanced buttons I recommend checking out custom button card.

Is it possible to get just a volume slider next to grouped speakers? I know there is the sync_volume boolean but I’d like to be able have separate volume levels and easily adjust them from one card.

1 Like

Don’t think that will ever be added to this card unfortunately, would require watching & tracking all the entities inside the speaker_group config, which I’m not a fan of.

You could always fork this card and implement the functionality though.

What is the correct url for custom_updater?
I can´t get the one in documentation to work

That is the correct one, should work unless something in custom_updater has changed.
I haven’t used custom_updater in a long time, but it worked fine last time I used it a few months back.

This looks really cool! Thanks. I see from the documentation this supports sonos & yamaha music cast. Any way this could support russound rio at some point? Integration should be fairly simple bc the entities are auto-populated with the russound rio plugin. They have a similar layout to most typical speaker groups.

The group functionality has to be implemented and supported in the backend before we can add support for it to this card.
I’m not familiar with russound rio but I’m looking at the component source and it doesn’t seem to have any kind of group management implemented right now.
But if it does in the future, we could possibly support that platform in this card.

Actually, don’t worry about it. I used the group media entity and it looks and works exactly how I want it to. Thanks!