Lovelace UI not loading but the rest of Home Assistant seems to be working

Started for me as well about 1 hour ago.

Restored VM image from 3 days ago and problem continues.

It happen to me about the same timing. Did you do a OS or Core restart? I noticed i can’t load the Hacs page as well but other like Developer, Supervisor and Configurations are OK.

I’ve done both Core and OS restart. I’ve done restore of VM from backup and comes back with same problem.

I try to SSH into VM and things work / respond for a bit but then I’m locked up.

Was working great 2 hours ago.

What about your hacs page? Can you access it? Wasn’t sure was it the root cause. Also are you using any custom component? To me, I’m just using the custom header.

I’m starting to get bunch of this error. Seems like the hacs store, weather and xiaomi integration are failing.

I’m getting a ton of errors as well. Trying to figure out how to stop them.

Can HACs be removed / disabled from command line?

From what i know is just to delete the hacs folder according to this link: .

BTW, can the frontend load is using local IP to access it? I’m currently away and it seems i can’t even remotely login to my HA instance with duckdns.

I don’t see any HACS error there… (Post a real log not a screenshot)

No - I tried direct IP address and same thing. Doesn’t work.

This is so frustrating. Everything was working great. All of a sudden “Loading data”

Tried deleting HACS directory.
Tried deleting config/.storage/Auth*

Still spinning at loading data.

WHen I SSH into VM I get about 30 seconds before the session completely locks and I have to disconnect an reconnect.

Here is the log about the hacs and as well as sensors error of sudden and I wasn’t sure if this is root cause.

Logger: homeassistant
Source: custom_components/hacs/hacsbase/
First occurred: 12:33:20 PM (3 occurrences)
Last logged: 1:33:22 PM

Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/local/lib/python3.8/site-packages/aiogithubapi/", line 59, in async_call_api
    result = await session.get(url, params=params or {}, headers=_headers)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 480, in _request
    conn = await self._connector.connect(
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 523, in connect
    proto = await self._create_connection(req, traces, timeout)
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 858, in _create_connection
    _, proto = await self._create_direct_connection(
  File "/usr/local/lib/python3.8/site-packages/aiohttp/", line 964, in _create_direct_connection
    hosts = await asyncio.shield(self._resolve_host(

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/config/custom_components/hacs/hacsbase/", line 289, in recurring_tasks_installed
    await self.handle_critical_repositories()
  File "/config/custom_components/hacs/hacsbase/", line 201, in handle_critical_repositories
    critical = await self.data_repo.get_contents("critical")
  File "/usr/local/lib/python3.8/site-packages/aiogithubapi/objects/repository/", line 113, in get_contents
    response = await self.client.get(endpoint=_endpoint, params=_params)
  File "/usr/local/lib/python3.8/site-packages/aiogithubapi/", line 36, in get
    response = await async_call_api(
  File "/usr/local/lib/python3.8/site-packages/backoff/", line 133, in retry
    ret = await target(*args, **kwargs)
  File "/usr/local/lib/python3.8/site-packages/aiogithubapi/", line 101, in async_call_api
    raise AIOGitHubAPIException(
  File "/usr/local/lib/python3.8/site-packages/async_timeout/", line 55, in __aexit__
  File "/usr/local/lib/python3.8/site-packages/async_timeout/", line 92, in _do_exit
    raise asyncio.TimeoutError

Logger: homeassistant.components.sensor
Source: helpers/
Integration: sensor (documentation, issues)
First occurred: 12:26:18 PM (481 occurrences)
Last logged: 1:58:23 PM

Updating xiaomi_miio sensor took longer than the scheduled update interval 0:00:30
Updating systemmonitor sensor took longer than the scheduled update interval 0:00:30
Updating waze_travel_time sensor took longer than the scheduled update interval 0:05:00
Updating command_line sensor took longer than the scheduled update interval 0:01:00

Can you access other page beside the lovelace frontend? I was thinking maybe is my custom header causing the problem. I will have to try to disable it and try again. But i can only do it once I’m back.

One more thing, I can’t access the my HA instance at all through web browser. But i can access other pages beside the lovelace ui with my HA companion app. Are you have same problem as mine?

cos randomly deleting shit works so well doesn’t it?

What HA are you running? I have seen this problem when DNS is fubar… I had similar today when I updated Debian (I run Supervised on Debian)

It’s potentially odd that you can’t use local ipaddress:8123 though but not enough info provided to work off

Hi David, may i know how to solve the DNS issue? I’m running 0.115 Core. My case is i can’t access my HA instance through web browser at all but i can access partial pages such as Developer, Supervisor and etc except my lovelace UI through HA companion app. I can even view my camera live feed in Developer page under states tab.

Do you think is my issue related to DNS?

For me - I can’t get into anything on HA (VM) using web browser. When I connect HA says “Loading Data” and that appears for me on web browser (PC and tablet). HA Companion App also sits on HA logo - and doesn’t proceed beyond.

If you have supervisor you have Supervised or HA OS
Could well be DNS. Do you have ssh into it? You can run

ha dns info

What are the dns servers?

VM? Can you not just make a new VM?

Hi, it appears that my problem is different and it got resolved after I restarted the OS. Restarting the core alone doesn’t solve the problem.

Going through the log files in detailed again and I noticed there was instance my camera lost connection and I suspect there either my router got restarted itself or my internet connection has restarted and causing the HA socket connection screw up.

Anyway, my HA is now back online. Thanks for the comment and reply.

1 Like

I found a solution to my problem. Not sure if this will help others but in my case it was related to the Modern Forms Smart Fan Integration. I added the automation shared here to auto reset the fan controller and my lockups went away. Over 2 weeks now with not 1 single issue.