Low-Powered Viewer: "custom element doesn't exist"

I have the latest version of everything on a Hassio VM with a custom domain.

Everything works perfectly on desktop, phone and my new Raspberry Pi 4. However, on my Raspberry Pi 3B+ I get: “custom element doesn’t exist” for most non-native elements. Is there any way to overcome this?

Thanks, Richard

For a start “latest” is not a version.

It is difficult to follow your post. Are you saying that the hass interface doesn’t work on a web browser on the raspberry pi 3? But it does on a raspberry pi 4?

If so, which browser? Which os?

You got it. Lovelace works perfectly on every platform except stock browser for Raspbian Stretch on the 3B+.

What is the stock browser?

@nickrout you should be knowing this as you tend to answer everyone’s question on every topic/post. Rather please be polite to the OP.

To answer your question RPI’s stock browser is Chromium. If you cannot help please don’t judge everyone’s post.

@RichardU it could be that Rpi 3b+ has insufficient memory? Or you could try clearing the cache?

I don’t think I was being rude. People need to define their problem accurately. I refer many people here: How to help us help you - or How to ask a good question

1 Like

Can you please stop using offensive language on this forum? Thank you.

Just remoted into one of my pi’s and tried. All looks ok:

Slow as a wet week, but it displayed all my custom cards eventually.

Do you have this in your configuration.yaml?

  javascript_version: auto
1 Like

LOVE the layout

@nickrout If you’re having a hard time understanding the meaning of “latest version”, I don’t think I need your help, thank you.

@bachoo786 clearing the cache doesn’t seem to help. Thanks.

@tom_l I tried adding javascript_version: auto and it didn’t do anything. I do appreciate seeing your site, however.

I have some deeply stacked cards (horizontal-stack inside vertical -stack etc.) so maybe that’s why it bogs down the rPi. On the other hand, I have a tab with an iframe containing an external website and that displays perfectly.

This isn’t a critical issue for me, but it would be nice to know if there is a known fix.

1 Like

Well you aren’t using the “latest” if you are using stretch on your raspberry pi.