Lutron Caseta Pico 4-Button Scene Remote

I tried this for the pico 4 button 2 group remote which is PJ2-4B-GXX-X21 (Pico4Button2Group), but unfortunately it does not work.
I am a new user of home assistant and still learning.
I would appreciate it if anyone can help me fix the code for this specific remote as well.
I managed to get the other code in your reference to work with the 5 button pico remote.
But I could not get this one to work.

These types of remotes are only compatible with Radio RA3 and QS Homeworks and do not work with the Caséta hub (pro or regular)

None of my pico devices are appearing in the selector drop down. I checked the devices and they are showing as

      model: PJ2-4B-GXX-X31 (Pico4ButtonScene)

Any ideas?

Make sure the remotes appear in the list of devices on your instance.

Open your Home Assistant instance and show your devices.

Search for “PJ2-4B-GXX-X31 (Pico4ButtonScene)” up at the top of the page to filter the list.

If your remotes are in that list, they should be available in the drop down. If they are in the list, but still not in the drop down, then I’m not sure what’s going on.

In my case, I’m using the remotes paired with a Lutron Caséta Smart Bridge Pro.

According to the documentation

Pico and Shade remotes are supported on the Smart Bridge (L-BDG2-WH), Smart Bridge PRO (L-BDGPRO2-WH), and RA2 Select (RR-SEL-REP2-BL) models.

What I don’t know is if the remotes appear with the exact same model string, or if it can vary if, for instance, you’re using the Smart Bridge or RA2 Select.

I hope that gives you enough to go on.

I found this note in another blueprint, it might be what you are looking for:

Make sure you have enabled at least one Pico Event Entity for each device, they are default to not enabled as of 2023.3, otherwise they won't show up as an available device in the drop down list.

from blueprint: Lutron Caséta Pico 4/5 Button Remote Advanced Actions (Core Integration)