macOS Mojave ... Home Assistant Will Not Autostart

Just did a clean install of Mojave and reinstalled HomeBrew > Python (via HomeBrew) > Home Assistant … everything went smoothly, no problems. However, when I try to install the Autostart script ($ hass --script macos install), I get the following error:

Unable to write to /Users/server/Library/LaunchAgents/org.homeassistant.plist [Errno 2] No such file or directory: ‘/Users/server/Library/LaunchAgents/org.homeassistant.plist’

Also, when I look in the Library directory, there is no LaunchAgents subdirectory. I believe it may have been moved in Mojave, but I am not sure.

Can anyone suggest another way to get Home Assistant to Autostart and run as a background service on macOS?

Thanks in advance :wink:

Schoolboy error, x.0 MacOS releases are always bug ridden junk.

  1. Open Terminal
  2. “cd ~/Library/”
  3. “mkdir LaunchAgents”
  4. “hass --script macos install”

If using python virtual environment, be sure to cd to the home assistant directory before running the hass script install

Tried all this, doesn’t work for me.

This solution worked for me.
But why doesn’t anyone adjust the Autostart on macOS instructions?

If you have working instructions, you can submit a pull request to change the official documents.

Click on the Edit this page on Github link on the page you wish to edit, and submit your changes. If approved, they will be updated for everyone else to benefit from.