Media browser, Spotify, select output device?

Hey,

Thanks for the reply.

Didn’t check that yet, but as most know there was a major malfunction @spotify/chromecast the last 2 days. So I hope that was the problem :slight_smile:
I am home tonight and hope that it’ll work again. I keep you posted

1 Like

Unfortunately it doesn’t work. Via developer tools when I start the script. I get the error that HA cannot find the device with the name unknown.

I’ve set up those two pieces of code, but how do I display it in my Lovelace please?

Hello,

You must do a media control card like this :

type: media-control
entity: media_player.spotify_jbm

and an entity card like this :

type: entities
entities:
  - input_select.chromecast_audio

Hey there.

I have alexas as media output rather than google devices and I can select output for Spotify.

What I seem to be the only one interested in, is the option to only play on the device you talk to as sometimes I might not want to disturb people which are in other rooms at times.

Is there I way I can talk to Alexa and she starts a scripts (using hassio cloud) that plays eg my playlist on the device I talk to only?

Hello and thanks for this workaround.

Only need to know if is any other way right now to do this?

and how reliable is this?

Edit: ok i found this Spotify Card with basically all the stuff

Hi @jtnn60,

Thx for that, very cool!
One question: should the “Spotify: Start Playback” disappear if at least one device is active, please? Because, as you can see below, for me it’s always displayed. However on your screenshot it isn’t.

image

Late reply but do you still happen to have that radiostation input control? looking for something likewise, and same country so that would make my life a lot easier ^^

Change the input in config.yaml into.

‘’’
input_select:
select_speaker:
‘’’

Then it will work!

Can you post the yams for radiostations and playlists as well?

Thanks

Never really used it, so removed it from my setup. So, sorry, don’t have it anymore…

Hello everyone, sorry for the late revival of this post.
But I need help setting up the media player. I integrated Spotify, SpotCast and configured everything correctly. I hope …: D

After I have ordered the cards and press “play” I get the following message.

“Error calling service media_player / media_play_pause. No active playback device found”

Does something else have to be configured?

I had the same issue, and it turned out to be quite simple to solve… the error message is quite misleading in my opinion.
What it basically tells you, is that the integration doesn’t know on which spotify-connected device (your phone, PC, HomeAssistan,…) to play your music.
You simply have to select “Source” from the drop-down menu according to the device you want to control from the card.
image

Note that if from Spotify itself you change the source to phone or so, you might have to select the source again.
Here there is a solution to this problem as well… I still have to figure out how it works though :smiley:

I hope this helps :+1:

Guys i have a question too!

How do you set up your phone as a media playback device?
To be more exact, if i set in the input.select an entry such as: MyPhone how does the script know that MyPhone is actually my mobile device?

Thanks

Im missing “Source” in my Spotify card.

3 Likes

Open the Spotify App on your PC or Smartphone and select the device you want to play from.
Sources option should then appear in your Spotify Card.

I have a question too. When I stop to play music over Spotify, the Media Player Card switches into idle mode after a while and the option to select sources dissappeares. I then can’t start to play music over home assistant and I have to start playback inside the Spotify Android/Windows App. Is there a way to prevent the idle mode from happening or any other workaround?
That would be really helpful, cause at the moment I am not able to automatically play music in the morning for example.

2 Likes

Did u fixed this problem? I have the same here. I cant play music via Automation until i start one track via spotify app on my mobile.

No, I fear it is a limitation of spotify applications. But I am not 100% sure.

thx for that. working great. i’ll add myself to the question.
should the entry “Spotify: Start Playback” fade out once playback started?
Also what would i have to do, to get a VolumeBar on the FrontPanel?

@others: did you guys manage to implement radiostations? or even better TuneIn ?

did you find a solution?