Miflora broken after upgrading to 0.97

So to setup this M5Stick you follow the same steps as regular ESP32?

Very poor range overall. I had to put a BLE tag and a MiFlora sensor within a metre of it to get it to pick up.

There was another MiFlora sensor through the next wall (plasterboard, no brick) and it didn’t pick that up.

As for the duct tape suggestion, I think that would be the only option. I did try taking it apart to see if I could disconnect it, but the unit seemed fairly sealed.

Yep, plugged it in via USB to the machine running Home Assistant, installed the ESPHome add in in Hassio and followed the installation wizard. It was amazingly simple and straight forward. It’s a real shame about the range.

Perhaps I have an iffy unit?

1 Like

Hi!
Back to the topic. After upgrading last night to 0.98.1 - it works again! :slight_smile:
Hope it works for you too.
Regards,
Heinrich

1 Like

Excellent. Was waiting for that @der_heinrich !

Indeed it does!

@johnflorin I’ve also noticed that it now seems to work happily alongside the Bluetooth LE tracker

I’ve been using the “Lolin D32 pro” and it covers two floors. The NUC covers three floors + terrace. You can also get some that have connectors for external antennas, like this one https://www.aliexpress.com/item/32983165020.html?spm=a2g0o.productlist.0.0.676c65715niZ6G&algo_pvid=6076597e-7cfe-47cf-890f-fc8d49ca0ba0&algo_expid=6076597e-7cfe-47cf-890f-fc8d49ca0ba0-1&btsid=8ad937f2-276c-4bbd-8903-b1ed883c7b36&ws_ab_test=searchweb0_0,searchweb201602_7,searchweb201603_52

Thanks for the recommendation! Do you have your Lolin D32 pro in a case?

Update:There’s something with the bluetooth libraries… I don’t know anything about this, but it should get fixed in the next release. Thanks to ChristianKuehnel


Something is different though… my miflora now does not work in the distance it used to be in anymore. It seems like the range has gotten worse, but is that possible?

If I have the miflora in close proximity to my raspi, then it will work flawlessly, but when I put it in my flower bed - exactly where I had it withouth a problem for the last 6 months - then hassio will not update the values anymore. I gave it a fresh battery, buit that doesn’t change the behaviour. Range has just gotten way worse.

Also I used to get the log message that fetching data from the bt sensor took longer that expected (it did get the data anyway though), but I don’t get that anymore at all. Is it possible that something in the fetching behaviour has changes and hassio ist not trying “as hard” to get the data anymore?

I’m really frustraded, because this comes righton the day that I am creating an automation that relies on the miflora data. :frowning:

Hi @all,
sorry for my euphoric post. After some hours the same situation. No data update. Same situation after a restart.
I tried to reduce the distance from my bluetooth dongle to the Miflora sensor - and of course nothing changed.
Do we need to open an issue for that? Or is It already opened?
Regards,
Heinrich

aww sigh…

Uhm… Not on the ESP itself. It’s tucked away above the ceiling where it shares power and space with a recessed Aeotec multisensor.

1 Like

picked up the m5stickC yesterday hoping that it would fix my miflora and Bluetooth cracking issues.
I found that the range was very limited and it needed to be in the same room as the miflora devices. That’s OK because I can just get one per room. It might be a bit limiting for ble tracking, though.

Same here: I’ve picked up a m5StickC to monitor Miflora and very disappointed: very poor range for BLE but also for WiFi… Tried with m5core Fire: same story… very short range…

To try to fix another issue I added a consider home value to my device_tracker bluetooth platform last night:

- platform: bluetooth_tracker
  consider_home: 150

I have since noticed that my miflora sensor has been working flawlessy, getting updated every 20mins, since last night (when before it only got a value after every hassio restart and then never updated)

miflora miflora2

So, is it a feature or a bug?

I don’t believe it should be needed but just by coincidence it seems to have kick started my sensor…

1 Like

Bugger. I have another m5stick waiting to be flashed as I was hoping I picked up a dodgy unit.

Hmm, well it’s stopped working again about an hour after my post. Typical. I use BT on my Pi as presence detection and the Miflora stopped working at the same time my “Bluetooth Presence” marked me as ‘not home’ and then never seems to recover once it marks me back as ‘home’

My original comment of adding consider_home: 150 was to try to stop the BT constantly switching me from ‘home’ to ‘not home’ whilst I am at home helped but hasn’t cured it.

I think the only proper fix for this flaky behavior is to not use BT itself in HA and forward it from something dedicated for BT with decent antennas…so, Pi Zero W + Plant Gateway, anyone? Using a Pi with Monitor has been super rock-solid for presence detection, so it might be worth getting another one just for this purpose, since the Pi’s BT chip also seems to be the best supported one.

edit: with that being said, for a few days already using 0.98 + my ASUS BT400 adapter has been…fine? At least temperature, light and conductivity seem to be broadcasting frequently enough, humidity and battery…not so much.

Hi!
I’m using right now 0.98.4. I was hoping the fix by ChristianKuehnel is already merged into the latest version …
But I could not wait :slight_smile:
See here --> https://github.com/peternijssen/home-assistant/commit/16604a5330909e8c1ea5ed8f3804192aa69193af

After adding that one-liner my sensors working (now for 2 days) again.

Regards,
Heinrich

1 Like