Migrate Broadlink RM deprecated switch YAML?

ah, sorry, as it is similar to the original, I got errors, it also needs to remove the friend name of the entity. Problem solved. As I thought the Broadlink component will ignore all YAML settings but fortunately, no big changes.
My mistake.

Great to hear your problem is solved!

I’ll still post an update after I’ve fixed my config, just in case it helps someone sitting in the same boat =).

So, updated after changing the YAML format, which I’m guessing is the deprecated format the breaking changes release notes mentioned.

The previously deprecated YAML configuration of the Broadlink integration has been removed.

After the changes and the update, everything is peachy. Good times!
I also now have the remote.send_command file for everything. Who knows - might come in handy someday.

However, some confusion on my part, because of @finity

the documentation/breaking changes section is pretty misleading if nothing actually gets imported but also everything gets wiped out.

and from the release notes

Broadlink is now configured via the UI, any existing YAML configuration has been imported in previous releases and can now be safely removed from your YAML configuration files.

So I don’t know what this is supposed to mean. What got imported? What was supposed to get imported?
I can’t see any automatically created entities or anything under the Broadlink integration (which I also don’t believe is meant by that…)

Can someone shed light on that part?

The integration configuration is the only thing that got imported, no custom switches that are configured via yaml as they are still done via yaml as in the documentation.
The only thing that got created automatically for me is the temp sensor and teh remote on the broadlink rm pro device

1 Like

That got imported a long time back and has been working fine for me too.

I got nervous when this was reported:

but apparently my concern was misguided. Which I kind of thought already but it’s good to have that confirmation. (got bit by this twice already now. I need to hold back a bit until confirmation either way… :roll_eyes: But I guess I thought I was doing that already as well since the release was already a week ago now… :slightly_frowning_face:)


The only thing that needed modifying was the custom switches i had to be based on new yaml configuration as per docs but was a 5/10 minute job at max

Is that a brand new change or has that been around for a while since the change of the integration configuration to the UI?

if so I’m pretty sure I already made that change. So I should be good to go.

a while since the change to UI.

Saying that i just realised i can bin a few custom switches as the tv some controlled has been thrown 2 weeks back.
and i moved some to be used via a card and use tap action on it

action: call-service
service: remote.send_command
entity_id: remote.broadlinkrmpro_remote
command: >-

So time for a cleanup