Migration from Conbee II to ConBee III

Quick question. I have a brand new Home Assistant Yellow. I’m not planning to migrate anything to it, I’ll set up each device and pair as if they are new.

I also have a new Conbee III USB stick and I’d like to use it. HA Yellow has Zigbee support on the board, so I’m assuming that I will have to disable the built-in Zigbee and instruct it to use the Conbee III. Anyone have an idea of how I might do that? Thanks in advance.

EDIT - answering my own question.

  • Click Settings → Devices & Services → Zigbee Home Automation
  • You should see an existing entry for “Yellow”, click the hamburger menu and delete it.
  • Click Add Entry and select the Conbee III and proceed with the configuraiton

FYI, should now be easy to migrate to a new adapter (via process of backup and restore) using this new TubesZB Zigpy-CLI Tools add-on can migrate even if using Zigbee2MQTT with Home Assistant:

Hello.
I bought a conbee 3 and i will migrate from conbee2 to conbee 3 (with zigbee2mqtt) in the next days.

My idea is:

  • stop zigbee2mqtt
  • making a backup with “zb-zigpy-cli-tools”.
  • change the baud rate of conbee in zigbee2mqtt config file
  • restore the backup with “zb-zigpy-cli-tools”
  • launch zigbee2mqtt

its seems simple, but i dont know if someone make this before and will work, because in the backup of zb-zigpy-cli-tools i can see information about the zigbee that maybe i will change?
like “node version” or “deconz version”

thanks for the help

ive had a ConBee 2 for 3+ years now.
you seening much benefit in doing the upgrade?

just cusious if worth spending the £ and effort to do it?

in my case yes. i see the map in zigbee2mqtt and see 24 devices connected directly to the conbee (other 80 by routers). and the conbee 2 have a limit in the direct connections.
with conbee3 i will can increase this limit. But is my case, each person have a user case.

but now the conbee3 firmware is buggy and not have all the improvements of the conbee2 for devices.
we need to wait some firmware version to make the migration

Yes, it should work, and others have reported that backup and restore to ConBee 3 works with zigpy-cli, see:

https://github.com/Koenkk/zigbee2mqtt/discussions/19785

and

https://github.com/zigpy/zigpy-cli/discussions/41

Note that Zigbee2MQTT does still not feature native backup support for ConBee adapter, again see → https://github.com/Koenkk/zigbee-herdsman/issues/665

So if using Zigbee2MQTT then it is recommended to use Texas Instruments CC2652 based adapter instead, which you can migrate to using zigpy-cli → https://github.com/Koenkk/zigbee2mqtt/discussions/16478

Curiously, has anyone reported this to Github Issues so they know the update is needed?

EDIT: I hope I didn’t overstep, but I went ahead and opened an issue to alert the dev to the need. deCONZ outdated - users cannot migrate to latest dongle · Issue #109206 · home-assistant/core · GitHub

Today seems to be the day - see changelog:

6.23.0

Bump deCONZ to 2.25.3

1 Like

The long awaited update finally happened. I immediately updated, backed up, shut down, pulled the Conbee II stick, plugged in the new Conbee III, loaded backup and everything was right where it was. Now I’m enjoying the much more flawless add-on features.
Thank you to all that made this update possible!

2 Likes

Hello Norbert,

can you write down the steps how to do it?
Thank you
Gabriel

Hello Gabriel,

sure:

  1. Update your Conbee II firmware to latest version → see: How to update ConBee/ConBee II firmware in Windows 10 - Flemming's Blog
    Firmware file can be found here:
    Index of /deconz-firmware/
    IMPORTANT: It is worth to update the Conbee III at this stage as well → obviously with another file, but in the same procedure.
  2. Update your deconz add-on in Home Assistant to at least version 2.24.0 (actual version is 2.25.3 → check under Gateway settings in deconz). IMPORTANT: No migration is possible below 2.24.0 version
  3. Make a backup in deconz → Gateway settings → Backup options → Create backup → save file where you find it
  4. Make a Home Assistant backup → you never know, when you’ll need it
  5. Shut down Home Assistant and I’m not sure if you need to switch off power but I did it anyways on my Raspberry Pi 4
  6. Unplug Conbee II
  7. Plug in Conbee III with it’s freshly updated firmware
  8. Let HA start
  9. Go to settings → add-ons → deconz → “configuration” tab and select the newly recognized Conbee III stick
  10. Start deconz in the “Info” tab
  11. Go to Gateway settings → Backup options → load backup from previously saved file and give it a good 10 mins.
  12. Restarted HA again - just to be sure
    Done
2 Likes

Hello.
Its posible to migration fron conbee II to conbee III without deconz plugin?

I use zigbee2mqtt and not use deconz. I only use zigbee2mqtt and im happy with it.

First, be aware that the ConBee/RaspBee (deconz) adapter driver in zigbee-herdsman that Zigbee2MQTT uses does not yet have native support, see request → deconz adapter/driver does not support backup and restore for ConBee/RaspBee by dresden elektronik? · Issue #665 · Koenkk/zigbee-herdsman · GitHub

There are however unofficial ways to perform backup and restore externally with third-party CLI tools, see → migrating coordinator from Conbee 2 to Conbee 3 · Koenkk/zigbee2mqtt · Discussion #19785 · GitHub (which in turn have links to other guides and discussions)

Hello!!!

the second post is mine, jejeje

This weekend I migrated from conbee2 to conbee3 without deconz.
Using the zigpy cli addon and some time to understand the procedure.

Its not easy but posible.

update firmware in conbee2
stop zigbee2mqtt
make a backup with the zigpy
update firmware in conbee3
restore backup with the zigpy (not chante NOTHING in the backup file)
in zigbee2mqtt change the baudrate to 115200 and the port to the new port of conbee3. try with the short route and the full route.
and works.

the problem is the conbee3 firmware is still new and some aqara devices disconected, but im tensting

Make sure follow best practice recommendations (like using a long USB extension cable to a USB 2.0 port to avoid EMF interference and add a few known good Zigbee Router Devices), read and try follow all the tips here → Zigbee networks: how to guide for avoiding interference + optimizing using Zigbee Router devices (repeaters/extenders) to get best possible range and coverage

Most issues with Aqara and Xiaomi devices are resolved if re-pair those devices them again after adding more/new (know good) Zigbee Router devices and avoiding EMF/EMI/RMI interference, but if still have issues with Aqara and Xiaomi devices then also see this too → Xiaomi & Aqara Devices - Pairing & Keeping them connected - Devices - Hubitat

1 Like

Yes, i use a usb 2.0 cable extensor since day 1.
And with conbee2 all works fine since one year ago.

After this migration, some devices los the connection. Only aqara devices.
I repair it today and keep monitoring.

The conbee3 have a very good coverage and performance, but in some days i will report more information it more device disconected

Hello all,

I tried to migrate from the ConBee 2 to ConBee 3 in ZHA like discribe in the below written comment.

The issue is, that the coordinator did not detect the ConBee 3…so I am not able to migrate the backup from CB2 to CB3…because an error occurs. I choose the serial port, but stick is recognize as N/A and the next question is, which device is steering and thats is…I have to close an includ CB2 again…

Any ideas?

Best
Nomad

Provide details on installation; if Home Assistant OS or not, exactly on what hardware/platform, etc.?

If you not using Home Assistant OS directly on bare-metal hardware then you might first have to jump through some hoops to install CP210x (USB to UART Bridge VCP) Drivers and configure correct settings for USB pass-through if using a virtual machine, etc. (and if you are using a container-based installation then need to configure USB device forwarding to the Docker image or similar).

Before starting also first upgrade the firmware on the ConBee 3 manually using a different computer to confirm that the adapter is working at all. If you manage to upgrade the firmware then at least you know that it should be possible to connect to it → https://phoscon.de/en/conbee3/install#hazha

Regardless of setup be sure to always use a long USB extension cable with good sheilding (either a USB 2.0 extension cable to any USB port or a USB 3.0 extension cable to a USB 2.0 port) to get it away from EMF sources, see → Zigbee networks: how to guide for avoiding interference + optimizing using Zigbee Router devices (repeaters/extenders) to get best possible range and coverage

Hi Hedda,

thank you for your response. I am using a Conbee II stick on an HA docker instance on my NAS. I have updated te ConBee 3 already to the newest firmware. I am using an ConBee 2 with a cable, nevertheless the ConBee 3 stick has not been able to be detected.

With the help ofthe ConBee support I found the issue:

  1. In the docker starting table you have to change the path of the stick and the boudrate.
    DEDVICE = /dev/ttyUSB0
    DECONZ_BAUDRATE=115200

Becausethis changed:
Conbee II = /dev/ttyACM0
Conbee III = /dev/ttyUSB0

  1. I have to use a downloaded backup of the ZHA setup, because with the autobackup it used a wrong zigbee channel.

Hope it helps!
Nomda

I believe that by default ConBee 2 uses a lower baud rate than ConBee 3, I believe it should be 38400 or 57600 for ConBee 2 instead of 115200 or higher baudrate for ConBee 3? Not sure about ConBee 1?

As for the Docker configuration in Home Assistent for ZHA, also see note about Docker Compose if not running Home Assistant on the official Home Assistant Operating System distrobution → https://www.home-assistant.io/integrations/zha/#cant-connect-to-usb-device-and-using-docker

Also, while I am not sure about ConBee 2, for the ConBee 3 you probably want to use /dev/serial/by-id with the unique USB product identifier instead of /dev/ttyUSB0 as the USB port can sometimes change. First check if you see the adapter in Home Assistant? Browse under Settings → System → Hardware → All hardware? If you can not find serial/by-id there then it must be problems with either Docker/Podman or virtual machine USB pass-through or the ConBee 3 adapter itself. If you can not see its serial/by-id there under ”All hardware” under Settings kn Home Assistant then the problem if not with the ZHA integration or Zigbee2MQTT but instead at a lower level, such as Docker/Container engine or virtual machine virtualization hypervisor or the physical dongle or its firmware.

Note! If your NAS supports running a VM (virtual machine) then it is recommend to install “Home Assistant Operating System” (Home Assistent OS) in a VM instead of running it in Docker yourself.

PS: Why not buy and migrate to a other radio type if you are using the ZHA ( Zigbee Home Automation) integration or Zigbee2MQTT? IMHO, the only good reason to buy a ConBee or RaspBee adapter today is if want to use Dresden-Elektronik’s deCONZ/Phoscon as both the ZHA integration and Zigbee2MQTT have better support for Silicon Labs EmberZNet (EZSP/Ember NCP) and Texas Instruments Z-Stack ZNP based Zigbee Coordinator adapters than what they have for the ConBee/RaspBee adapters.

1 Like