MiLight WiFi Controller (iBox 2) with LED-Stripe

Unfortunately no success.

Where can I see what version would be correct?

1 Like

I’d also like to know if there’s any way to see which version is required

I have the same problem, i think the python-limitlessled does not support it. Next week i will capture some network between the app and the ibox 2. hopefully i can see some messages i can use to include in the python-limitlessled lib.

Anyone more success?

I have made support for my 1CH MiLight led dimmer, now waiting for merging into home-assistant.
More info see:

Awesome, thanks! Looking forward for your change to be integrated officially! :slight_smile:

I might test it tomorrow manually and report back. Is there any github-way to test this? Otherwise I would just edit the and see what happens.


you can simply edit the file with this one and it should work. It should automatically install the latetest python-limitlessled.

Ok, I edited the and get the following error:

Traceback (most recent call last):
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/helpers/", line 171, in _async_setup_platform
    SLOW_SETUP_MAX_WAIT, loop=self.hass.loop)
  File "/usr/local/lib/python3.6/asyncio/", line 352, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.6/asyncio/", line 244, in result
    raise self._exception
  File "/usr/local/lib/python3.6/concurrent/futures/", line 55, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/srv/homeassistant/lib/python3.6/site-packages/homeassistant/components/light/", line 121, in setup_platform
    group_conf.get(CONF_TYPE, DEFAULT_LED_TYPE))
  File "/srv/homeassistant/lib/python3.6/site-packages/limitlessled/", line 154, in add_group
    group = group_factory(self, number, name, led_type)
  File "/srv/homeassistant/lib/python3.6/site-packages/limitlessled/", line 50, in group_factory
    return DimmerGroup(bridge, number, name)
  File "/srv/homeassistant/lib/python3.6/site-packages/limitlessled/group/", line 25, in __init__
    super().__init__(bridge, number, name, DIMMER)
  File "/srv/homeassistant/lib/python3.6/site-packages/limitlessled/group/", line 57, in __init__
    self._command_set = command_set_factory(bridge, number, led_type)
  File "/srv/homeassistant/lib/python3.6/site-packages/limitlessled/group/commands/", line 30, in command_set_factory
    raise ValueError('There is no command set for '
ValueError: There is no command set for specified bridge version and led type.

Any ideas? I’ll try to look into this more tomorrow.


Hm, limitlessled seems to be the correct version.

(homeassistant) homeassistant@hassbian:/home/pi $ pip show limitlessled
Name: limitlessled
Version: 1.1.0
Summary: Control LimitlessLED products.
Author: happyleaves
Author-email: [email protected]
License: MIT
Location: /srv/homeassistant/lib/python3.6/site-packages

Someone else seemed to have the same problem. Unfortunately there’s no trace of a solution whatsoever.

I might “upgrade” to home-assistant dev-branch later. Or do you know when or which version will contain your


EDIT: The issue still exists in HASS v0.64.0dev0.

What is your current YAML configuration?

This is the relevant part:

  - platform: limitlessled
    - host:
      version: 5
      port: 5987
      - number: 1
        type: dimmer

It should be version: 6 (which is default, so you can just remove it).

Great this works, thanks!

Adjusting temperature and brightness are not though. Even not with type “white”.


I have Mi-Light iBox2 and a Mi-Light RGBW Bulb connected to it. I can control the bulb via the app. I cannot get it to work within Home Assistant. I do not get any errors, the bulb just isnt reacting…

- platform: limitlessled
    - host:
      - number: 1        
        name: milight_bulb_1
        type: rgbw

Home Assistant V 0.75.3.

Are there any known issues? How did you get it to work, @Regularj?

Did you try type: rgbww ?

I tried with type “rgbw”, “rgbww”, “white”, no effect. I even tried with version: 5 & port: 8899, nothings changes. The weird thing is I don’t event get any log outputs other than

INFO (MainThread) [homeassistant.loader] Loaded light.limitlessled from homeassistant.components.light.limitlessled
INFO (MainThread) [homeassistant.components.light] Setting up light.limitlessled

Any ideas on how to troubleshoot further?

Can you post an image of the remote that works in the app? (this affects the settings that should be used).

Also, double check the IP address :slight_smile:

Thanks for your help!

Sure! The remote I am using is the second from the left:

With this “virtual remote”, it is working just fine!

The IP is correct. I am able to access the bridges web interface:

Hopefully you didn’t change any settings in that web interface.

The remote should work as type: rgbw like you had so it looks like some network issue at your end. Do you have a firewall or other advanced setup that could have gone awry?

You can enable debugging logs with the below configuration but it will only tell you that messages are being sent, you are not able to see whether they are received by the bridge.

  default: warning
    limitlessled: debug

I put a port into my config. See above.

Do you see the entity in Home Assistant?

Did you get it to work?
I have the same Wifi bridge with the exact same software version and was also struggling with the Hass config.
Verified port and ip address.

A version 6 in the configuration.yaml kept resulting in “Connection Refused” message in the home-assistant.log

I had tried several other versions and enabled debugging.

The cause of my problem was the setting on the MiLight controller, it was set to UDP 8899 (homebridge can only use UDP) while the Home-Assistant tries to connect using TCP (and could not connect, causing the connection refused message)
I changed the Network Connection to: TCP-Server and the port back to 5987 and use RGBWW for the type of my lights.
Now everything works!

Hope it helps