Mobile App and Nabu Casa

EDIT: If you are here for the first time please look further down for the latest summary of my problem:

I’m trying Nabu Casa.
I have the Mobile App (Android) which works perfectly on my local network.

In the app configuration I can add the new Nabu Casa remote URL and all works well when I am off my local WiFi but I can’t add my ‘Internal Connection URL’ as it is greyed out.

Therefore I have no local access (unless I turn WiFi off on my phone).

Any hints please?

I believe you have to select Home Network WiFi SSID(s) to select Internal Connection URL.

1 Like

I can verify that setting SSID and then local IP address worked for me on my android phone.

Thanks. Yes I tried that and it worked in that it allowed me to add the Internal URL.

HOWEVER, I still can’t get both external and internal access to work at the same time. I don’t know if it is an issue with the app, Nabu Casa or something else…

If I have it as in the following picture it works fine on my home network. If I put my Nabu Casa address in as the Home Assistant URL it works fine (mostly - see below) outside my network.

If I then define my SSID and add an internal connection URL it doesn’t work locally.

I have tried deleting the app cache and data, uninstalling and reinstalling but that didn’t work either, in fact very often the app fails to start properly. I see the HA logo with the Loading data message, Then the screen clears to the HA blue top bar with a non-functioning hamburger menu, the ‘loading circle’ spins for while and then the app crashes.

But it is not even that simple because if I navigate to the Nabu Casa URL in a browser it often doesn’t work either.

I assume for Nabu Casa there is some kind of support as it is a paid service but I wonder if it is something simple because I doubt if it is usually this difficult to set up.

I think he meant like this…

I don’t use nabu casa, but I would expect it to be the same, just with the nabu casa url in the top one instead of a dynamic dns service.

Mine works both externally and internally using this process. I’m not sure why yours isn’t.

I don’t know what is going on but after several reinstalls and reconfigures of the app I can finally connect locally with these settings. However if I turn WiFi off on my phone it won’t connect externally, the wheel spins and then the app crashes.

Neither can I connect from my phone in a browser using the Nabu Casa URL.


I don’t really want to either but I still haven’t worked up the courage open a port in my router. It goes against the grain for me to choose to rely on a cloud service even if it is one I trust as much as HA.

My problem is that I understand enough to set up external access but not enough to know if I’ve done it safely. (But the latest post on this thread is interesting DuckDNS - It’s not just me - it’s you!)

EDIT: I spoke too soon. After closing the app I can’t now open it on the local network either.

I think there is an issue with the app…

I’ve realised I had this post poorly tagged so hopefully now someone who knows/develops the Android app will see this. The first post has been edited to direct them to a new summary of the issue below…

I have had the mobile app (Android) working perfectly for some time now on my local network but I have decided to try Nabu Casa.

But, after several reinstalls and reconfigures of the app I still cannot get it to work.

I have the following configuration…


…but the app starts, shows the HA logo and ‘Loading Data’ before going to a white screen with a plain header bar with a non functional hamburger menu but the wheel spins for a few seconds before the app crashes.

This happens both on WiFi and off it.

The only way to get the app to start again is to clear the cache and data and start again from the beginning.

What do I have wrong?
Is it the app?
Is it Nabu Casa?
Is it something else?

what do you mean the app crashes? do you just get a cannot connect message or is it actually crashing?

Hard to tell based on your network setup what I can tell you is plenty of folks have the exact same setup you do in the app with a nabu casa URL and using the wifi connection part to connect locally. Based on that alone probably something in your network. Tough to tell whats going on.

Does the app have location permission? Is location and GPS enabled on the device? Both of these are required to get the connected SSID.

You can find more networking tips here:

Yes, it actually crashes. I briefly get the HA Logo and ‘Loading Data’ followed by a blank screen* with the coloured header bar and a non functional hamburger menu. The wheel spins for a few seconds, stops briefly and spins again briefly before crashing and returning me to the phone’s home page.

*Interestingly the colour scheme changes to match the theme of the user.

I’m more than happy to help providing any further info (logs etc.) if that is useful.

Yes, and yes. The app worked perfectly for many weeks before I changed to try and use Nabu Casa.

Some more info that might help.

If I turn off Remote UI and try to connect with the app I get this, so it is clearly trying…

When I turn on the Remote UI it crashes as described above.

I currently have a very standard network with no non-default firewall rules in place.

Please get us the crash logs: after reproducing the crash. Then open an issue on github with the log.

Try logging into Nabu Casa with a browser on your phone. For some reason that has allowed me to login with the Android app.

Hopefully they get us the crash logs beforehand so we can try to fix the actual issue :wink:

Sorry for taking so long to respond…

I looked at this and it seems that I need to install a lot of extra software on my PC and phone for this. I’ll need to look into exactly what I am allowing before I do this. It seems convoluted though…

I can’t get to my Nabu Casa URL from my phone either.

Maybe it’s a Nabu Casa issue?

Just go to Nabu Casa, not your URL, in Chrome on your phone and log in to the website.

I’ve needed to do that from time to time.

You should use your URL, actually. The remote portal is only meant for temporary one time connections. Toggling it on from within your own server settings and leaving it on is the persistent way.

1 Like


What I was suggesting was just to log in at Nabu Casa. I’ve had to do that a few times because the mobile app wouldn’t connect. After just logging in to Nabu Casa I was able to connect using the mobile app.


I have no idea what order of events did it but today after more fiddling around and trying to log in using all the various methods I seem to have finally got it working.

It does seem that something somewhere is getting its knickers in a twist and that Mike has a point in that logging in through the various ways in a certain order seems to clear the ‘blockage’.

I can offer no help in troubleshooting it though I’m afraid because I really don’t remember what order I did things to make it work (for now?)

On the plus side, the app is excellent (but I knew that already from using it locally :wink: )

Just one small further question…
Is it possible to confirm the app is using the local URL when on the home WiFi without turning off mobile data?