Mosquitto 5.1.1add-on is broken

I am using hassos based Home Assistant amd64 version (virtual machine) and I have also noticed strange issues with Mosquito 5.1.1. The responses became some kind of slow, although there are no error messages in the Mosquitto logs. For example I have two Mqtt based wifi lights that combined into a group within Home Assistant and I am controlling this group through Zigbee2Mqtt button. Before this version, clicking on the button was toggling both lights at the same time, but now there is a delay between first light and the second light. This is only an example, everything became so slow… Going back to version 5.1 returned everything to normal again.

I am on the same boat. Using official hassos on a raspberry pi 4. Mosquito addon 5.1.1 results in slow response for my MQTT devices (specially shellies connected through shelly discovery script). Reverting back to 5.1 and everything was OK again…

Ha… I knew something is wrong. For last few weeks turning all lights in my house off at once by turning off a light group can take more than 5 seconds. I was thinking what happenned.
Interestingly, the operation might be quick if mqtt light being subject of the test is toggled prior to actual test

What is the way to downgrade? i was looking around but found nothing useful.

I had a couple of weeks old full home assistant backup so I selected only the mosquito addon when restoring from the supervisor/snapshot menu. Worked perfectly.

Check also this comment on the github issue that explains a way to rollback without backup.


Thank you for response and idea that it can be restored from backup. It’s most easiest way.

BTW 2 weeks passed and this broken version hasn’t been rolled back from repository.
What’s wrong?

I think I have a path to overcome the problem. I used the following procedure to get 5.1.1 working for me.

  1. Take a snapshot (complete) from your current home assistant instance
  2. go to the mosquitto add-on page and copy your configuration into an text editor for later use.
  3. deinstall the mosquitto add-on
  4. install mosquitto 5.1.1 and copy the configuration back from the editor
  5. start the add-on

This solved the problem in my installation

Could you please post that on the github issue too?

already done. Infact I posted it first on github

1 Like

I can’t feel it helped me - the 5.1.1 version is still much slower than 5.1 for me. Reverted back to 5.1.

I just cannot understand that could possible be the problem…

I experienced the same with 5.1.1 installed from scratch. No disconnections but everything seemed slower and got a lot of log messages “No ACK from MQTT server in 10”. Went back to 5.1 and working fine since.

Yeah this works! thank you

What works? You didn’t say who you were replying to.

@nickrout is there anything we can do to help track this problem? I have updated to latest home assistant version 2021.04.3 and thought about upgrading mosquitto add-on to 5.1.1. As soon as I did the “No ACK from MQTT server” messages came back.

1 Like

Post to the github issue, with logs and full details of what system you are running.

I noticed MQTT is now on 6.0.1.I figure I would update from 5.1 and see if there would be no issue. While HA seems to be working as it should. I noticed in t he supervisor log of this warning. Anyone knows how to fix it?

MQTT config:

logins: []
  active: true
  folder: mosquitto
certfile: fullchain.pem
keyfile: privkey.pem
require_certificate: false
anonymous: false

The warning is caused by the update to the mosquitto addon, it no longer supports anonymous, and you should remove that option.

1 Like

ok. Thanks for the heads up.

I changed my post as I though you were talking about another error. Remove anonymous: false