MotionEye, home assistant, camera motion, automation

Been a long time since I made this post. I am more into HA than ever and you guys contributed to that. Thank you very much.

I have one more question for you guys.
I changed my setup to use SSL, and the webhook is not working. I changed my webhook to use https but the script is not triggering. The obvious reason (i am just guessing here) is that motioneye cant accept the self singed certificate.
Any thoughts on this?

Are you using the motioneye addon? Can’t get mine to publish mqtt

MQTT is not supported by default…apparently he has custom setup with mqtt

Stupid question: how did u guys configure the motion in motioneyeos… For me it triggers motion even if no motion is detected … I also use the mask filter to reduce fails.

but still getting fails motion detections.

Go with a reeeeaaalllyyyy low frame change threshold I have it set at 0.1%.

Here is a screen from mine.
3

Hi, I’ve a problem with the add-on, when I click on web UI, it doesn’t load the page…
What can I get to do, please¿

Thank you so much!

check your ports are open on the router (8765)

Otherwise, when you click on “open web ui” replace your public hassio hostname with the local ip address of your hassio instance

Alright guys, I need your help once again. With HA constantly updating to new things, it is now the time to update my webhook command. That means that I no longer have to use api_password as part of my command. I must now use long-lived tokens.
I created my token and I changed this:

https://my.ddns.domain:port/api/services/script/cam1motion?api_password=mypassword

and tried different things such as ‘access token’, ‘token’, auth and I cant remember what else.
Can you help me? How to I use the access token to send a webhook at HA?
@anderstbl You helped me before, any chance to do it again? :smiley:

1 Like

Had the same issue.
I was playing around and found a solution that works for me.
You might try following web hook URL (method Post (query)):

http://127.0.0.1:8123/api/services/script/yourscript?access_token+=PUT_YOUR_TOKEN_HERE

Edit: After update to 0.83.3 it’s not working anymore.

gents, if you’re not using docker you can always use the mqtt method as posted here May 3

If you are using docker, you can install the mosquitto-client manually

The most annoying for me is the motion itself in motioneyeos. It triggers false motion. How did u configure motioneyeos?

@thundergreen
As I mentioned in an earlier post, you have to configure your threshold really low. I have it at 0.1%.
If you notice no motion is detected, raise the slider by 0.1% each time to see if it makes any difference. I never had a single false positive for about a year now, even with light changing (sun-clouds) situations.

Motioneye is really accurate as long as you have the correct settings, which are (at my opinion) very hard to get at first, but once you understand what you have to do, they are pretty easy.

@itom
I tried your solution, but I had no success:

https://127.0.0.1:8123/api/services/script/stairsmotion?access_token+=mytoken

Just to be sure:
I created the longlive token in HA: Went to user profile and clicked on the bottom of the page, right?

3

Ignore me, I just noticed you posted them above in the thread, should have read up, instead of starting at the top :smiley:

This is right…

So, since your solution didnt work, could this be related with the base_url of my configuration.yaml? I have it pointing at my dyndns.

base_url: https://mydyndns.com:myport

I cant figure out why this is not working.

Sorry argykaraz, I have to confirm that my approach isn’t working (anymore?).
I hope someone finds a solution to make it work with token.

has anybody managed to get this to work? all the above does nothing.

@argykaraz and me managed to make it work with “command” instead of web hook.
This goes into motioneye command:

curl -X POST -H "Authorization: Bearer TOKEN" -H "Content-Type: application/json" -d '{"entity_id": "script.yourscript"}'  http://yourip:8123/api/services/script/turn_on
3 Likes

This no longer works since release 0.84, can anybody help?

I get a

401: Unauthorized

returned

HI John,
In your node red flow the exec node does not find the image file(debug) shows “” )and so the msg.payload is not populated. Does this flow work with Hassio?