Move data disk

I have HA up and running in Debian 12 on my Orange Pi 5 Plus. No obvious problems, but before I get too deep into the configuration, I want to MOVE DATA DISK to an NVMe m.2 that is installed specifically for that.

I have tried in the GUI and also the command line (as root), but in each case it simply results in:-

“Error: ‘DataDisk.migrate_disk’ blocked from execution, no Home Assistant OS available”

No it is indeed not HAOS, but the ha command otherwise runs fine. What is it that Debian apparently lacks and how can I get around this? I could manually move files but not sure exactly what should be moved nor how to then tell HA to use the different location since the command to do that is exactly what is failing.

A bit of a stumbling block so could do with some advice on how to overcome/get around this issue.


Details of the partitions moved on my own HAOS install in a Yellow can be found here:

The thing that Debian is lacking is basically support and testing by the Nabu Casa team and community.

If this helps, :heart: this post!

From what I can see, HA’s structure in a Debian supervised install seems quite different from HAOS on e.g. a Yellow. I don’t seem to have most of those mounts, or anything equivalent.

Without knowing how HA works with the filesystem, I’m kinda in the dark. However it is surprising that while such an install is in theory ‘supported’, it fails at this basic hurdle. Wouldn’t be so bad if somewhere there were instructions as to what needs to be done manually to get around the fact that the move data disk routine doesn’t work on Debian.

Or does it? I’m not seeing a huge number of posts about such a failure and surely there must be a lot of Debian based users out there. Are they all unable to move their data disk? Or if they have, how?

This is still an issue I want to resolve. HA on Debian is supposed to be an acceptable (supported) configuration, but this failure to move the data disk is a big problem.

I could perform all steps manually, if I knew what the steps were and HAOS is apparently significantly different.

There’s likely to be very little or no data to actually move. So should be just a question of pointing HA at the different location.

Is there no way to actually get support for a tissue like this?

I ran HA Supervised initially and spent a lot of time learning different aspects of it. Supervised is supported but I switched to Home Assistant OS (HAOS) to give me much more of what I wanted.

The Installing Home Assistant Supervised using Debian 12 guide has a number of people asking the same question. There might be clues in there (I just searched for “mount” in the topic but you might have better search terms/luck). Search for “SSD”

My supervised installations on Pi4 and Pi2 boot from SD, but run from HDD. But you have to do it with Debian tools, HA won’t help with it.

1 Like

I could indeed use Debian tools, but I need to know what I have to use those Debian tools to do and I am unable to find that information anywhere.