Moving HAOS to a different hardware platform

I currently have HAOS running on a Raspberry Pi 3B+ with microSD.

I’m considering moving it to something a little faster, for example, my Odroid N2+.

Is there a way to do this ? And if so, what would be the best way ?

As a test, I tried setting up a Virtualbox VM on my PC. Once it booted up, I opened a browser on the host, and logged in to its web UI (at http://vmip:8123). I selected the link “Alternatively you can restore from a previous backup”. I then selected a TAR backup from my HAOS Pi 3B+ installation.
But I got a pop-up stating “Unsupported file format - Please choose a Home Assistant backup file (.tar)”. I suspect there must be more to it than this.

I have never tested the restore process, even on the same hardware platform, though, something that’s still on my to-do list.

Backup files are compatible between install methods. Don’t use a password on your backup. And obviously restored addons wont work unless you use an install method on the new system that supports them.

I’m not using a password on the backup.

I am using backup add-ons for Google drive and Samba. Those generate TAR backup files. The restore function in HAOS in the VM didn’t accept those files, though. I guess the content must be different than standard HAOS backups.

What’s the procedure for changing hardware platform ?

If a backup is done locally through HAOS onto the SD card on the Pi3B, I would need to get the backup file off to another location, so I can restore it onto the new platform. I don’t believe I can get the file off HAOS without some sort of add-on.

And I’m not certain what you mean by “install method”, either.


Are you trying to restore the individual tar files inside the main tar file?

Don’t do that. Use the overall tar file. Read this:

No, I’m not trying to do that. I’m only trying to restore the top-level tar file.

Steps I followed on my Pi 3B+.

  1. Went to Settings / System / Backups
  2. Selected “create backup”
  3. Waited about a half hour (!) for the backup to be created
  4. Once complete, I clicked the vertical … menu, and “download backup” to get the file onto my Windows PC
  5. On my PC, fired up the Virtualbox VM running HAOS (Linux)
  6. Logged into http://:8123 in my browser
  7. Clicked “Alternatively you can restore from a previous backup”
  8. Selected the tar backup file I downloaded in step 4
  9. I got a pop-up stating “Unsupported file format - Please choose a Home Assistant backup file (.tar)”.
    Is the HAOS backup not compatible between different hardware platforms ?

FYI, I’m using Core 2022.5.4 on the Pi . HAOS 7.6 Supervisor 2022.05.1 .

The VDI image I downloaded is for HAOS 7.6 .

It has nothing to do with the hardware.

Try using a dummy account to set up the new system (it will be overwritten in a moment).

Install the SAMBA or SSH addon and upload the backup.

Try restoring from Settings > System > Backups.

Yes - use the method that Tom suggested. There is a bug (which I thought was fixed) that prevents restoring backups over a certain size during install.

I always need to install the base system, install SAMBA, copy over the backup then restore from local.

1 Like

Thanks. Do you have a reference to that bug ? And what is the size limit ? My backup is 715 MB.



I tried with a dummy account. Then went to Settings → Systems → Backups . Clicked the vertical … menu and “upload backup”. I got the exact same problem as when using “Alternatively you can restore from a previous backup”. The tar file (which was generated by “Create backup” under Settings → Systems → Backups ) was not accepted. Same error I reported already multiple times : " “Unsupported file format - Please choose a Home Assistant backup file (.tar)”.

Is there no way to restore the backup without an add-on ?

I had issues with the Samba add-on related to the fact that my Windows username has a space in it, and the add-on doesn’t support it. Maybe I’ll give it another shot.

I will look at how to upload the backup with the ssh add-on.

Use WinSCP. It’s free.

Thanks. WinSCP worked. After setting up the SSH add-on, I was able to upload the backup. Once uploaded, I was able to restore it.

It seems that the “Upload backup” functionality from the browser is broken.
Is there a fix for this ? I’m on the latest HAOS release available to download.

The VM on which I’m trying to do the “upload backup” is :

Home Assistant Supervisor 2022.05.1

Home Assistant OS 7.6

Kernel version 5.10.108

Agent version 1.2.1

Log an issue on Github if it’s not working - it’s a long time since I had to do a restore so I can’t comment.

Opened Restore fails with "unsupported file format" · Issue #3639 · home-assistant/supervisor · GitHub

1 Like

Still not working in 2022.9.x. Uploading a backup over certain size during onboarding just silently fails without any indication, whisking the user to a “create new account” screen.

Having the same issue here. HOWEVER, ill save you a trip down to github: use CHROME instead of Firefox (workaround)

Sounds ridiculous, but - when I went from an HA Blue to a NUC, I decided to just re-do everything from scratch. I had lots of odd errors and warnings and nonsense on my old system, so I wanted a nice clean, new system. It took me probably 30-40 hours worth of work. The way I saw it, no need to import old problems into a new system.

I know it’s not what you asked, but just wanted to throw this out there as something to consider.