MQTT for BOTH Ring and Solar Assistant Clashing? Just want to arm/disarm but nothing is working

Hello, I’ve had Solar Assistant working over MQTT via Mosquitto Broker for a few months, and I am now trying to add in my Ring Alarm System because it can’t be found by the normal Ring integration. I just need to automate arming and disarming the Ring alarm upon certain events. I tried Z-Wave to connect the key panel, but I’ve been unsuccessful. I can see all of my sensors through Z-Wave using Scrypted, but it can’t see the key panel.

I resorted to the next option which was MQTT. The Ring/MQTT Addon is up and running, and the logs look right. However, I can’t see the traffic on the broker. It appears that the Solar Assistant MQTT traffic is taking priority somehow. Maybe I just need some additional setup.

Willing to donate for some help!! Thanks!!

Maybe start by telling how you set things up.

MQTT does not do that, it just passes messages.

What MQTT broker did you use for that ? Did you install a second broker ?

I’m only using the Mosquitto Broker and from what I read, that is what is used for both the Ring MQTT and the Solar Assistant.

It appears that this guy had the same problem (trying to run both Solar Assistant and the “Ring-MQTT with Video Streaming” addon). It looks like that thread is now stale. His solution did not work for me, or I’m not understanding his solution well.

That for sure is a solution. Do you have logs from the Mosquitto add-on ?

I mean, the Ring/MQTT add on is definitely working. I’m pasting the “Ring-MQTT with Video Streaming” addon log below, and below that you can see the MQTT reading the Solar Assistant. I just can’t see the Ring MQTT anywhere else to use it. I only see activity in the Ring-MQTT with Video Streaming Log. It doesn’t show up anywhere in the MQTT Integration like the Solar Assistant info does.

Restarted it and this comes up first.

Ok I re-configured using the full username, password, and IP address for the host, and it all runs great again in the Log, but this time using the local user for the username etc.

However, the MQTT integration can only input 1 IP address in the MQTT settings when I configure it, and it’s setup to look at the Solar Assistant IP address. How can it also read info coming from the Ring IP address?

Seems to be reading the Ring items just fine, I just can’t get it on the MQTT to view it. I am sure that I just don’t understand it and need someone to just help me understand.

Do I need to add another file similar to this one like I did for Solar Assistant?


Why don’t you let ring simply use the Solar Assistant MQTT ? Give it the Solar Assistant IP, username and password.

I can’t believe it was that easy… It’s working perfectly now. Thanks!!