My steps to success for on Intel NUC

Thanks, Mark and David, I am going to try it this weekend.
I try not to mess with things on the evenings because for some reason things don’t work out and I end up with a non working home automation.

I have a NUC8i5BEH3 and have been running hassio for 7 months now. Its been using the 240Gb M.2 drive but I have space for a 2Tb HDD as well so thinking of adding that.

I want to use the NUC for other things including development and programming.

Im running Proxmox with hassio at the moment.

When I’ve installed the drive I will be wiping everything clean and starting a fresh start.

With 2 drives installed should I stick with Proxmox or set up docker and use Portainer?

Anyone done a NUC install direct onto NVMe using the gunzip -c /media/sdc1/hassos_intel-nuc-2.12.img.gz | dd of=/dev/sda bs=4M conv=fsync method as it’s not working for me with the 2.12 GZ file?

Boot gets stuck on clocksource: switched to clocksource tsc.

Anyone seen that?

UPDATE: Tried using a M.2 SATA drive and the dd command works and the HA install completes successfully. Also tried the Proxmox install method on my NVMe M.2 SSD and that works so it appears to be a quirk with the Hassio installer and NVMe? Trying to now borrow a NVMe M.2 external enclosure to see if the Etcher method is more successful.

I have the same issue with Etcher method.

Buggar! I just purchased a PCIe adapter card today in the hope of trying the Etcher method tomorrow. Maybe it’s an issue with the current image? Logged an issue.

I can confirm this today. I used Etcher with the NVMe inserted in a PCIe card and although the write succeeds and the partitions are created, the boot still fails at clocksource: switched to clocksource tsc

Hi there,

just a short question, I successfully managed to dd the hassos intel NUC image on my SSD, and it runs just fine, but what happens to the rest of the unused SSD space the image is not using?


Doesn’t it expand to the available disk size?

What is the easiest way to check on that?

Login using SSH and run df -h

First line (overlay) should show you total formatted disk size, spaced used and space available. My system below has a 30GB SSD in it.

Thanks, I’ll try this!

Anyone using Hassio on Proxmox with the MariaDB HA add-on? I’ve migrated to a Proxmox based i3 NUC this evening (using wipe and restore) and my recorder and other services relying on MariaDB have died. Figure it’s something to do with the host below so if anyone has a working config, that would be appreciated.

  "databases": [
  "logins": [
      "username": "hass",
      "host": "%",
      "password": "mysglpassword"
  "rights": [
      "username": "hass",
      "host": "%",
      "database": "hassosdb",
      "grant": "ALL PRIVILEGES ON"

Apparently there is a bug. You need to stop MariaDB before you do a migration backup. I did not. Reinstalled MDB with same settings, all working again.

This method do not works for me!
I’ve a Intel NUC8i3BEH if I use Etcher to put Hassio image “assos_intel-nuc-3.7.img” to my Sandisk usb dongle it do not start at boot and show me:

HassOS boot Menu:

  1. Autoboot
  2. Boot System 0
  3. Boot System 1
  4. Shell

If I put it directly in my SSD disk with etcher without using Usb stick it works fine.

1 Like

I wonder if i can use the nuc image to install on a i7 920 machine that i have around… Can i? Or i need the virtual machine method?

Hi guys,

I am following this instruction, booted my NUC using Parted Magic, but after I run:

gunzip -c /media/sdc1/hassos_intel-nuc-3.8.img.gz | dd of=/dev/sda bs=4M conv=fsync

It says:
gzip: /media/sdc1/hassos_intel-nuc-3.8.img.gz: not in gzip format

Any ideas?


Redownloaded the file again and looks better now. Previously even via gui it din’t want to open the archive, so maybe it was corrupted or not fully downloaded

Hi, It might be too late for some, but I have really been struggling with this and finally succeeded. Just posting this in case somebody else faces the same problem, with a bit of luck they can find it all (or at least most of it) here. Note that it is not a detailed guide as I tried so many things, but it should give the overall gist of it.

I am new to both Hassio/OS and Linux so had to go through a lot of posts. This one somehow led me on the right track so I am posting here. I, like others did not want to run it on a linux/docker (yes, I know, many arguments for doing that, but I did not want to deal with that).

First problem was that most posts are about loading the hassio image to SD, which I do not have, some then resort to burning it directly to the SSD/HDD which I also could not do. So wanted to do it from USB. As others have encountered next problem was to get it to boot from USB, played around with bios settings, a lot. The main thing is to change USB from legacy to UEIF. I believe not everybody has to do that, but I had.

Once I got it to boot, the third problem was that the Hass installation got stuck, as other have, on the menu with autoboot, system 0, system 1, shell options. Neither of which worked.

Saw somewhere the description of a Linux Live distribution, where you run Linux from your USB. Tried that. Worked fine. Then some were talking about having the hass image on a nas server, a second USB and god knows what. Sounded very complicated. I put the gz file on the same USB as the Linux live. Then followed xbmcnut’s description (see post above): gunzip -c /home/ubuntu/Downloads/hassos_intel-nuc-2.12.img.gz | sudo dd of=/dev/sda

Problem four: As I was new to Linux I had no idea how/where to enter the above command. Turns out it is in a terminal window which you can open by pressing Ctrl + Alt + T. Probably obvious to Linux people, but not to me.

xmbcnut’s post might actually be what gave me the clue as he writes, offhandedly sort of, that BerryClaim “had downloaded the GZ using a live Ubuntu install instead”. And I had seen somewhere else that a live linux was running it from USB.

At some point during the above I had to put the USB back to legacy, not sure when that was, so play around with it.

So a big thanks to xmbcnut and the many others whose posts allowed me to piece this together.


Hi @eriktoft,

Can you expand on this, please?
I’ve been trying to install Proxmox on my NUC8i5 from a USB stick with the Proxmox iso image, prepared using Etcher, and getting an error when it starts to boot:

“Image Authorization Fail, System cannot boot to this device due to Security Violation.”

When you mention ‘putting the USB back to legacy’, how did you do that? Is it something you did to the USB stick, or something in the bios during the boot process?
This might just be the bit I’m missing!

Yes, it was changing the USB settings in bios, I could not boot from bios without changing it back. But it was a different error message, I think, I got, so perhaps you need to change some security settings also in bios. Trial and error, a lot, did it for me:-)

Thanks for the information, that helps. I’ll give it another try soon.