My steps to success for Hass.io on Intel NUC

In 11. you write that you wait 30 mins for download and updates. Are there any output written to the screen during the 30 mins wait?

I’m asking because my NUC stops booting (no output to screen) after a few seconds. Excatly the same problem as Blair_Pollard had in this thread.

Ya, I gotta ask the same thing…I’m doing this in a virtual machine, and on a pi.
On the VM with no addon devices, it gets to port 4, says its starting version 3.2.9, and then sits there forever.
With the pi it gets the last “usb” device (which is the built in BT I think) the it sits there and every few minutes spams IPv6 link is not ready, power save enabled.

With the pi, it might be a bad powersupply, or a bad SD card…but I have no clue what it is for the VM (I’ve also tried as a SATA, don’t really want to try as a scsii or ide unless someone says to)

Mine is on a NUC - no VM, and stops at the same place, the Bluetooth drivers. No amount of waiting will make it go any further,

OK, I figured it out…atleast for me…I had an internal DNS server that wasn’t running, the Hassio apparently doesnt lookup secondary DNSs that aren’t listed in its own files.

example:
hassio is on automatic
custom internal DNS 192.168.5.95 -> this is set on home router
standard DNS 8.8.8.8 -> this is set on cablemodem which router is plugged into
hassio will use the one set on the router but wont use the cablemodem one when the custom one fails (windows and ubuntu will both do this)

Which NUC do you have? And are you booting from a eMMC?

Edit: one more thing, I have noticed the NIC LEDs are both off. Is that the same for you?

Sorry, didn’t look. I have now successfully installed using Supervised install on Debian OS, which went without a hitch.

No worries. I found out that my problem is similar to HassOS Image not working on NUC 2TB SSD

Still no solution though.

Actually I didnt really pay that much attention. I just figured I would leave it for 20mins since the official installation instructions said so. I was out doing other things in the mean time and when I got back everythin was up and running!

I have just installed a m2 SSD in my NUC, and now it works. eMMC is apparently not supported.

So you switched from NVMe?

I tried resetting everything up and actually ended up with the same problem you guys have been reporting all along.

I tried all different things and finally I got hassio to start-up again. I really don’t know what the deal-breaker was.

Final setup:

  1. Linux live
  2. download the latest hassio NUC image
  3. balenaetcher to flash directly to NVMe drive
  4. in bios disable WLAN
  5. also I removed my manual DHCP-post in my router
  6. Hassio booted up perfectly

I have no idea why or what solved it. I am just happy I got it running again…

And it just worked

1 Like
  1. in bios disable WLAN

This is the only bit I didn’t try - and may be relevant as it was wireless / bluetooth drivers where it was stopping.

At the moment I am still with my HA on a Pi4 with SD card, but now I ordered:

- Intel NUC10i3FNK
- WD SN550 250GB M.2 PCIe NVME SSD
- 1 x HyperX Impact DDR4 HX426S15IB2/16 2666MHz CL15 SODIMM 16GB

I hope that after the NUC-image-file has been transferred to the SSD, I can easily import my backup from the Pi and that everything will work.

I have an adapter USB to M.2-NVME-PCIe (if I can only flash the SSD this way?)

Are there any pitfalls that could occur? If anyone says that there could be problems with the components, let them shout out loud now. :smile:

Okay, here are the steps that were necessary, briefly summarized again:

  1. Install memory in the NUC (hard disk not yet needed, but without memory the NUC did not start). HDMI cable connected to monitor and keyboard plugged in.

  2. downloaded the current BIOS (“F7-BIOS”) and entered the BIOS-Update by pressing the F7 key during startup Select the file from USB-Stick

  3. Set in BIOS: secure boot OFF (otherwise the NUC will not boot from the official image from the hard disk).

  4. Under Power tap > Secondary Power Setting > After Power Fails: activate “power on” (otherwise the NUC will not restart automatically after power failure).

  5. Disk image flashed to the M.2-SSD with Balea Etcher (under MacOS) I used a USB adapter and the Mac recognized the SSD as a drive.

  6. Install the SSD in the NUC, removed HDMI and Keyboard, start the thing.

  7. Home Assistant boots up, and was accessible via the browser. The brand new function (0.116) to import previously created backups directly in the setup screen did not work (“Bad Gateway 502” or so). So create a user, install Samba and copy the backup to the /backup folder of the HA installation. Then I could import it.

  8. Everything was back again! Only the database and the logfile I deleted so that they would be recreated (there were problems with saving the log entries).

Jorgensen & for those struggling with the ‘wait 30 mins thing’
Turns out there is a step in the process missing. As stolen from oscylo

Applies to NVMe disks (unsure if it also applies to M.2 disks)

  1. Make sure bios is updated to latest on NUC, Use F2 upon boot to explore bios and see what version you are on. Go to Intel site for your NUC version and download latest bios. Extract the files to a clean usb root directory. Put USB in the NUC and press F7 in the boot up and follow instructions. Very important to wait until this is complete and the computer reboots itself. Afterwards go into bios again (F2). Do Factory default (F9) and then you must go into advanced --> boot secure --> disable secure boot. Press F10 to save and exit.
  2. Download latest official release (v 4.12).
  3. Unpack the .gz file to a clean usb so only the .img file is in the root (note usb had to be NTFS for me due to large size).
  4. Download Ubuntu Desktop (right now Ubuntu 20.04.1 LTS). It will be a .iso file
  5. Make a bootable USB from this file - Follow steps in oscylo’s post
  6. Put the bootable ubuntu usb and the USB with the hassio in the NUC and fire it up. Ubuntu will load, choose Try Ubuntu option and you will get to the desktop.
  7. Press Ctrl + Alt + T to open up a terminal window. Type: gnome-disks press enter
    • This didn’t work for me. I just selected the menu option (9 dots) and clicked on terminal
  8. Missing Step Click on the disk and FORMAT it first. Make sure you select No Partition during the process
  9. Click on your NVMe disk. Then click on the “settings” icon (looks like gears) and choose “Restore partition image”.
  10. I can’t remember exactly how it looked, but a new window will open and you will have to choose the source. Thus open the USB containing the hassio and choose the .img file and press ok. The image will be loaded onto the NVMe-drive.
  11. Shut down the NUC. Remove both USBs.
  12. Start the NUC again. Hassio should load. I let mine be for 30 mins to allow for everything to download/update. Note I use ethernet and not WIFI, there might be an additional step needed.
    UPDATE: on my second install I had to disable WIFI within bios before it would start.
  13. Go to http://homeassistant.local:8123 to see that it’s up and running.

Hope this helps someone as noob as me in regards to linux :slight_smile:

Ordered a NUC BXNUC10I5FNK2 Core i5-10210U now with an evo 970 plus nvme.
Did anyone have any success with WIFI yet or knows if it will be supported some time in the future.
The wifi module is not in an extra socket, hence not swappable i guess, to an older maybe supported one?

I moved from a VM to a dedicated NUC build over the last month. In the process I finally killed off SmartThings. In my testing I would absolutely agree with the core Home Assistant team by staying away from wifi for this solution. I’m on a gen 3 i5 NUC that just screams now! This is a 100% headless solution which sits in a closet. If you run HassOS natively on the NUC you will have an awesome solution!!

This sounds like it will be very useful.

I’m planning to migrate from my existing Pi to a NUC and was hoping it would be a simple case of installing it and importing a snapshot at install time, like it is with the Pi setup.

It sounds like this was a naive assumption and that all of the steps you outlined above need to be followed? If I do, will I end up with an exact clone of my existing system, just running on the NUC instead? Do you still get all of the useful features of HA like HACS?

For me in Ubuntu 20.04, the “settings” icon was 3 vertical dots in the top right of the window. Do not use the gear icon that’s near the partition map, as it won’t work.

I was able to use an exact clone after I started up the NUC and restored the system from a recent backup from my previous RPi system.

Yes! It’s exactly like an RPi installation, but runs on super beefy hardware.

2 Likes

I completely agree. In-fact the NUC has better USB support so even the USB Z-Wave and ZigBee radios I use seem to work better!! This is by far my favorite setup!!

I want to add my experience here in doing the NUC install.

I was unable to get Home Assistant OS installed on my hardware(NUCi5) following the procedure above. I instead decided to take another approach.

The steps I took are as follows:

Download the Home Assistant OS NUC image on a USB drive(extract it so it is the bare image, with NTFS formatting and no folder structure)
Insert USB drive into the NUC.
Boot into Ubuntu Live(with a second USB flash drive)
Download etcher(on the live Ubuntu system)
Burn the Home Assistant OS image to the main m2 ssd in the NUC.
BOOT UP
Success

This seems to be simpler and easier to me.

6 Likes