NabuCasa doesn't support Garage doors?

How can I make it so my Google Home understands my “shelly switch” is actually a Garage door. So its not something I can “turn on, turn off” but instead “open and close”?

I’ve tried using a cover entity for that, but then google home just makes it look like a “unknown script” entitty.

I think you need to read up on device classes. I recently had a front gate (cover) that didn’t quite work as expected but after setting the device class properly the issue was resolved.

This is my current cover:

cover:
  - platform: template
    covers:
      garage_door: # https://www.home-assistant.io/integrations/cover.template
        device_class: garage
        friendly_name: "Garage Door"
        value_template: "{{ states('sensor.garage_door')|float > 0 }}"
        open_cover:
          service: switch.toggle
          data:
            entity_id: switch.shelly1_68c8eb
        close_cover:
          service: switch.toggle
          data:
            entity_id: switch.shelly1_68c8eb

but Google Home still doesn’t see it as a garage door it can open and close.

image

Thanks for the help. I think I’m using the right device_class already, garage

Strange…

I have a very similar setup and one difference I see is that you don’t have a stop_cover action. I don’t know if that is causing an issue.

I use Apple’s HomeKit and I can say that it works there so it could be a Google Home issue. Unfortunately, I don’t know much about that. Is it possible to delete and recreate the device (or let it rediscover it) on the Google side?

My config, just for comparison:

- platform: template
  covers:
    main_gate:
      friendly_name: "Main Gate"
      device_class: gate
      open_cover:
        service: switch.turn_on
        data:
          entity_id: switch.gate_remote
      close_cover:
        service: switch.turn_on
        data:
          entity_id: switch.gate_remote
      stop_cover:
        service: switch.turn_on
        data:
          entity_id: switch.gate_remote
      value_template: "{{ is_state('binary_sensor.gate_status', 'on') }}"
      icon_template: >-
        {% if is_state('binary_sensor.gate_status', 'on') %}
          mdi:gate-open
        {% else %}
          mdi:gate
        {% endif %}
- platform: template
  covers:
    lhs_garage_door:
      friendly_name: "LHS Garage Door"
      device_class: garage
      open_cover:
        service: switch.turn_on
        data:
          entity_id: switch.lhs_garage_door_remote
      close_cover:
        service: switch.turn_on
        data:
          entity_id: switch.lhs_garage_door_remote
      stop_cover:
        service: switch.turn_on
        data:
          entity_id: switch.lhs_garage_door_remote
      value_template: "{{ is_state('binary_sensor.lhs_garage_door_status', 'on') }}"
      icon_template: >-
        {% if is_state('binary_sensor.lhs_garage_door_status', 'on') %}
          mdi:garage-open
        {% else %}
          mdi:garage
        {% endif %}

That still didn’t help.

Just to confirm, you see something better than this when you open the device on Google Home?

Unfortunately, I don’t use Google Home so I don’t know what that linking entails.

My whole setup runs independently of any cloud provider – for security and maintainability reasons. There’s just one exception, which is NabuCasa.

I can’t think of anything else to help.

I’m spitballing here but let me try…

Is this the relevant integration? https://www.home-assistant.io/integrations/google_assistant/

Did you note this?

Certain devices are considered secure, including anything in the lock domain, alarm_control_panel domain and covers with device types door, garage or gate.

By default these cannot be opened by Google Assistant unless a secure_devices_pin is set up. To allow opening, set the secure_devices_pin to something and you will be prompted to speak the pin when opening the device. Closing or locking these devices does not require a pin.

Unfortunately, I don’t use Google Home so I don’t know what that linking entails.

That’s fine. Still thankful for the help.

I’m spitballing here but let me try…

That applies to devices that need the pin to unlock, which is not the case here. I can open and close the gate just fine.

Only issue is that google isn’t fully aware its a gate/door, so it keeps answering that is “running the garage door” as if its running a script to close it. Which is really just me being nitpick, but e.g. it prevents Google Home from showing the status of the gate.

Maybe try setting the device class to something else just to see if it updates and presents differently?

Still no luck :frowning: