Need help troubleshooting IFTTT setup


#1

Anyone have success linking IFTTT to Alarm.com?

I’m having issues linking Google Assistant to IFTTT to Home Assistant to Alarm.com service


How to Integrate Google Assistant and Home Assistant API using only IFTTT
#2

Google Assistant to IFTTT to Home Assistant to Alarm.com service Troubleshooting
I am having issues getting home assistant to respond to IFTTT request for Alarm.com. I am not a computer scientist nor do I have a degree in anything related. I am just someone who can read what I see on the internet and then implement (or lack there of). So I’ll run through all my steps.

  1. Install Hassbian, update hassbian via ethernet, ssh in via Putty, configure wifi

  2. Setup DuckDNS and Let’sEncrypt following BRUH’s Video

    • I am able to access my home assistant from outside my network via my https://XXXXXX.duckdns.org
      -Including adding lines to config file (see image below)
      -here is what my final port forwarding is set to (After following all other instructions in the video)
  3. Set up alarm.com and am able to control arm/disarm via home assistant

  4. Setup IFTTT so that I can ask Google Assitant via my Google Home Mini to activate my mini

    • This article was also part of my guideance
    • including addding the webhooks key to my configuration.yaml file
      Untitled2

    -Home Assistant services page for info to imput into IFTTT

    -IFTTT setup is below

  5. Ask my google home mini to “lock it up”
    - my google assistant replies yuppers but then my alarm doesn’t arm
    -using Postman to input the URL seen in the IFTTT image - I get a " 404: Not Found " error
    -when I put "https://XXXXXXX.duckdns.org/api/?api_password=myactualpassword into my browser I get " {“message”: “API running.”} "

Any help on troubleshooting or next steps would be appreciated? ( FYI: I will probably need more detailed instructions on how to troubleshoot)

I have already spent a few days reading through post/articles/blogs online about trying to figure this out and am so close to completing this project/challenge.

thanks!


#3

Anyone have any ideas?


#4

Kudos for the images and write up.

I’ve looked at this twice, and can’t seem to fault the steps.

The only thing that get’s my spidy-senses tingling is that port forwarding …

My problem is that you have port forwarded 8123, but clearly, in the screenshot of your dev panel, you are using 443.

  1. Either forward 443 externally to 443 internally, or
  2. Change your configration.yaml to say server_port: 8123

#5

thanks. I tried both suggestions and still no luck.


#6

hi,
in to IFTTT comand, iside box URL of Webhooks write: - http://xxxxxxxxxx.duckdns.org:8123/api/services/script/turn_on?api_password=yourpassword -
no more.